cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
749
Views
15
Helpful
8
Replies
Highlighted
Beginner

881-W and 3750-X

Hi,

 

I am setting up a lab using 3750-X and 881-W devices.

I want to setup the 3750-X as a L3 switch with the router to the internet.

 

The original plan is to:

no switch port on the switch port to the router

Enable IP Routing on the L3 Switch

Setup Default routes

IP Nat on router

 

My question is because the 881-W has a integrated L2 switch, how should/can I add the 881-W to the switch?

 

Thanks in advance!

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

On a side note, I think the 881-W has only one routed port, FastEthernet4. There is a GigabitEthernet port, but that is used for the connection to the embedded AP. So your config would look like below (I have not included any NAT statements). Don't forget to create Vlan 2 on the router...

 

881-W

 

interface FastEthernet0
description Downlink to 3750
switchport access vlan 2
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
description Link to ISP
ip address dhcp
duplex auto
speed auto
!
interface Vlan1
ip address 192.168.1.1 255.255.255.0
!
interface Vlan2
ip address 10.0.0.1 255.255.255.252
!
ip route 0.0.0.0 0.0.0.0 FastEthernet4 dhcp

 

3750

 

ip routing
!
interface GigabitEthernet0/1
description Uplink to 881-W
switchport mode access
switchport access vlan 2
!
interface Vlan2
ip address 10.0.0.2 255.255.255.252
!
ip route 0.0.0.0 0.0.0.0 10.0.0.1

View solution in original post

8 REPLIES 8
Highlighted
Beginner

IMG_20190709_192647.jpg

 

The lab

Highlighted

On a side note, I think the 881-W has only one routed port, FastEthernet4. There is a GigabitEthernet port, but that is used for the connection to the embedded AP. So your config would look like below (I have not included any NAT statements). Don't forget to create Vlan 2 on the router...

 

881-W

 

interface FastEthernet0
description Downlink to 3750
switchport access vlan 2
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
description Link to ISP
ip address dhcp
duplex auto
speed auto
!
interface Vlan1
ip address 192.168.1.1 255.255.255.0
!
interface Vlan2
ip address 10.0.0.1 255.255.255.252
!
ip route 0.0.0.0 0.0.0.0 FastEthernet4 dhcp

 

3750

 

ip routing
!
interface GigabitEthernet0/1
description Uplink to 881-W
switchport mode access
switchport access vlan 2
!
interface Vlan2
ip address 10.0.0.2 255.255.255.252
!
ip route 0.0.0.0 0.0.0.0 10.0.0.1

View solution in original post

Highlighted

Awesome, will have to try that tomorrow!
Highlighted

Those LAN ports on the Router are Layer 2 (L2) ports.

You can configure an interface Vlan for the vlan configured on the L2 port connecting to the Switch.

Btw, nice lab!

Highlighted

Thanks Hector, so then I would create a new Vlan give it an IP, assign it to lets say port 3 which is connected to the switch and no switch port that port and give it an IP?

 

Highlighted

If port 3 accepts the command no switchport (to make it Layer 3), you can then configure the IP address directly in the port and that is the IP address that will communicate with your Switch since to this interface you are connecting that Switch.

If 'no switchport' is rejected, the port is Layer 2 only and by default it belongs to vlan 1. You can modify the vlan association by running switchport access vlan X in the port configuration where X is any vlan number within the accepted range. In this case, interface vlan X is where you need to configure the IP address.

Highlighted
Beginner

I appreciate the help from both Hector and Greg. Because Greg provided a working config, i will mark his reply as the solution.

Highlighted

Do not worry about it!
Cheers.