10-21-2020 11:54 PM
hi,
dyndns unable to capture my public ip address for my remote desktop connection via my dynamic dns instead of ip
Below are some attempt I did,
1) setting shorter internal time
2) use afraid.org and noip.com
3) reload/restart router
4) debug ip ddns update -> "Dynamic DNS debugging is on"
5) show logging -> no attempt in ddns connection
6) if I update my public ip manually in dyndns, i can establish the connection using avixxx.xxxxxx.xx
************************************************************************************************************
Current configuration : 2747 bytes
!
! Last configuration change at 13:58:52 UTC Thu Oct 22 2020 by admin
!
version 15.8
service timestamps debug datetime msec
service timestamps log datetime localtime
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
enable secret 5
!
no aaa new-model
memory-size iomem 25
clock timezone UTC 8 0
!
!
!
ip dhcp excluded-address 192.168.2.1 192.168.2.50
!
ip dhcp pool pool1
import all
network 192.168.2.0 255.255.255.0
dns-server 8.8.8.8
default-router 192.168.2.1
!
!
!
ip domain lookup source-interface GigabitEthernet5
ip domain name axxxxxx.xxxxxx.org
ip name-server 8.8.8.8
ip name-server 8.8.4.4
ip ddns update method dyndns
HTTP
add https://usernamexxx:passwordxxx@members.dyndns.org/nic/update?system=dyndns&hostname=<h>&myip=<a>
interval maximum 1 0 0 0
interval minimum 0 0 1 0
!
ip cef
no ipv6 cef
multilink bundle-name authenticated
!
!
!
username admin secret 5
!
redundancy
!
interface GigabitEthernet0
switchport access vlan 250
switchport mode access
no ip address
!
interface GigabitEthernet1
switchport access vlan 250
switchport mode access
no ip address
!
interface GigabitEthernet2
switchport access vlan 250
switchport mode access
no ip address
!
interface GigabitEthernet3
switchport access vlan 250
switchport mode access
no ip address
!
interface GigabitEthernet4
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet5
ip ddns update hostname avxxxx.xxxxxx.xxx
ip ddns update dyndns
ip address dhcp
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
!
interface Vlan1
no ip address
!
interface Vlan250
ip address 192.168.2.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip dns server
ip nat inside source list 1 interface GigabitEthernet5 overload
ip nat inside source static tcp 192.168.2.200 9999 interface GigabitEthernet5 9999
ip nat inside source static tcp 192.168.2.200 81 interface GigabitEthernet5 81
ip nat inside source static tcp 192.168.2.200 8000 interface GigabitEthernet5 8000
ip nat inside source static udp 192.168.2.160 22 interface GigabitEthernet5 22
ip nat inside source static tcp 192.168.2.160 22 interface GigabitEthernet5 22
ip nat inside source static tcp 192.168.2.51 3389 interface GigabitEthernet5 3389
ip route 0.0.0.0 0.0.0.0 dhcp
!
!
!
access-list 1 permit 192.168.2.0 0.0.0.255
Not sure what I missed, please help
Thank you, much appreciate this community help! =D
Solved! Go to Solution.
10-27-2020 12:59 AM
I suggest to go to DDNS Site, remove all records and reinitiate, and check the time. as soon as it updates.(do you have many domains, remove and test only 1 )
i tested yesterday with my other router it still works as expected.
10-22-2020 12:17 AM - edited 10-22-2020 12:22 AM
I will change the default route first if still not working then configured with no-ip and test it.
ip ddns update method no-ip
HTTP
add http://email:password@dynupdate.no-ip.com/nic/update?hostname=<h>&myip=<a> ( change the username password and tst)
interval maximum 1 0 0 0
interval minimum 0 0 1 0
!
!
interface GigabitEthernet5
ip ddns update hostname avxxxx.no-ip.com or info
ip ddns update no-ip
!
ip route 0.0.0.0 0.0.0.0 GigabitEthernet5
enable debug
10-22-2020 12:26 AM
Hi Balaji,
1) I use DDNS from dyndns or dyn.com, shouldn't I be using https://usernamexxx:passwordxxx@members.dyndns.org/nic/update?system=dyndns&hostname=<h>&myip=<a>
instead of no-ip url ?
2) already enable debug ip ddns update, however there is no logging. any idea?
Thank you!
10-22-2020 12:29 AM
Try this below first -
ip route 0.0.0.0 0.0.0.0 GigabitEthernet5 dhcp
Still not working, then change it, i was tried sometime back as soon as i chage to no-ip domain it worked. (i guess it should work as expected as soon as you change the route)
10-22-2020 12:27 AM
Hello,
the DYNDNS configuration looks by the book. Try and change your default route to:
--> no ip route 0.0.0.0 0.0.0.0 dhcp
--> ip route 0.0.0.0 0.0.0.0 GigabitEthernet5 dhcp
10-22-2020 01:15 AM
Thanks @Georg Pauwen and @balaji.bandi , will try tomorrow morning, i try not to disrupt user connection here in office =D
10-22-2020 06:27 AM
Hello,
I recall a similar case from a while ago where the platform would not support DDNS at all. What is the exact router model you have, and what IOS version are you running ?
10-22-2020 01:49 AM
Sure no problem - let us know how it goes. in case issue, make sure you collect debug also to understand.
10-22-2020 07:02 PM
hi @balaji.bandi and @Georg Pauwen
I think I found the issue, it capture the old hostname instead of the correct one, will try to remove and readd everything
will update the result
xxxxxx.mooo.com instead of xxxxx.webhop.org
Model: C921-4P
Firmware: Version 15.8(3)M2
**************************************************************************************************************
*Oct 22 22:04:49.574: DYNDNSUPD: Adding DNS mapping for xxxxxx.mooo.com <=> 118.xxxxx
*Oct 22 22:04:49.574: HTTPDNS: Update add called for avxxtx.xxxxxx <=> 118.xxxx
*Oct 22 22:04:49.574: HTTPDNSUPD: Session ID = 0xE
*Oct 22 22:04:49.574: HTTPDNSUPD: URL = 'https://xxx:pxxxx@members.dyndns.org/nic/update?system=dyndns&hostname=avxxxxx&myip=118.xxxxx'
*Oct 22 22:04:49.574: HTTPDNSUPD: Sending request
*Oct 22 22:04:49.588: DYNDNSUPD: Adding DNS mapping for axxxxxxx <=> 118.xxxxx
*Oct 22 22:04:49.588: HTTPDNS: Update add called for axxxxxxx <=> 118xxxxxx
*Oct 22 22:04:49.588: HTTPDNSUPD: Session ID = 0xF
*Oct 22 22:04:49.588: HTTPDNSUPD: URL = 'https://xxxxxxxx@members.dyndns.org/nic/update?system=dyndns&hostname=axxxxxxxx&myip=xxxxxxxxxxx'
*Oct 22 22:04:49.588: HTTPDNSUPD: Sending request
*Oct 22 22:04:49.946: HTTPDNSUPD: Call returned Request Aborted, update of avxxxxxx <=> 1xxxxxxx failed
*Oct 22 22:04:49.946: DYNDNSUPD: Another update completed (outstanding=0, total=1)
*Oct 22 22:04:49.946: HTTPDNSUPD: Clearing all session 14 info
*Oct 22 22:04:49.966: HTTPDNSUPD: Call returned Request Aborted, update of axxxxxxx <=> 11xxxxxx failed
10-22-2020 10:48 PM - edited 10-22-2020 10:50 PM
hi,
after negating http detail and re-add hostname, it still capture the old host name
how do i remove mooo.com?
and also how come the timing "*Oct 23 04:54:26.554:" is different from my clock? see *Oct 23 12:01:52: -> this is correct
please help. Thank you.
*******************************************************************************************************************************
*Oct 23 12:01:51: %DNSSERVER-3-BADQUERY: Bad DNS query from 192.168.2.50
*Oct 23 12:01:52: %DNSSERVER-3-BADQUERY: Bad DNS query from 192.168.2.50
*Oct 23 04:54:26.554: DYNDNSUPD: Adding DNS mapping for xxxxxx.mooo.com <=> xxxxxxxxx
*Oct 23 04:54:26.554: HTTPDNS: Update add called for xxxxxxxmooo.com <=> xxxxxxxx.131
*Oct 23 04:54:26.554: HTTPDNSUPD: Session ID = 0x10
*Oct 23 04:54:26.554: HTTPDNSUPD: URL = 'https://xxxxxxx:xxxxxxx@members.dyndns.org/nic/update?system=dyndns&hostname=axxxxxxxmooo.com&myip=xxxxxxxx131'
*Oct 23 04:54:26.554: HTTPDNSUPD: Sending request
*Oct 23 04:54:26.942: HTTPDNSUPD: Call returned Request Aborted, update of xxxxxxxxmooo.com <=> xxxxxxx131 failed
*Oct 23 04:54:26.942: DYNDNSUPD: Another update completed (outstanding=0, total=0)
*Oct 23 04:54:26.942: HTTPDNSUPD: Clearing all session 16 info
Thank you.
10-22-2020 11:30 PM - edited 10-22-2020 11:34 PM
make sure you write the config. you need to post the configuration to have look, also, check on DynDNS website what domains you have registered.
10-22-2020 11:53 PM
Hi Balaji,
Thank you! I did some research, many advised to reload the router in order to capture the new hostname.
dyndns is using xxxxx.webhop.org
Here is my config
***********************************************************************************************************************
Current configuration : 2943 bytes
!
! Last configuration change at 11:54:28 UTC Fri Oct 23 2020 by admin
!
version 15.8
service timestamps debug datetime msec
service timestamps log datetime localtime
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
enable secret 5
!
no aaa new-model
memory-size iomem 25
clock timezone UTC 8 0
!
!
!
ip dhcp excluded-address 192.168.2.1 192.168.2.50
ip dhcp excluded-address 192.168.2.98 192.168.2.101
!
ip dhcp pool pool1
import all
network 192.168.2.0 255.255.255.0
dns-server 165.21.83.88 165.21.100.88 8.8.8.8
default-router 192.168.2.1
!
!
!
ip domain lookup source-interface GigabitEthernet5
ip domain name xxxxxxx.webhop.org
ip name-server 8.8.8.8
ip name-server 8.8.4.4
ip ddns update method dyndns
HTTP
add https://xxxxxx:xxxxxxxx@members.dyndns.org/nic/update?system=dyndns&hostname=<h>&myip=<a>
remove https://xxxx:xxxx@members.dyndns.org/nic/update?system=dyndns&hostname=<h>&myip=<a>
interval maximum 0 1 0 0
interval minimum 0 0 5 0
!
ip cef
no ipv6 cef
multilink bundle-name authenticated
!
!
!
license udi pid C921-4P sn
!
!
username admin secret 5
!
redundancy
!
!
!
!
!
!
interface GigabitEthernet0
switchport access vlan 250
switchport mode access
no ip address
!
interface GigabitEthernet1
switchport access vlan 250
switchport mode access
no ip address
!
interface GigabitEthernet2
switchport access vlan 250
switchport mode access
no ip address
!
interface GigabitEthernet3
switchport access vlan 250
switchport mode access
no ip address
!
interface GigabitEthernet4
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet5
ip ddns update hostname xxxxx.webhop.org
ip ddns update dyndns
ip address dhcp
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
!
interface Vlan1
no ip address
!
interface Vlan250
ip address 192.168.2.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip dns server
ip nat inside source list 1 interface GigabitEthernet5 overload
ip nat inside source static tcp 192.168.2.200 9999 interface GigabitEthernet5 9999
ip nat inside source static tcp 192.168.2.200 81 interface GigabitEthernet5 81
ip nat inside source static tcp 192.168.2.200 8000 interface GigabitEthernet5 8000
ip nat inside source static udp 192.168.2.160 22 interface GigabitEthernet5 22
ip nat inside source static tcp 192.168.2.160 22 interface GigabitEthernet5 22
ip nat inside source static tcp 192.168.2.51 3389 interface GigabitEthernet5 3389
ip route 0.0.0.0 0.0.0.0 GigabitEthernet5 dhcp
!
!
!
access-list 1 permit 192.168.2.0 0.0.0.255
!
control-plane
10-23-2020 12:13 AM
After reload - i take this as resolved. or still, having issues after reload?
10-23-2020 12:16 AM
Hi BB,
Not yet, will try tonight.
Did you spot any issue on the clock?
Thank you!
10-23-2020 12:24 AM
i do not see any issue: make sure on DynDNS side you have correct domains in place - remove rest which is old one.
HTTP
add https://xxxxxx:xxxxxxxx@members.dyndns.org/nic/update?system=dyndns&hostname=<h>&myip=<a>
remove https://xxxx:xxxx@members.dyndns.org/nic/update?system=dyndns&hostname=<h>&myip=<a>
Once the above changes are done, write the config make sure you see only 1 entry after changing the config.
check the debug again as you did before.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide