cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
896
Views
0
Helpful
4
Replies

Actiontec 1424 WR edge to 3750 switch

oneirishpollack
Level 1
Level 1

I have Verizon FIOS with a Actiontec 1424 WR as my edge router. I setup a Cisco 3750 (12.2) switch with ip routing enabled and 6 VLANs and their respective SVIs. I can route traffic fine internally, but am now looking to connect the internal network to the edge router. Do I setup e a VLAN for the FIOS connection and create an SVI that is on the the same subnet as the router's inside interface?

4 Replies 4

John Blakley
VIP Alumni
VIP Alumni

You can either do that, or configure a routed port. The Actiontec will need to do your natting if possible because the 3750 doesn't support it.

To do a routed port, you can do the following. Assume your internal interface on the Actiontec is 192.168.1.1. You can create a routed port on any of the ports for the 3750, but for this example let's use g0/3

int g0/3

no switchport

ip address 192.168.1.2 255.255.255.0

ip route 0.0.0.0 0.0.0.0 192.168.1.1

Or you can do the svi route as well:

int g0/3

switchport

switchport mode access

switchport access vlan 192

int vlan 192

ip address 192.168.1.2 255.255.255.0

ip route 0.0.0.0 0.0.0.0 192.168.1.1

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***

John,

Closer, but still having issues. I have detailed the key configuration and output from SH IP ROUTE and PING.

In summary, the switch itself can ping the internal networks (10.1.10.x, 10.1.20.x, etc), the inside of the router (192.168.1.1) and the outside (8.8.4.4), but internal devices on VLANS can ping as far as their SVI, but not the 192.168.1.0/24 next hop network.

Can you see anything that is obviously wrong?

*****************

interface FastEthernet1/0/2      <---- port configuration on switch
description students
switchport access vlan 10

interface Vlan10                 <--- SVI
description students
ip address 10.1.10.1 255.255.255.0
ip helper-address 10.1.50.5


interface FastEthernet1/0/46     <---  Interface on 192.168.1.0/24
no switchport
ip address 192.168.1.3 255.255.255.0


Results from SH IP ROUTE and PINGS


Switch(config)#do sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.1.1 to network 0.0.0.0

     10.0.0.0/24 is subnetted, 5 subnets
C       10.1.10.0 is directly connected, Vlan10
C       10.0.0.0 is directly connected, Loopback0
C       10.1.40.0 is directly connected, Vlan40
C       10.1.60.0 is directly connected, Vlan60
C       10.1.50.0 is directly connected, Vlan50
C    192.168.1.0/24 is directly connected, FastEthernet1/0/46


Switch(config)#do ping 192.168.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/4/9 ms
Switch(config)#do ping 192.168.1.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
Switch(config)#do ping 8.8.4.4

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.4.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 25/26/33 ms

S*   0.0.0.0/0 [1/0] via 192.168.1.1

Mike Williams
Level 5
Level 5

You need to add routes on the Actiontec router pointing back to your 3750 for your internal VLANs. You may also need to add those networks to the NAT list in the Actiontec if necessary, though it may not even be an option and just NATs everything by default.

Regards,
Mike

Sent from Cisco Technical Support Android App

So I added the the following IP route on the Actiontec router:

Name: Home/Office

Destination: 10.1.10.0

Netmask: 255.255.255.0

Gateway: 192.168.1.3

Metric: 0

I am able to ping internal devices connected to the 3750 and routed via SVI. For example, the Actiontec router can ping my 10.1.10.21 test machine and that same test machine can ping the 192.168.1.1 interface on the edge router. However, pinging 8.8.4.4 from the machine does not seem to work, No replies are received.

Review Cisco Networking for a $25 gift card