10-22-2017 04:05 AM - edited 03-05-2019 09:20 AM
Hello guys,
I would like to know a scenario for the inter-vlan routing. As we know that switch can perform the L3 routing between the vlan which eliminates the need to router-on-stick etc. I have a scenario for a customer to perform routing between 3 vlans. We have 3 vlans tagged as VLAN5, VLAN10, VLAN20.
We want the below routing, if its possible.
VLAN5 <--yes--> VLAN10
VLAN10 <--yes--> VLAN20
VLAN5 <--no--> VLAN20
I hope you get it. We want routing between vlan 5 to 10, 10 to 20 but we don't want the routing between vlan 5 to 20. Can this be achieved by the Switch L3 routing?
Appreciate your support/cooperation.
Solved! Go to Solution.
10-22-2017 11:02 AM
Hello,
thinking about it again, in order for Vlan 5 not to be able to communicate with Vlan 20 (but vice versa) and be allowed to talk to anyone else, you need the following access list on your Vlan 5 interface:
ip access-list extended 100
permit tcp 192.168.5.0 0.0.0.255 192.168.20.0 0.0.0.255 established
deny ip 192.168.5.0 0.0.0.255 192.168.20.0 0.0.0.255
100 permit ip any any
interface Vlan5
ip access-group 100 in
However, that blocks only TCP traffic. If that is sufficient, fine. If not, you need to configure CBAC or ZBF (Zone Based Firewall).
10-22-2017 04:53 AM
Hi
Actually there is not way to specify once IP routing is enabled but you can filter the communication using ACL or VACL.
Hope it is useful
:-)
10-22-2017 04:56 AM
Hello,
basically, you just create your three SVIs, and then apply access lists:
interface Vlan5
ip address 192.168.5.1 255.255.255.0
interface Vlan10
ip address 192.168.10.1 255.255.255.0
ip access-group 101 in
interface Vlan20
ip address 192.168.20.1 255.255.255.0
ip access-group 102 in
access-list 101 deny ip 192.168.10 0.0.0.255 192.168.20.0 0.0.0.255
access-list 101 deny ip 192.168.20 0.0.0.255 192.168.10.0 0.0.0.255
access-list 101 permit ip any any
access-list 102 deny ip 192.168.20 0.0.0.255 192.168.10.0 0.0.0.255
access-list 102 deny ip 192.168.10 0.0.0.255 192.168.20.0 0.0.0.255
access-list 102 permit ip any any
What about Vlan 5 access to Vlan 10 and Vlan 20 ? Should that be allowed or denied ?
10-22-2017 06:04 AM
10-22-2017 06:09 AM
Hello,
add the below to your configuration:
interface Vlan5
ip address 192.168.5.1 255.255.255.0
ip access-group 103 in
access-list 103 deny ip 192.168.5.0 0.0.0.255 192.168.20.0 0.0.0.255
access-list 103 permit ip any any
10-22-2017 11:02 AM
Hello,
thinking about it again, in order for Vlan 5 not to be able to communicate with Vlan 20 (but vice versa) and be allowed to talk to anyone else, you need the following access list on your Vlan 5 interface:
ip access-list extended 100
permit tcp 192.168.5.0 0.0.0.255 192.168.20.0 0.0.0.255 established
deny ip 192.168.5.0 0.0.0.255 192.168.20.0 0.0.0.255
100 permit ip any any
interface Vlan5
ip access-group 100 in
However, that blocks only TCP traffic. If that is sufficient, fine. If not, you need to configure CBAC or ZBF (Zone Based Firewall).
10-22-2017 09:26 PM
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide