cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
690
Views
0
Helpful
2
Replies

Alternate Internet/NAT

eduardopozo56
Level 1
Level 1

Hi guys, this is my first Post/Question on cisco forums, i'm a CCNA4 student and i'm having a little problem with a nat configuration:

I have to sites wich are connected by PPP, each one of them has their ISP provider and each router do the Intervlan/DHCP/Nat translation, i just need to finish the exercise with the following:

PPP link must be always down, if SITE A internet goes down, it has to use the PPP link to go to internet thu SITE B router (so SITE B router would make the NAT translation), all of this have to be done with Static Routes - Metrics.

I have tried setting up a static route to SITE B with higher metric but it is not working, SITE A router can ping the SITE B interface but hosts cant.

Any help is appreciated, ty.

Cisco.jpg


Configuration is BASIC, TRUNK interface, Intervlan Routing, Nat done from Subinterfaces to Ethernet Interface connected to ISP,
Serial Interface Encapsulation PPP

Nothing fancy, ty

2 Replies 2

cadet alain
VIP Alumni
VIP Alumni

Hi,

Post config of 2 routers and put ip addresses on your diagram to make things clearer.

Regards.

Alain.

Don't forget to rate helpful posts.

!

version 12.4

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname ROUTER

!

ip dhcp excluded-address 192.168.0.1 192.168.0.10

ip dhcp excluded-address 192.168.0.193 192.168.0.200

ip dhcp excluded-address 192.168.0.129 192.168.0.135

!

ip dhcp pool DATOS10

network 192.168.0.0 255.255.255.128

default-router 192.168.0.1

ip dhcp pool DATOS20

network 192.168.0.128 255.255.255.192

default-router 192.168.0.129

ip dhcp pool DATOS30

network 192.168.0.192 255.255.255.224

default-router 192.168.0.193

!

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0.10

encapsulation dot1Q 10

ip address 192.168.0.1 255.255.255.128

!

interface FastEthernet0/0.20

encapsulation dot1Q 20

ip address 192.168.0.129 255.255.255.192

!

interface FastEthernet0/0.30

encapsulation dot1Q 30

ip address 192.168.0.193 255.255.255.224

!

interface FastEthernet0/0.40

encapsulation dot1Q 40

ip address dhcp

!

interface FastEthernet0/0.100

encapsulation dot1Q 100

ip address 192.168.100.1 255.255.255.0

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

shutdown

!

interface Serial0/2/0

no ip address

encapsulation ppp

!

interface Vlan1

no ip address

shutdown

!

Router number 2 is same configuration with same ip scheme on subnet 192.168.10.X

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card