12-20-2015 04:43 PM - edited 03-05-2019 02:58 AM
Hey all,
So I am trying to figure out an issue I am having. My ISP recently notified me that modem rental will be going up starting the first of the year. I have fiber optics to my house. Right now the setup is:
ONT box (fiber converter) -->DHCP - modem - static external/30 -->static external/30 - ASA 5505 - internal range (router mode)-->L3 switch (internal VLAN routing).
What I would like to get to is: ONT --> ASA --> L3 switch.
One thing I have figured out is that I COULD eliminate the modem by plugging in a firewall/router and going from there I was able to get to the Internet and such.
The problem I currently have is that I have a static IP address. The modem pulls a WAN IP from DHCP, with the internal IP being one part of a /30 IP address. So right at the moment I am trying to figure out how to get the ASA to pull the DHCP from the ONT box and still keep my static IP in play.
Thoughts? Suggestions?
Thank you all!
Scott
12-20-2015 09:13 PM
Hello,
As I understood, your modem is getting a public /30 IP address from ONT and your ASA another /30 from modem which is currently used in your network. And you are translating your private internal IP addresses to the IP address on the ASA interface by using PAT.
After connecting ASA to ONT, ASA will receive an IP address from ONT. Then you need to change your NAT configuration. In your NAT statement, instead of using interface IP(ONT), you can use your static IP address.
Just to mention, you do not need to set your current static IP address on the interface. You need to just add it in the NAT statement.
You also need to change ASA default route toward ONT.
I hope I understood your question correctly.
Masoud
12-21-2015 10:34 AM
Hi Masoud,
Thank you for your reply. Currently the modem is getting a DHCP from the ONT box, with the internal interface on the modem being one side of my static /30 IP. The outside interface of my ASA is the other side of the /30 IP.
At this moment the ONT box is really just a converter. The ISP is currently running a DHCP server that seems to have a lease expiration of 58 minutes.
I have uploaded a PDF hoping to clear up that my description may have caused.
I guess what I am really not sure of is how to deal with the static IP address when I cut out the modem. If I didnt have the static IP, this would be a no-brainer and easy to do.
Since I run my own website, Exchange and such to play with, I would like to keep my static IP.
Thoughts? Suggestions?
Thank you!
Scott
12-21-2015 10:56 AM
Hello,
Does exchange has a private IP address and has been published by ASA using static NAT?
If yes, you need to change ASA static IP address on external interface to DHCP and change the ASA default route toward to ISP.
and a little change in your NAT statement based on your current configuration.
If you share you config, I can explain more.
Masoud
12-22-2015 01:39 PM
Masoud,
Exchange does have a private IP and traffic is passed via port fowarding.
ASA Config:
ASA5505# sh run
: Saved
:
ASA Version 8.2(5)
!
hostname ASA5505
domain-name DOMAINNAME.COM
enable password encrypted
passwd encrypted
names
!
interface Ethernet0/0
description ISP Modem
switchport access vlan 2
!
interface Ethernet0/1
shutdown
!
interface Ethernet0/2
description Internal
switchport access vlan 11
!
truncated
!
interface Vlan1
shutdown
no nameif
no security-level
no ip address
!
interface Vlan2
nameif outside
security-level 0
ip address 125.125.125.125 255.255.255.252
!
interface Vlan11
nameif inside
security-level 100
ip address 10.1.1.1 255.255.255.224
!
interface Vlan21
no nameif
security-level 100
no ip address
!
interface Vlan31
no nameif
security-level 100
no ip address
!
interface Vlan51
no nameif
security-level 100
no ip address
!
interface Vlan101
no nameif
security-level 100
no ip address
!
!
time-range RDP-inbound
periodic weekdays 7:15 to 16:45
!
banner exec This is a private network. If you have not been given explicit permission to be on this device, disconnect immediately!
banner login This is a private network. If you have not been given explicit permission to be on this device, disconnect immediately!
ftp mode passive
clock timezone EST -5
clock summer-time EDT recurring
dns domain-lookup inside
dns server-group DefaultDNS
name-server SERVER1
name-server SERVER2
domain-name DOMAINNAME
same-security-traffic permit intra-interface
object-group network mail
network-object host SERVER
object-group network webserver
network-object host SERVER
access-list inside_nat0_outbound extended permit ip 10.1.0.0 255.255.240.0 IP 255.255.255.248
access-list Outside_access_in extended permit tcp host IP interface outside eq 3389
access-list Outside_access_in extended permit tcp any interface outside eq smtp
access-list Outside_access_in extended permit tcp any interface outside eq www
access-list Outside_access_in extended permit tcp any interface outside eq https
access-list Outside_access_in extended permit ip host IP any
access-list New-Group_splitTunnelAcl standard permit 10.1.0.0 255.255.240.0
access-list inside_access_in extended permit ip host IP any
access-list Outbound extended permit tcp host SERVER any eq smtp
access-list Outbound extended deny tcp any any eq smtp
access-list Outbound extended permit ip any any
access-list global_mpc extended permit ip any any
pager lines 24
logging enable
logging trap notifications
logging asdm informational
logging host inside SERVER
logging permit-hostdown
no logging message 106015
no logging message 313001
no logging message 313008
no logging message 106023
no logging message 710003
no logging message 106100
no logging message 302015
no logging message 302014
no logging message 302013
no logging message 302018
no logging message 302017
no logging message 302016
no logging message 302021
no logging message 302020
flow-export destination inside SERVER 9991
mtu outside 1500
mtu inside 1500
ip local pool VPN-IPs IP-IP mask 255.255.255.248
ip verify reverse-path interface outside
icmp unreachable rate-limit 1 burst-size 1
icmp deny any echo-reply outside
asdm image disk0:/asdm-645.bin
asdm history enable
arp timeout 14400
nat-control
global (outside) 10 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 10 IP 255.255.255.255
nat (inside) 10 192.168.80.0 255.255.255.248
nat (inside) 10 10.1.0.0 255.255.240.0
static (inside,outside) tcp interface 3389 IP 3389 netmask 255.255.255.255
static (inside,outside) tcp interface smtp IP smtp netmask 255.255.255.255
static (inside,outside) tcp interface www IP www netmask 255.255.255.255
static (inside,outside) tcp interface https IP https netmask 255.255.255.255
access-group Outside_access_in in interface outside
access-group Outbound in interface inside
!
router eigrp 5
no auto-summary
network 10.1.1.0 255.255.255.224
network IP 255.255.255.248
network IP 255.255.255.252
!
router rip
network IP
version 2
!
route outside 0.0.0.0 0.0.0.0 IP 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
aaa authentication ssh console LOCAL
http server enable 8080
http 10.1.X.X 255.255.255.255 inside
http 10.X.X.X 255.255.255.255 inside
http 10.X.X.X 255.255.255.255 inside
http X.X.X.X 255.255.255.255 inside
http X.X.X.X 255.255.255.255 outside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs group1
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map outside_map interface outside
crypto ca trustpoint _SmartCallHome_ServerCA
crl configure
crypto ca certificate chain _SmartCallHome_ServerCA
certificate ca 6ecc7aa5a7032009b8cebcf4e952d491
-Truncated-
quit
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
crypto isakmp policy 65535
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
telnet timeout 5
ssh X.X.X.X 255.255.255.255 outside
ssh X.X.X.X 255.255.255.255 inside
ssh X.X.X.X 255.255.255.255 inside
ssh X.X.X.X 255.255.255.255 inside
ssh X.X.X.X 255.255.255.255 inside
ssh X.X.X.X 255.255.255.255 inside
ssh timeout 30
console timeout 10
management-access inside
threat-detection basic-threat
threat-detection statistics access-list
threat-detection statistics host number-of-rate 3
threat-detection statistics tcp-intercept rate-interval 30 burst-rate 400 average-rate 200
ntp server X.X.X.X source inside prefer
webvpn
group-policy New-Group internal
group-policy New-Group attributes
dns-server value X.X.X.X
vpn-tunnel-protocol IPSec
split-tunnel-policy tunnelspecified
split-tunnel-network-list value New-Group_splitTunnelAcl
default-domain value ebbs.us
username sworks password rZHtLTteBnX1edzp encrypted privilege 15
username sebbing password aVPcVVXENmaXU.Ix encrypted privilege 15
username sebbing attributes
vpn-group-policy New-Group
vpn-access-hours none
vpn-simultaneous-logins 3
vpn-idle-timeout 30
vpn-session-timeout none
vpn-filter none
ipv6-vpn-filter none
vpn-tunnel-protocol IPSec l2tp-ipsec svc webvpn
password-storage disable
group-lock none
username buddy password QRqHo6j2jCymU1dT encrypted privilege 0
username buddy attributes
vpn-group-policy New-Group
tunnel-group New-Group type remote-access
tunnel-group New-Group general-attributes
address-pool VPN-IPs
default-group-policy New-Group
tunnel-group New-Group ipsec-attributes
pre-shared-key *****
!
class-map global-class
match any
class-map inspection_default
match default-inspection-traffic
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum client auto
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect ip-options
inspect netbios
inspect rsh
inspect rtsp
inspect skinny
inspect esmtp
inspect sqlnet
inspect sunrpc
inspect tftp
inspect sip
inspect xdmcp
inspect icmp
class global-class
flow-export event-type all destination X.X.X.X
!
service-policy global_policy global
smtp-server X.X.X.X
prompt hostname context
call-home reporting anonymous
call-home
profile CiscoTAC-1
no active
destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
destination address email callhome@cisco.com
destination transport-method http
subscribe-to-alert-group diagnostic
subscribe-to-alert-group environment
subscribe-to-alert-group inventory periodic monthly
subscribe-to-alert-group configuration periodic monthly
subscribe-to-alert-group telemetry periodic daily
Cryptochecksum:d41d8cd98f00b204e9800998ecf8427e
: end
I understand that if I were to drop the static from the loop, this would be an easy fix. However, with needing to keep the static IP is what is making it difficult.
Thank you.
Thoughts? Suggestions?
Scott
12-22-2015 02:39 PM
Hello,
There might be more involved because I do not have ASA with OS the same version as yours to test it.
interface Vlan2
nameif outside
security-level 0
ip address dhcp
current
global (outside) 10 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 10 IP 255.255.255.255
nat (inside) 10 192.168.80.0 255.255.255.248
nat (inside) 10 10.1.0.0 255.255.240.0
next
global (outside) 10 125.125.125.125 255.255.255.252
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 10 IP 255.255.255.255
nat (inside) 10 192.168.80.0 255.255.255.248
nat (inside) 10 10.1.0.0 255.255.240.0
current
static (inside,outside) tcp interface 3389 IP 3389 netmask 255.255.255.255
static (inside,outside) tcp interface smtp IP smtp netmask 255.255.255.255
static (inside,outside) tcp interface www IP www netmask 255.255.255.255
static (inside,outside) tcp interface https IP https netmask 255.255.255.255
next
static (inside,outside) tcp 125.125.125.125 3389 IP 3389 netmask 255.255.255.255
static (inside,outside) tcp 125.125.125.125 smtp IP smtp netmask 255.255.255.255
static (inside,outside) tcp 125.125.125.125 www IP www netmask 255.255.255.255
static (inside,outside) tcp 125.125.125.125 https IP https netmask 255.255.255.255
current
route outside 0.0.0.0 0.0.0.0 IP 1
next
route outside 0.0.0.0 0.0.0.0 [your ISP ip] 1
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide