cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
9272
Views
10
Helpful
7
Replies

ASR1006 - bootflash: not present

johnelliot6
Level 2
Level 2

Hi Guys,

Have an ASR1006 (Dual RP's/Dual ESP's), and the "standby" RP is stuck in rommon:

System Bootstrap, Version 12.2(33r)XN2, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 2008 by cisco Systems, Inc.


Current image running: Boot ROM0
Last reset cause: LocalSoft

ASR1000-RP1 platform with 4194303 Kbytes of main memory

no valid BOOT image found
Final autoboot attempt from default boot device...
media drive bootflash: not present
boot: cannot determine first file name on device "bootflash:"
autoboot: boot failed, restarting...

System Bootstrap, Version 12.2(33r)XN2, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 2008 by cisco Systems, Inc.


Current image running: Boot ROM0

                  

Then checking dev, bootflash is there, but then cant be read:

rommon 1 > dev

Devices in device table:

        id  name

bootflash:  Internal flash drive

harddisk:  Internal hard disk

     usb0:  External USB drive 0

     usb1:  External USB drive 1

rommon 2 > dir bootflash:

media drive bootflash: not present

Any suggestions greatly appreciated.

7 Replies 7

cedar_lee
Level 1
Level 1

 

In my case, after cold reboot, issue no more.

It happened to us with a C9300 stack. I performed a cold reboot too, I disconnected all of them from the power supply and connected them again.

 

After that everything was well. We're trying to figure out what happened.

 

Some of the errors we got:

 

switch: dev
Devices in device table:
id name
tftp: network via tftp
flash: Internal flash drive
usbflash0: External USB drive 0
usbflash1: External USB drive 1
switch:
switch:
switch: dir flash:
media drive flash: not present.

 

Last reset cause: SoftwareReload
C9300-48U platform with 8388608 Kbytes of main memory

media drive sda8: not present.
attempting to boot from [flash:packages.conf]
media drive flash: not present.
ERROR: failed to boot from flash:packages.conf (Not Found)
Please wait while the system restarts.

Initializing Hardware...

You are my hero!

Hani Elgaali
Cisco Employee
Cisco Employee

Hi, Im also having the same issue, here is my out boot after resetting from rommon:

 

Current image running: Boot ROM1
Last reset cause: LocalSoft
Last reset at: Wed Jan 28 17:01:05 UTC 2015


ASR1000-RP1 platform with 4194303 Kbytes of main memory

media drive bootflash: not present
boot: error executing "boot bootflash:asr1000rp1-adventerprisek9.03.07.00.S.152-4.S.bin"
autoboot: boot failed, restarting...

 

System Bootstrap, Version 15.2(1r)S, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 2011 by cisco Systems, Inc.


Current image running: Boot ROM1
Last reset cause: LocalSoft
Last reset at: Wed Jan 28 17:02:05 UTC 2015


ASR1000-RP1 platform with 4194303 Kbytes of main memory

no valid BOOT image found
Final autoboot attempt from default boot device...

 

If anyone has a solution to this please respond.

 

Thanks,

Hani

Hani, 

 

You can boot the ASR's IOS straight from a USB stick. 

Thanks Leo, Can the ASR rp1 from the HDD, I'm not sure if that a valid option.

 

Thanks again,

Hani

Not HDD, a USB thumb drive.

Review Cisco Networking for a $25 gift card