02-18-2018 08:23 AM - edited 03-05-2019 09:56 AM
I'm just testing this Cisco 1921, very basic configuration on a static connection. Works with my other routers that are Cisco... but for some reason the configs I have entered are not working here. Where am I going wrong.?
*** Router Cisco 1921: Info below
Router#show ver
Cisco IOS Software, C1900 Software (C1900-UNIVERSALK9-M), Version 15.0(1)M3, RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2010 by Cisco Systems, Inc.
Compiled Sun 18-Jul-10 01:47 by prod_rel_team
ROM: System Bootstrap, Version 15.0(1r)M9, RELEASE SOFTWARE (fc1)
*** Here is my basic configuration, as you can see 0/0 is WAN and 0/1 is my LAN
DHCP works fine on my side, just not passing traffic... see below.
! My Network Configs at home
!
!
!
config t
interface GigabitEthernet0/0
ip address 221.254.158.60 255.255.255.248
no cdp enable
no shut
end
!
!
!
config t
interface GigabitEthernet0/1
ip address 10.10.10.1 255.255.255.0
no shut
end
!
!
!
! ---------configure DNS-----------------------
config t
ip domain-name zeta1.local
ip route 0.0.0.0 0.0.0.0 221.254.158.57
ip domain-lookup
ip name-server 8.8.8.8
ip name-server 8.8.4.4
ip dns server
end
!
!
!
! ----------Configure DHCP--------------
config t
service dhcp
ip dhcp pool zeta1_dhcp
network 10.10.10.0 /24
dns-server 8.8.8.8
dns-server 8.8.4.4
default-router 10.10.10.1
lease 7
ip dhcp excluded-address 10.10.10.200
ip dhcp excluded-address 10.10.10.20
ip dhcp excluded-address 10.10.10.10
end
!
Nothing exstravagant just want to be able to pass traffic.
Its probably one or two lines Im missing... right?
Thanks for your help in advanced.
Dwayne
Solved! Go to Solution.
02-18-2018 02:26 PM
Hello,
here is the basic configuration for Internet connectivity:
service dhcp
!
ip dhcp excluded-address 10.10.10.200
ip dhcp excluded-address 10.10.10.20
ip dhcp excluded-address 10.10.10.1
ip dhcp excluded-address 10.10.10.10
!
ip dhcp pool zeta1_dhcp
network 10.10.10.0 /24
dns-server 8.8.8.8
dns-server 8.8.4.4
default-router 10.10.10.1
lease 7
!
ip domain-name zeta1.local
ip domain-lookup
ip name-server 8.8.8.8
ip name-server 8.8.4.4
ip dns server
!
interface GigabitEthernet0/0
ip address 221.254.158.60 255.255.255.248
ip nat outside
no cdp enable
!
interface GigabitEthernet0/1
ip address 10.10.10.1 255.255.255.0
ip nat inside
!
ip nat inside source list 1 interface GigabitEthernet0/0 overload
ip route 0.0.0.0 0.0.0.0 221.254.158.57
!
access-list 1 permit 10.10.10.0 0.0.0.255
02-18-2018 03:49 PM
02-18-2018 09:24 AM
Hi
Could you please share more details about: "DHCP works fine on my side, just not passing traffic... see below"
Also I suggest excluded the first IP .1
02-18-2018 01:34 PM
I agree with Julio that we need more details to be able to identify the issue. Among other things the output of show ip interface brief would be helpful. I do not see anything configured about address translation. Is nat configured?
HTH
Rick
02-18-2018 02:10 PM
Router#show ip int br
Interface IP-Address OK? Method Status Protocol
GigabitEthernet0/0 221.254.158.60 YES NVRAM up up
GigabitEthernet0/1 10.10.10.1 YES NVRAM up up
Router#
Hi guys thanks for jumping in. Its a very basic setup .
The Wan is static, 221.254.158.60, link is up.
The LAN is 10.10.10.1, the link is up.
No Nat translation are in the configuration as you can see. But I went through the configs in the Cisco guide and nothing was mentioned on NAT if all I'm doing is is a simple internet connection. Richard are you saying some kind of NAT is required to get a basic connection with this router?
02-18-2018 02:20 PM
I am not sure what guide you are referring to but I am guessing that it describes basic configuration of an IOS router where both interfaces are using private addressing (network 10.0.0.0 etc). In that situation there is no need for nat.
But if your LAN is 10.10.10.0 and your WAN is 221.254.258.60 then absolutely someone must provide nat for this to work. It could possibly be on the provider router. Did the provider say that they would translate addresses for you? If they are not doing translation then they assume that you would be doing translation.
HTH
Rick
02-18-2018 02:24 PM
There is a fairly simple test that you can do that would help clarify the issue.
1) from the router ping some Internet resource (something like ping 8.8.8.8
2) assuming that this ping is successful then you have validated your interface configuration, your routing, and your connection to the provider.
3) from the router ping that same Internet resource and this time specify that the source address is 10.10.10.1
4) if that ping fails it is pretty convincing evidence that the problem is using private addresses to access the Internet and that you need to configure nat.
HTH
Rick
02-18-2018 03:46 PM
02-20-2018 11:10 AM
Dwayne
Thank you for posting back to the forum and letting us know that you do now have it working. Thank you for marking this question as solved. This will help other readers in the forum to identify discussions that have helpful information.
HTH
Rick
02-18-2018 02:26 PM
Hello,
here is the basic configuration for Internet connectivity:
service dhcp
!
ip dhcp excluded-address 10.10.10.200
ip dhcp excluded-address 10.10.10.20
ip dhcp excluded-address 10.10.10.1
ip dhcp excluded-address 10.10.10.10
!
ip dhcp pool zeta1_dhcp
network 10.10.10.0 /24
dns-server 8.8.8.8
dns-server 8.8.4.4
default-router 10.10.10.1
lease 7
!
ip domain-name zeta1.local
ip domain-lookup
ip name-server 8.8.8.8
ip name-server 8.8.4.4
ip dns server
!
interface GigabitEthernet0/0
ip address 221.254.158.60 255.255.255.248
ip nat outside
no cdp enable
!
interface GigabitEthernet0/1
ip address 10.10.10.1 255.255.255.0
ip nat inside
!
ip nat inside source list 1 interface GigabitEthernet0/0 overload
ip route 0.0.0.0 0.0.0.0 221.254.158.57
!
access-list 1 permit 10.10.10.0 0.0.0.255
02-18-2018 03:49 PM
02-19-2018 04:19 AM
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide