06-17-2023 12:37 AM
Hi guys,
i have a question for you. If it's possible of course.
I have some problems setting BGP in ipv6 environment. I have this sample configuration
Router:1
conf t
ipv6 unicast routing
router bgp 1
bgp router id 192.168.0.1
neighbor 2::2 update-source loopback 0
address family ipv6
neighbor 2::2 activate (loopback 0)
network 11::11/128 (loopback 1)
Router 2
conf t
ipv6 unicast routing
router bgp 2
bgp router id 192.168.0.2
neighbor 1::1 update-source loopback 0
address family ipv6
neighbor 1::1 activate (loopback 0)
network 22::22/128 (loopback 1)
In Gns3 i test it with C7200 iso but don't work !!!
We can help me?
Best regards
06-17-2023 12:53 AM
First can you ping between router for ipv6?
06-17-2023 04:52 AM
Yes i ping all routers on serial with ipv6 address 2001:1::1/64 for the first router and 2001:1::2/64 for second router, but the bgp protocollo don't execute adjacency
06-17-2023 05:04 AM
Ok'
Neighbor <ipv6> remote-as xx
I dont see this command
06-17-2023 06:09 AM
You are right, I forgot to write it down. Sorry
06-17-2023 06:13 AM
No since as is different you and multi hop away you need
Neighbor <ipv6> ebgp multihop
06-17-2023 07:08 AM
Ok I try it and update
06-17-2023 09:14 AM
Sorry, dont work probably gns3 have a bug on ios on 7200
06-17-2023 09:15 AM - edited 06-17-2023 09:22 AM
Can I see the config ? all config.
Do you ping from lo to lo
You need to use source in ping command
06-17-2023 10:45 AM
Router 1:
Building configuration...
Current configuration : 1879 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
logging queue-limit 100
!
ip subnet-zero
no ip icmp rate-limit unreachable
!
!
ip tcp synwait-time 5
no ip domain lookup
!
ip cef
ipv6 unicast-routing
mpls ldp logging neighbor-changes
!
!
!
!
!
!
!
!
!
!
!
!
no voice hpi capture buffer
no voice hpi capture destination
!
!
mta receive maximum-recipients 0
!
!
!
!
interface Loopback0
no ip address
ipv6 address 1::1/128
!
interface Loopback1
no ip address
ipv6 address 11::11/128
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
no ip address
ipv6 address 2001:1::1/64
serial restart_delay 0
!
interface Serial1/1
no ip address
shutdown
serial restart_delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart_delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart_delay 0
!
router bgp 1
no synchronization
bgp router-id 192.168.0.1
bgp log-neighbor-changes
neighbor 2::2 remote-as 2
neighbor 2::2 update-source Loopback0
no auto-summary
!
address-family ipv4 multicast
no auto-summary
no synchronization
exit-address-family
!
address-family ipv6
neighbor 2::2 activate
network 11::11/128
exit-address-family
!
address-family ipv4
no neighbor 2::2 activate
no auto-summary
no synchronization
exit-address-family
!
ip classless
no ip http server
no ip http secure-server
!
!
!
no cdp log mismatch duplex
!
!
!
call rsvp-sync
!
!
mgcp profile default
!
dial-peer cor custom
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
!
end
Router 2:
Current configuration : 1879 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
logging queue-limit 100
!
ip subnet-zero
no ip icmp rate-limit unreachable
!
!
ip tcp synwait-time 5
no ip domain lookup
!
ip cef
ipv6 unicast-routing
mpls ldp logging neighbor-changes
!
!
!
!
!
!
!
!
!
!
!
!
no voice hpi capture buffer
no voice hpi capture destination
!
!
mta receive maximum-recipients 0
!
!
!
!
interface Loopback0
no ip address
ipv6 address 2::2/128
!
interface Loopback1
no ip address
ipv6 address 22::22/128
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
no ip address
ipv6 address 2001:1::2/64
serial restart_delay 0
!
interface Serial1/1
no ip address
shutdown
serial restart_delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart_delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart_delay 0
!
router bgp 2
no synchronization
bgp router-id 192.168.0.2
bgp log-neighbor-changes
neighbor 1::1 remote-as 1
neighbor 1::1 update-source Loopback0
no auto-summary
!
address-family ipv4 multicast
no auto-summary
no synchronization
exit-address-family
!
address-family ipv6
neighbor 1::1 activate
network 22::22/128
exit-address-family
!
address-family ipv4
no neighbor 1::1 activate
no auto-summary
no synchronization
exit-address-family
!
ip classless
no ip http server
no ip http secure-server
!
!
!
no cdp log mismatch duplex
!
!
!
call rsvp-sync
!
!
mgcp profile default
!
dial-peer cor custom
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
!
end
06-17-2023 10:46 AM
The issue its multihope setting dont work !!!
06-17-2023 10:53 AM - edited 06-17-2023 11:02 AM
As I mention in my first comment'
Where is static or igp route between two routers? The loopback must be appear in rib then you can use bgp'
lo must ping to other lo
The bgp not like other igp' it need first ip reachability between two peers.
06-17-2023 11:19 AM
Thank you works correctly!!!IGP with OSPFv3
06-17-2023 11:22 AM
You are so welcome
Have a nice day
MHM
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide