06-08-2023 04:05 PM - last edited on 06-11-2023 10:26 PM by Translator
Doing a lab.
R9 is not forming sessions with R10 and R11:
here is debug on R9
Jun 8 23:00:58.002: BGP: 192.10.10.10 Active open failed - tcb is not available, open active delayed 10240ms (35000ms max, 60% jitter)
*Jun 8 23:00:58.002: BGP: ses global 192.10.10.10 (0xDCE67060:0) act Reset (Active open failed).
Any advice appreciated (it's just a lab, but if you have time, I like the learning experience)
here is the show run:
R9
interface Loopback0
description Network Admin1
ip address 192.9.9.9 255.255.255.255
ipv6 address 2010:CAFE:9::9/128
!
interface Loopback1
description Test Network
ip address 192.199.199.199 255.255.255.255
!
interface Loopback100
description Metric Test
ip address 192.99.99.99 255.255.255.255
!
interface Ethernet0/0
ip address 192.168.10.9 255.255.255.252
ipv6 address 2001:CC1E:CAFE::9/126
ipv6 address 2001:CCCC:CAFE::1/126
!
interface Ethernet0/1
ip address 192.168.10.2 255.255.255.252
ipv6 address 2001:CC1E:CAFE::2/126
bfd interval 60 min_rx 60 multiplier 8
!
interface Ethernet0/2
no ip address
shutdown
!
interface Ethernet0/3
no ip address
shutdown
!
!
router eigrp San_Francisco_HQ
!
address-family ipv4 unicast autonomous-system 150
!
af-interface default
authentication mode hmac-sha-256 EIGRP
exit-af-interface
!
af-interface Ethernet0/1
bfd
exit-af-interface
!
topology base
redistribute connected metric 1 1 1 1 1 route-map Metric
offset-list 1 in 2147483647 Ethernet0/1
exit-af-topology
network 192.9.9.9 0.0.0.0
network 192.168.10.0 0.0.0.3
network 192.168.10.8 0.0.0.3
network 192.199.199.199 0.0.0.0
eigrp router-id 192.9.9.9
exit-address-family
!
router bgp 64784
bgp router-id 192.9.9.9
bgp log-neighbor-changes
no bgp default ipv4-unicast
neighbor PEER-INTERNAL peer-group
neighbor PEER-INTERNAL remote-as 64784
neighbor PEER-INTERNAL update-source Loopback0
neighbor 192.8.8.8 peer-group PEER-INTERNAL
neighbor 192.10.10.10 peer-group PEER-INTERNAL
neighbor 192.11.11.11 peer-group PEER-INTERNAL
!
address-family ipv4
neighbor PEER-INTERNAL send-community
neighbor 192.8.8.8 activate
neighbor 192.10.10.10 activate
neighbor 192.11.11.11 activate
exit-address-family
!
ip forward-protocol nd
!
ip bgp-community new-format
!
no ip http server
no ip http secure-server
!
!
ip prefix-list Metric seq 5 permit 192.99.99.99/32
access-list 1 permit 192.188.188.188
!
route-map Metric permit 10
match ip address prefix-list Metric
!
!
!
control-plane
!
!
!
!
!
!
!
line con 0
logging synchronous
line aux 0
line vty 0 4
login
transport input all
!
R11
interface Loopback0
description Internal DNS Server
ip address 192.11.11.11 255.255.255.255
ipv6 address 2010:CAFE:11::11/128
!
interface Ethernet0/0
ip address 192.168.10.26 255.255.255.252
ipv6 address 2001:CC1E:CAFE::26/126
!
interface Ethernet0/1
ip address 192.168.10.18 255.255.255.252
ipv6 address 2001:CC1E:CAFE::17/126
!
interface Ethernet0/2
ip address 192.168.10.22 255.255.255.252
!
interface Ethernet0/3
ip address 155.84.74.13 255.255.255.252
!
interface Ethernet1/0
bandwidth 1
ip address 140.60.88.14 255.255.255.252
shutdown
!
interface Ethernet1/1
no ip address
shutdown
!
interface Ethernet1/2
no ip address
shutdown
!
interface Ethernet1/3
no ip address
shutdown
!
!
router eigrp San_Francisco_HQ
!
address-family ipv4 unicast autonomous-system 150
!
af-interface default
authentication mode hmac-sha-256 EIGRP
exit-af-interface
!
topology base
distribute-list prefix NETWORK gateway GATEWAY in Ethernet0/2
exit-af-topology
network 192.11.11.11 0.0.0.0
network 192.168.10.18 0.0.0.0
network 192.168.10.22 0.0.0.0
network 192.168.10.26 0.0.0.0
metric rib-scale 153
eigrp router-id 192.11.11.11
exit-address-family
!
router bgp 64784
bgp log-neighbor-changes
neighbor PEER-INTERNAL peer-group
neighbor PEER-INTERNAL remote-as 64784
neighbor PEER-INTERNAL update-source Loopback0
neighbor 192.8.8.8 peer-group PEER-INTERNAL
neighbor 192.9.9.9 peer-group PEER-INTERNAL
neighbor 192.10.10.10 peer-group PEER-INTERNAL
neighbor 192.10.10.14 peer-group PEER-INTERNAL
!
address-family ipv4
neighbor PEER-INTERNAL send-community
neighbor 192.8.8.8 activate
neighbor 192.9.9.9 activate
neighbor 192.10.10.10 activate
neighbor 192.10.10.14 activate
exit-address-family
!
ip forward-protocol nd
!
ip bgp-community new-format
!
no ip http server
no ip http secure-server
!
!
route-map list permit 5
!
!
!
control-plane
!
!
!
!
!
!
!
line con 0
logging synchronous
line aux 0
line vty 0 4
login
transport input all
!
!
end
R10
interface Loopback0
description Finance User
ip address 192.10.10.10 255.255.255.255
ipv6 address 2010:CAFE:10::10/128
!
interface Ethernet0/0
ip address 155.84.74.9 255.255.255.252
!
interface Ethernet0/1
ip address 192.168.10.25 255.255.255.252
ipv6 address 2001:CC1E:CAFE::25/126
!
interface Ethernet0/2
ip address 192.168.10.14 255.255.255.252
ipv6 address 2001:CC1E:CAFE::13/126
!
interface Ethernet0/3
no ip address
shutdown
!
!
router eigrp San_Francisco_HQ
!
address-family ipv4 unicast autonomous-system 150
!
af-interface default
authentication mode hmac-sha-256 EIGRP
exit-af-interface
!
topology base
distribute-list prefix NETWORK gateway GATEWAY in Ethernet0/2
exit-af-topology
network 192.10.10.10 0.0.0.0
network 192.168.10.14 0.0.0.0
network 192.168.10.25 0.0.0.0
metric rib-scale 153
eigrp router-id 192.10.10.10
exit-address-family
!
router bgp 64784
bgp log-neighbor-changes
neighbor PEER-INTERNAL peer-group
neighbor PEER-INTERNAL remote-as 64784
neighbor PEER-INTERNAL update-source Loopback0
neighbor 155.84.74.10 remote-as 15789
neighbor 192.8.8.8 peer-group PEER-INTERNAL
neighbor 192.9.9.9 peer-group PEER-INTERNAL
neighbor 192.11.11.11 peer-group PEER-INTERNAL
!
address-family ipv4
neighbor PEER-INTERNAL send-community
neighbor 155.84.74.10 activate
neighbor 192.8.8.8 activate
neighbor 192.9.9.9 activate
neighbor 192.11.11.11 activate
exit-address-family
!
ip forward-protocol nd
!
ip bgp-community new-format
!
no ip http server
no ip http secure-server
!
!
ip prefix-list GATEWAY seq 5 permit 192.168.10.13/32
!
ip prefix-list NETWORK seq 5 deny 192.199.199.199/32
ip prefix-list NETWORK seq 10 permit 0.0.0.0/0 le 32
!
!
!
control-plane
!
!
!
!
!
!
Solved! Go to Solution.
06-09-2023 03:35 AM - last edited on 06-12-2023 02:34 AM by Translator
R11
interface Ethernet0/1
ip address 192.168.10.18 255.255.255.252
ipv6 address 2001:CC1E:CAFE::17/126
R9
interface Ethernet0/0
ip address 192.168.10.9 255.255.255.252
ipv6 address 2001:CC1E:CAFE::9/126
ipv6 address 2001:CCCC:CAFE::1/126
you use different subnet in both router, it can be true in case the SW is L3 not L2, so are SW between R9 and R11 L3 or L2 SW?
06-08-2023 04:18 PM
Router1#telnet x.x.x.x 179
Check if the tcp port is open or not
06-08-2023 05:24 PM
I just copy pasted the configuration for R11 it was giving to much of a headache
06-08-2023 10:34 PM - edited 06-08-2023 10:35 PM
Hello @hfakoor222,
Please, confirm that there is IP connectivity between the loopback interfaces used as BGP router IDs on R9, R10, and R11. You can verify this by pinging the loopback addresses from each router.
Thanks.
06-09-2023 03:35 AM - last edited on 06-12-2023 02:34 AM by Translator
R11
interface Ethernet0/1
ip address 192.168.10.18 255.255.255.252
ipv6 address 2001:CC1E:CAFE::17/126
R9
interface Ethernet0/0
ip address 192.168.10.9 255.255.255.252
ipv6 address 2001:CC1E:CAFE::9/126
ipv6 address 2001:CCCC:CAFE::1/126
you use different subnet in both router, it can be true in case the SW is L3 not L2, so are SW between R9 and R11 L3 or L2 SW?
06-09-2023 07:12 AM
I noticed today I had wrong ip addresses assigned.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide