06-05-2024 12:01 PM - edited 06-05-2024 12:04 PM
Team,
I need your help for BGP prefix-list/route policy Config.
We currently have a static route with the ISP for both the primary and secondary connection.
We are now going to make it BGP.
For simplicity, I have attached a photo of the basic connection to the ISP with the makeup number.
My ISP has shared their BGP configuration for both routers, including the prefix and route policy.
I am familiar with the interface and the basic BGP configuration. However, I am encountering difficulties in configuring the prefix-list/route policy on our router.
Our sole requirement is to have Router A as the primary path and Router B as the secondary path.
Would an expert be able to assist me, please?
I greatly appreciate your help.
################################################
ISP BGP Prefix list/ route-policy config on both their router
#################################################
prefix-set CUSTOMER-routes
10.10.10.0/24
end-set
route-policy to-CUSTOMER
if destination in default-route then
pass
endif
end-policy
route-policy from-CUSTOMER
if destination in CUSTOMER-routes then
set community (5.5.5.5:1000) #####>> not sure what is this 1000
endif
end-policy
#################################################
ISP BGP config on Router A
#################################################
router bgp 5555
neighbor 1.1.1.2
remote-as 6666
password [BGP PASSWORD]
address-family ipv4 unicast
route-policy from-CUSTOMER in
route-policy to-CUSTOMER out
default-originate
#################################################
ISP BGP config on Router B
#################################################
router bgp 5555
neighbor 2.2.2.2
remote-as 6666
password [BGP PASSWORD]
address-family ipv4 unicast
route-policy from-CUSTOMER in
route-policy to-CUSTOMER out
default-originate
-------------------------------------------------------------
Customer BGP Config Router A
-------------------------------------------------------------
router bgp 6666
network 10.10.10.0 255.255.255.0
neighbor 1.1.1.1 remote-as 5555
neighbor 1.1.1.1 password [BGP PASSWORD]
address-family ipv4
neighbor 1.1.1.1 activate
-------------------------------------------------------------
Customer BGP Config Router B
-------------------------------------------------------------
router bgp 6666
network 10.10.10.0 255.255.255.0
neighbor 2.2.2.1 remote-as 5555
neighbor 2.2.2.1 password [BGP PASSWORD]
address-family ipv4
neighbor 2.2.2.1 activate
-------------------------------------------------------------
Customer BGP Prefix list/ route-policy config on both their router
-------------------------------------------------------------
???
???
???
06-06-2024 12:31 AM
Hello
Please see the attached example:
06-06-2024 09:22 AM
Hello,
Really appreciate for config file. I have just got access of our Edge router on different site and management like to have similar config if possible. I understood few config but not sure about few lines.
I am thinking to duplicate same config with new IPs.
I have attached config of that site. Is it doable to just change IP in this config and make BGP working ? My concern is I dont have ISP config of that site so cant say whether ISP config really matter or not.
Again, thank you.
06-06-2024 07:57 AM
Hello @ap9025 ,
>> set community (5.5.5.5:1000) #####>> not sure what is this 1000
it is a value chosen 5.5.5.5:1000 is a BGP standard community and the route-policy sets this value on the received prefix and accepts it if the prefix has a match on the prefix-set
route policies and prefix-sets should be IOS XR configuration elements are you sure the ISP devices are ASR 1000 that run IOS XE ?
Hope to help
Giuseppe
06-06-2024 08:46 AM
Hello @Giuseppe Larosa
my understanding here is that the XR is on the ISP PEs and the XE are the CE rtrs (hence the supplied cfg)
06-06-2024 11:07 AM
Hello,
Thank you for reply and information.
They said ASR 1000 in the past but not sure if they have replaced them recently.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide