12-03-2019 10:50 AM - edited 12-03-2019 11:24 AM
See attached topology of lab.
I am running OSPF on routers 1-4, and 10; BGP on R4-6.
I am using Lo0 for BGP neighborships, not using IGP for BGP connectivity as I have static routes.
I entered redistribute static subnets under OSPF 1 on router 4 so all OSPF routers can now ping all Lo0 of every router including R4-6 BGP routers. Would this be a good practice implementation, or is IGP usually always used on BGP routers which may connect to ISP BGP routers, etc.?
R2:
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface GigabitEthernet1/0
ip address 10.1.1.2 255.255.255.0
ip ospf message-digest-key 1 md5 cisco
ip ospf 1 area 0
negotiation auto
!
interface GigabitEthernet2/0
ip address 10.1.3.2 255.255.255.0
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 cisco
ip ospf 1 area 1
negotiation auto
!
interface GigabitEthernet3/0
ip address 10.1.4.2 255.255.255.0
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 cisco
ip ospf 1 area 1
negotiation auto
router ospf 1
router-id 2.2.2.2
network 2.2.2.2 0.0.0.0 area 1
================================
R4:
interface Loopback0
ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface GigabitEthernet1/0
bandwidth 128
ip address 10.1.4.4 255.255.255.0
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 cisco
ip ospf 1 area 1
load-interval 30
negotiation auto
!
interface GigabitEthernet2/0
ip address 11.1.3.4 255.255.255.0
negotiation auto
!
interface GigabitEthernet3/0
ip address 11.1.1.4 255.255.255.0
negotiation auto
!
interface GigabitEthernet4/0
no ip address
shutdown
negotiation auto
!
interface FastEthernet5/0
no ip address
shutdown
duplex half
!
interface FastEthernet6/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet6/1
no ip address
shutdown
duplex auto
speed auto
!
router ospf 1
router-id 4.4.4.4
redistribute bgp 4 subnets
redistribute static subnets
!
router bgp 4
bgp log-neighbor-changes
bgp redistribute-internal
network 4.4.4.4 mask 255.255.255.255
network 11.1.1.0 mask 255.255.255.0
network 11.1.3.0 mask 255.255.255.0
redistribute ospf 1
neighbor cisco peer-group
neighbor cisco ebgp-multihop 255
neighbor cisco update-source Loopback0
neighbor cisco version 4
neighbor 5.5.5.5 remote-as 5
neighbor 5.5.5.5 peer-group cisco
neighbor 6.6.6.6 remote-as 6
neighbor 6.6.6.6 peer-group cisco
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip route 5.5.5.5 255.255.255.255 11.1.1.5
ip route 6.6.6.6 255.255.255.255 11.1.3.6
================================
R5:
interface Loopback0
ip address 5.5.5.5 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface GigabitEthernet1/0
ip address 11.1.2.5 255.255.255.0
negotiation auto
!
interface GigabitEthernet2/0
ip address 11.1.1.5 255.255.255.0
negotiation auto
!
interface GigabitEthernet3/0
ip address 12.1.1.5 255.255.255.0
ip ospf 1 area 0
negotiation auto
!
interface GigabitEthernet4/0
no ip address
shutdown
negotiation auto
!
interface FastEthernet5/0
no ip address
shutdown
duplex half
!
interface FastEthernet6/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet6/1
no ip address
shutdown
duplex auto
speed auto
!
router ospf 1
redistribute bgp 5 subnets
!
router bgp 5
bgp log-neighbor-changes
bgp redistribute-internal
network 5.5.5.5 mask 255.255.255.255
network 11.1.1.0 mask 255.255.255.0
network 11.1.2.0 mask 255.255.255.0
network 12.1.1.0 mask 255.255.255.0
neighbor cisco peer-group
neighbor cisco remote-as 5
neighbor cisco ebgp-multihop 255
neighbor cisco update-source Loopback0
neighbor cisco version 4
neighbor 4.4.4.4 remote-as 4
neighbor 4.4.4.4 peer-group cisco
neighbor 6.6.6.6 remote-as 6
neighbor 6.6.6.6 peer-group cisco
neighbor 10.10.10.10 remote-as 5
neighbor 10.10.10.10 next-hop-self
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip route 4.4.4.4 255.255.255.255 11.1.1.4
ip route 6.6.6.6 255.255.255.255 11.1.2.6
Solved! Go to Solution.
12-03-2019 02:04 PM
Hello,
you changed your original post, but just keep in mind that by default, when you redistribute BGP into any IGP, OSPF in your case, it will not redistribute routes learned from iBGP
12-03-2019 02:04 PM
Hello,
you changed your original post, but just keep in mind that by default, when you redistribute BGP into any IGP, OSPF in your case, it will not redistribute routes learned from iBGP
12-04-2019 06:26 AM
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide