cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
559
Views
5
Helpful
15
Replies
ccollins
Beginner

C1101 IP address command not present

I have a brand new C1101 that came with 16.12.4. The command "ip address" is not an option:

>en
Password:
newswitch#conf t
Enter configuration commands, one per line. End with CNTL/Z.
newswitch(config)#int gi0/1/0
newswitch(config-if)#switchport host
switchport mode will be set to access
spanning-tree portfast will be enabled
channel group will be disabled

newswitch(config-if)#ip add?
% Unrecognized command

 

Can someone provide direction or documentation? The Documentation I have read so far indicates the command should exist.

15 REPLIES 15
balaji.bandi
VIP Master

Try below :

 

 

int gi0/1/0

no switchport

ip address x.x.x

BB

***** Rate All Helpful Responses *****

How to Ask The Community for Help

Thank you for your reply.

I had tried that:
#no switchport
% Incomplete command.
Newswitch(config-if)#no switchport ?
access Set access mode characteristics of the interface
autostate Include or exclude this port from vlan link up calculation
host Set port host
mode Set trunking mode of the interface
nonegotiate Device will not engage in negotiation protocol on this
interface
port-security Security related command
priority Set appliance 802.1p priority
protected Configure an interface to be a protected port
trunk Set trunking characteristics of the interface
voice Voice appliance attributes

newswitch(config-if)#no switchport host
The 'no' form of this command has no effect on the system.

I also tried no switchport at the non-interface level and it failed as well.

apologies, ISR router - I gave in the thought of the Layer 3 switch.

 

ISR router you need to create Layer 3 SVI and allocate the port to that VLAN as an access port, how we do in switches.

 

example config :

 

https://www.cisco.com/c/en/us/td/docs/routers/access/1100/software/configuration/xe-16-7/cisco_1100_series_swcfg_xe_16_7_x/cisco_1100_series_swcfg_chapter_01100.html

BB

***** Rate All Helpful Responses *****

How to Ask The Community for Help

ccollins
Beginner

The following are the IP options available under an Interface:

Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int gi 0/1/0
Router(config-if)#ip ?
Interface IP configuration subcommands:
access-group Specify access control for packets
admission Apply Network Admission Control
auth-proxy Apply authenticaton proxy
ddns Configure dynamic DNS
dhcp Configure DHCP parameters for this interface
flow NetFlow related commands
header-compression IPHC options
reassembly Reassembly
rsvp RSVP Interface Commands
rtp RTP parameters
subscriber IP session configuration options
virtual-reassembly Enable Virtual Fragment Reassembly (Input)
virtual-reassembly-out Enable Virtual Fragment Reassembly (Output)

ccollins
Beginner

I am not sure why this is the case, but it appears that I am only able to apply IP addressed to VLAN interfaces. THE C1101-4P IS A ROUTER!!!!! UGH

 

Yes the C1101 is a router. But it treats its physical interfaces like they were switch ports. It may be a bit cumbersome but you should be able to make it do whatever you want it to do. If you want every physical interface to be in a separate subnet (as is normal on most traditional routers) then just create separate vlans for each physical interface, assign each physical interface to the appropriate vlan, configure IP addresses on each vlan interface. 

HTH

Rick

Thank you for your reply.
I was just getting suspicious that there was something wrong because the ISR 1100 documentation shows the IP address command being applied directly to the Interface and I did not see any examples of applying IP addresses to the VLAN.
https://www.cisco.com/c/en/us/td/docs/routers/access/isr1100/software/configuration/xe-17/isr1100-sw-config-xe-17/cisco_1100_series_swcfg_chapter_01000.html#task_u14_k1m_1z
Another weird thing with the C1101-4P is that show version says there are 5 Gigabit Ethernet Interfaces and I see 5 Physical interfaces but only 4 are reported in the configuration and show interface. But I guess that is what the 4P dictates.

I received three C1101-4P units. The third unit unlike the other two has a gi 0/0/0 interface. The other two just have four ports gi0/1/0-3. The setup wizard asked me to setup gi 0/0/0 and gi0/1/0-3 on the third unit, so I provided IP addresses for each interface, but the only IP address that was applied was for interface gi0/0/0.
Leo Laohoo
VIP Community Legend

What is the exact model of the router?

Is the router running SD-WAN image?

It is not. This is a very simple static route configuration.

 

cisco C1101-4P (1RU) processor with 1414527K/6147K bytes of memory.

System image file is "bootflash:c1100-universalk9.17.03.03.SPA.bin"

 

There was an oversight in previous inspections.  Gi0/0/0 it is there and does not require vlan allocation like the other ports Gi0/1/0-3. But still odd that the setup wizard would prompt to apply IP address to all the interfaces when that is not possible on this version.

 

 

Connect the console, reboot and capture all the Logs including your configuration errors and post here.

 

BB

***** Rate All Helpful Responses *****

How to Ask The Community for Help

Thank you for your time in review the attached.

The attached files have been changed to protect actual addresses, accounts, and such. 

If you configuring Gi 0/1/0 to 0/1/3 Layer 2 portrs only you need to configure VLAN SVI inteface as example config

 

interface Vlan7
ip address 192.168.233 255.255.255.240
!
interface Vlan13
ip address 192.168.156.153 255.255.255.252
!
interface Vlan26
ip address 192.168.197.111 255.255.254.0
!

 

and allocated interface to VLAN as example :

 

 

nterface GigabitEthernet0/1/0
switchport mode access

switchport access vlan 26

spanning-tree portfast
!
interface GigabitEthernet0/1/1
switchport mode access

switchport access vlan 7
spanning-tree portfast
!
interface GigabitEthernet0/1/2
switchport mode access

switchport access vlan 13

spanning-tree portfast

BB

***** Rate All Helpful Responses *****

How to Ask The Community for Help

Thank you for your response.
I was aware of this option. Just a little misleading when the Cisco initial setup script asks if you would like to add IP addresses directly to the interfaces when it is not in fact possible.