08-12-2021 03:02 AM
Building configuration...
Current configuration : 1588 bytes
!
! Last configuration change at 09:56:00 UTC Thu Aug 12 2021
!
version 15.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
enable secret 5 $1$ft/u$pmj7///cxuFcnkHInnjFx.
!
no aaa new-model
!
!
!
!
!
!
!
!
!
!
!
ip dhcp excluded-address 192.168.1.1 192.168.1.30
!
ip dhcp pool vlan1pool
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 8.8.8.8
!
!
!
ip cef
no ipv6 cef
!
!
!
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
cts logging verbose
license udi pid C881-K9 sn FCZ212192AQ
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0
no ip address
!
interface FastEthernet1
no ip address
!
interface FastEthernet2
no ip address
!
interface FastEthernet3
no ip address
!
interface FastEthernet4
ip address dhcp
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
!
interface Vlan1
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip nat inside source list 1 interface FastEthernet4 overload
ip route 0.0.0.0 0.0.0.0 dhcp
!
!
access-list 1 permit 192.168.1.0 0.0.0.255
!
control-plane
!
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
!
!
!
!
!
!
line con 0
no modem enable
line aux 0
line vty 0 4
login
transport input none
!
scheduler allocate 20000 1000
!
!
!
end
08-12-2021 03:35 AM
Hello,
the config looks good as far as I can tell. The only change I could think of is the line marked in bold:
Current configuration : 1588 bytes
!
! Last configuration change at 09:56:00 UTC Thu Aug 12 2021
!
version 15.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$ft/u$pmj7///cxuFcnkHInnjFx.
!
no aaa new-model
!
ip dhcp excluded-address 192.168.1.1 192.168.1.30
!
ip dhcp pool vlan1pool
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 8.8.8.8
!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
cts logging verbose
license udi pid C881-K9 sn FCZ212192AQ
!
interface FastEthernet0
no ip address
!
interface FastEthernet1
no ip address
!
interface FastEthernet2
no ip address
!
interface FastEthernet3
no ip address
!
interface FastEthernet4
ip address dhcp
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
!
interface Vlan1
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
ip nat inside source list 1 interface FastEthernet4 overload
--> ip route 0.0.0.0 0.0.0.0 FastEthernet4
!
access-list 1 permit 192.168.1.0 0.0.0.255
!
control-plane
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
line con 0
no modem enable
line aux 0
line vty 0 4
login
transport input none
!
scheduler allocate 20000 1000
!
end
08-12-2021 07:17 AM
same problem
08-12-2021 03:39 AM
change routing as below and test it.
ip route 0.0.0.0 0.0.0.0 FastEthernet4 dhcp
or
ip route 0.0.0.0 0.0.0.0 FastEthernet4
08-12-2021 03:50 AM
same problem
08-12-2021 04:08 AM - edited 08-12-2021 04:09 AM
Can you post updated information :
show version
show run
show ip interface brief
show ip route
show interface FastEthernet4
show interface FastEthernetX ( X where the device connected or switch connected ?)
what is the end user IP address ? ( what device you testing ?)
From end device are you able to ping Router 192.168.1.1 ?
08-12-2021 07:16 AM
show version
Device# PID SN
-------------------------------------------------
*1 C881-K9 FCZ212192AQ
show run
hostname Router
!
boot-start-marker
boot-end-marker
enable secret 5 $1$ft/u$pmj7///cxuFcnkHInnjFx.
no aaa new-model
ip dhcp excluded-address 192.168.1.1 192.168.1.30
ip dhcp pool vlan1pool
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 8.8.8.8
ip cef
no ipv6 cef
multilink bundle-name authenticated
cts logging verbose
license udi pid C881-K9 sn FCZ212192AQ
interface FastEthernet0
no ip address
interface FastEthernet1
no ip address
interface FastEthernet2
no ip address
interface FastEthernet3
no ip address
interface FastEthernet4
ip address dhcp
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
interface Vlan1
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
ip forward-protocol nd
ip http server
no ip http secure-server
ip nat inside source list 1 interface FastEthernet4 overload
ip route 0.0.0.0 0.0.0.0 FastEthernet4
access-list 1 permit 192.168.1.0 0.0.0.255
control-plane
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
mgcp profile default
line con 0
no modem enable
line aux 0
line vty 0 4
login
transport input none
scheduler allocate 20000 1000
end
Router#show ip interface brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0 unassigned YES unset up up
FastEthernet1 unassigned YES unset up down
FastEthernet2 unassigned YES unset up down
FastEthernet3 unassigned YES unset up down
FastEthernet4 192.192.0.153 YES DHCP up up
NVI0 unassigned YES unset administratively down down
Vlan1 192.168.1.1 YES NVRAM up up
show ip route
Gateway of last resort is 0.0.0.0 to network 0.0.0.0
S* 0.0.0.0/0 is directly connected, FastEthernet4
192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.1.0/24 is directly connected, Vlan1
L 192.168.1.1/32 is directly connected, Vlan1
C 192.192.0.0/16 is directly connected, FastEthernet4
192.192.0.0/32 is subnetted, 1 subnets
L 192.192.0.153 is directly connected, FastEthernet4
show fast interface4
Internet address is 192.192.0.153/16
show interface vlan 1
Internet address is 192.168.1.1/24
what is the end user IP address ?
IPv4 Address. . . . . . . . . . . : 192.168.1.31
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.1.1
From end device are you able to ping Router 192.168.1.1 ?
yes
08-12-2021 07:33 AM
Hello,
do you see any NAT entries at all when you try and access the Internet from a client PC (show ip nat translation *) ?
Try an extended access list (changes marked in bold
Current configuration : 1588 bytes
!
! Last configuration change at 09:56:00 UTC Thu Aug 12 2021
!
version 15.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$ft/u$pmj7///cxuFcnkHInnjFx.
!
no aaa new-model
!
ip dhcp excluded-address 192.168.1.1 192.168.1.30
!
ip dhcp pool vlan1pool
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 8.8.8.8
!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
cts logging verbose
license udi pid C881-K9 sn FCZ212192AQ
!
interface FastEthernet0
no ip address
!
interface FastEthernet1
no ip address
!
interface FastEthernet2
no ip address
!
interface FastEthernet3
no ip address
!
interface FastEthernet4
ip address dhcp
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
!
interface Vlan1
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
--> ip nat inside source list NAT interface FastEthernet4 overload
--> ip route 0.0.0.0 0.0.0.0 FastEthernet4
!
-->ip access-list extended NAT
--> permit ip 192.168.1.0 0.0.0.255 any
!
control-plane
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
line con 0
no modem enable
line aux 0
line vty 0 4
login
transport input none
!
scheduler allocate 20000 1000
!
end
08-12-2021 08:42 AM
Config wise i do not see any issue here.
is the device configed Manually the IP address ? ( or DHCP ?)
what is the end user IP address ?
IPv4 Address. . . . . . . . . . . : 192.168.1.31
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.1.1
if you get chance post ipconfig /all (from PC to Look)
There are 2 options here.
Option1 :
1. Enable debug on the Router (debug ip nat translations and debug ip packet), see the NAT Translation working or not.
2. traceroute from PC 8.8.8.8
3. Pc nslookup google.com (is this resolves)
Option 2 :
@Georg Pauwen agree here to factory reset and test it. ( but again if you stuck with same issue, still you need to Options 1)
08-12-2021 11:34 PM
is the device configed Manually the IP address ? ( or DHCP ?)
DHCP
traceroute from PC 8.8.8.8
tracert 8.8.8.8
Tracing route to 8.8.8.8 over a maximum of 30 hops
1 <1 ms <1 ms <1 ms 192.168.1.1
2 * * * Request timed out.
3 ^C
Pc nslookup google.com (is this resolves)
nslookup google.com
DNS request timed out.
timeout was 2 seconds.
Server: UnKnown
Address: 192.168.1.1
DNS request timed out.
timeout was 2 seconds.
DNS request timed out.
timeout was 2 seconds.
DNS request timed out.
timeout was 2 seconds.
DNS request timed out.
timeout was 2 seconds.
*** Request to UnKnown timed-out
08-13-2021 03:58 AM - edited 08-13-2021 09:12 AM
Some how your PC configured as DHCP you should get DNS Server as 8.8.8.8 but looks you are Looking DNS Server as 192.168.1.1 here ?
seup dns server to 8.8.8.8 and try to browse google.com see if this works.
save and then do nslooku google.com (post the output)
also while doing that enable "(debug ip nat translations and debug ip packet)" post the logs ?
also post latest show run
08-12-2021 07:06 AM
Hello,
on a side note, the config is good. I have seen cases where just erasing the entire configuration (wr erase) and reentering everything makes the router work again. If nothing else helps, that would be an option...it takes about 10 minutes.
08-12-2021 11:24 PM
hello
it is the 5th time that i reset it but same problem
08-13-2021 07:34 AM
Hello,
I remember that sometimes (I think on the older platforms) you have to configure 'ip routing' globally:
Router#conf t
Router(config)#ip routing
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide