cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
803
Views
15
Helpful
9
Replies

can we create multiple vrf/address families with eigrp numbered mode.

i am trying to create vrf and have eigrp routing enabled. my IOS doesnt support eigrp named mode. configured like this, but cannnot see any eigrp debug events/neighbors forming or any comms.

 

router eigrp 100
no auto-summary
!
address-family ipv4 vrf red
network 10.0.12.0 0.0.0.255
network 10.0.24.0 0.0.0.255
no auto-summary
exit-address-family
!
router eigrp 200
no auto-summary
!
address-family ipv4 vrf green
network 172.16.12.0 0.0.0.255
network 172.16.23.0 0.0.0.255
no auto-summary
exit-address-family
!
router eigrp 300
no auto-summary
!
address-family ipv4 vrf blue
network 192.168.12.0
network 192.168.23.0
no auto-summary
exit-address-family

2 Accepted Solutions

Accepted Solutions

Hello @ahmedsid432135621 ,

try to add the autonomous-system command within the address-family vrf green context.

 

 

Hope to help

Giuseppe

View solution in original post

9 Replies 9

Hello,

 

this should work. Make sure the 'autonomous-system' keyword is added to the address family, and the corresponding interfaces are in the correct VRFs. Here is an example:

 

R1

 

ip vrf red
rd 1:1
!
interface GigabitEthernet0/0
ip vrf forwarding red
ip address 192.168.1.1 255.255.255.252
duplex auto
speed auto
media-type rj45
!
router eigrp 100
!
address-family ipv4 vrf red autonomous-system 100
network 0.0.0.0
exit-address-family
!


R2

 

ip vrf red
rd 1:1
!
interface GigabitEthernet0/0
ip vrf forwarding red
ip address 192.168.1.2 255.255.255.252
duplex auto
speed auto
media-type rj45
!
router eigrp 100
!
address-family ipv4 vrf red autonomous-system 100
network 0.0.0.0
exit-address-family
!

balaji.bandi
Hall of Fame
Hall of Fame

yes, you can create number mode, named mode only get an advantage when you have a large number of peers to configure. otherwise not a big change.(less admin task)

 

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

R1(config-router)#address-family ipv4 vrf red ?
<cr>

 

not getting the option for AS, IOS version  Version 12.4(24)T5, 

Hello,

 

12.4 is (obviously) ancient. Are your interfaces in the correct VRF ? If they are, you run into the limitations of the 12.4 version, and your only option is to upgrade.

so why is this command "address-family ipv4 vrf green" still alllowed, is there a way around to do it with this IOS, im guessing the vrf feature was still around at the time of this IOS.

Hello,

 

not sure why the 'vrf' keyword is there, but apparently doesn't work. Can you post the entire configuration you have ?

Hello @ahmedsid432135621 ,

try to add the autonomous-system command within the address-family vrf green context.

 

 

Hope to help

Giuseppe

see this note fgdlgjl.png

thanks, that worked

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card