cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
202
Views
2
Helpful
2
Replies

Cannot get BGP to Redistribute into EIGRP

pevans1970
Level 1
Level 1

IOU3#sh ip route bgp | begin Gateway
Gateway of last resort is not set

B 4.0.0.0/8 [200/0] via 192.168.34.4, 00:02:05
IOU3#
IOU3#sh ip route 4.0.0.0
Routing entry for 4.0.0.0/8
Known via "bgp 100", distance 200, metric 0, type internal
Last update from 192.168.34.4 00:02:05 ago
Routing Descriptor Blocks:
* 192.168.34.4, from 192.168.34.4, 00:02:05 ago
Route metric is 0, traffic share count is 1
AS Hops 0
MPLS label: none
IOU3#
IOU3#sh run | section router
router eigrp 1
network 192.168.23.0
redistribute bgp 100 metric 1000 1 255 1 1500
eigrp router-id 3.3.3.3
router bgp 100
bgp router-id 3.3.3.3
bgp log-neighbor-changes
neighbor 192.168.34.4 remote-as 100
IOU3#
IOU3#sh ip eigrp neigh
EIGRP-IPv4 Neighbors for AS(1)
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 192.168.23.2 Et0/0 13 00:21:46 30 180 0 40
IOU3#
IOU3#sh ip eigrp topology
EIGRP-IPv4 Topology Table for AS(1)/ID(3.3.3.3)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status

P 192.168.23.0/24, 1 successors, FD is 281600
via Connected, Ethernet0/0

IOU3#

IOU3#sh cdp neigh | begin Device
Device ID Local Intrfce Holdtme Capability Platform Port ID
IOU2 Eth 0/0 171 R B Linux Uni Eth 0/0
IOU4 Eth 0/3 174 R B Linux Uni Eth 0/3

#########################################################################

IOU2#sh ip eigrp ne
EIGRP-IPv4 Neighbors for AS(1)
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
1 192.168.23.3 Et0/0 12 00:23:28 31 186 0 7
IOU2# sh ip route | begin Gat
Gateway of last resort is not set

192.168.23.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.23.0/24 is directly connected, Ethernet0/0
L 192.168.23.2/32 is directly connected, Ethernet0/0
IOU2#sh run | section router eigrp
router eigrp 1
network 0.0.0.0
eigrp router-id 2.2.2.2
IOU2#

1 Accepted Solution

Accepted Solutions

Harold Ritter
Cisco Employee
Cisco Employee

Hi @pevans1970 ,

By default, iBGP routes are not redistributed into the IGP. You need to configure the following command for this to happen.

router bgp 100

bgp redistribute-internal

Regards,

 

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

View solution in original post

2 Replies 2

Harold Ritter
Cisco Employee
Cisco Employee

Hi @pevans1970 ,

By default, iBGP routes are not redistributed into the IGP. You need to configure the following command for this to happen.

router bgp 100

bgp redistribute-internal

Regards,

 

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

pevans1970
Level 1
Level 1

Thanks so much for your quick and accurate solution.

Review Cisco Networking for a $25 gift card