ā11-20-2017 06:37 AM - edited ā03-05-2019 09:31 AM
I'm a third year comp-sci student, and having trouble with some basic setup of my network in packet tracer. My main issue is that I cannot send packets between ACMER1 to ACMER2, and ACMER1 to ACMER3. I am pretty sure I'm supposed to implement some variation of a static route, but for the life of me cannot figure out why I can't get it to work. I am sure this a simple fix and that I'll kick myself if I figure it out.
My network topology:
Here are my "show running-config"'s below:
ACMER1:
Current configuration : 1451 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
service password-encryption
!
hostname Router
!
login block-for 300 attempts 2 within 120
!
!
enable secret 5 $1$mERr$hx5rVt7rPNoS4wqbXKX7m0
!
!
!
!
!
!
no ip cef
Router#
Router#
Router#show running-config
Building configuration...
Current configuration : 1451 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
service password-encryption
!
hostname Router
!
login block-for 300 attempts 2 within 120
!
!
enable secret 5 $1$mERr$hx5rVt7rPNoS4wqbXKX7m0
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
username ACMER1 password 7 0822455D0A16
!
!
!
!
!
!
!
!
no ip domain-lookup
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.1.18.126 255.255.255.128
duplex auto
speed auto
!
interface Serial0/0/0
ip address 172.16.1.153 255.255.255.252
clock rate 2000000
!
interface Serial0/0/1
ip address 172.16.0.73 255.255.255.252
encapsulation ppp
ppp authentication chap
clock rate 2000000
!
interface Vlan1
no ip address
shutdown
!
router ospf 1
router-id 1.1.1.1
log-adjacency-changes
network 10.1.18.0 0.0.0.127 area 1
network 172.16.1.152 0.0.0.3 area 0
network 172.16.0.72 0.0.0.3 area 0
!
ip classless
ip route 0.0.0.0 0.0.0.0 0.0.0.0
!
ip flow-export version 9
!
!
ip access-list extended sl_def_acl
deny tcp any any eq telnet
deny tcp any any eq www
deny tcp any any eq 22
permit tcp any any eq 22
!
no cdp run
!
banner motd ^C
This router is managed by 1404956 ^C
!
!
!
!
line con 0
password 7 0822455D0A16
login
!
line aux 0
!
line vty 0 4
access-class TELNET in
password 7 0822455D0A16
login
line vty 5 15
password 7 0822455D0A16
login
!
!
!
end-------------------------------------------------
Current configuration : 1451 bytes
!
version 15.1
service timestamps log datetime msec
no service timestamps debug datetime msec
service password-encryption
!
hostname Router
!
logging userinfo
!
!
enable secret 5 $1$mERr$hx5rVt7rPNoS4wqbXKX7m0
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
username ACMER2 password 7 0822455D0A16
!
!
license udi pid CISCO2911/K9 sn FTX15240EF0
license boot module c2900 technology-package securityk9
!
!
!
!
!
!
!
!
!
no ip domain-lookup
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
ip address 202.202.18.155 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface GigabitEthernet0/2
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/0/0
ip address 172.16.0.74 255.255.255.252
encapsulation ppp
ppp authentication chap
clock rate 2000000
!
interface Serial0/0/1
ip address 172.16.2.73 255.255.255.252
clock rate 2000000
!
interface Serial0/1/0
no ip address
clock rate 2000000
shutdown
!
interface Serial0/1/1
no ip address
clock rate 2000000
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 0.0.0.0
!
ip flow-export version 9
!
!
!
no cdp run
!
banner motd ^C
This router is managed by 1404956 ^C
!
!
!
!
no logging trap
line con 0
password 7 0822455D0A16
login
!
line aux 0
!
line vty 0 4
password 7 0822455D0A16
login
line vty 5 15
password 7 0822455D0A16
login
!
!
!
end-------------------------------------------------
ACMER3
Current configuration : 900 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
service password-encryption
!
hostname Router
!
!
!
enable secret 5 $1$mERr$hx5rVt7rPNoS4wqbXKX7m0
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
no ip domain-lookup
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/0
ip address 10.2.21.126 255.255.255.128
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/0/0
ip address 172.16.1.154 255.255.255.252
clock rate 2000000
!
interface Serial0/0/1
ip address 172.16.2.74 255.255.255.252
!
interface Vlan1
no ip address
shutdown
!
ip classless
!
ip flow-export version 9
!
!
!
no cdp run
!
!
!
!
!
line con 0
password 7 0822455D0A16
login
!
line aux 0
!
line vty 0 4
password 7 0822455D0A16
login
line vty 5 15
password 7 0822455D0A16
login
!
!
!
end-------------------------------------------------
Any help/guidence is greatly appreciated
Solved! Go to Solution.
ā11-27-2017 07:28 AM
You are welcome. I am glad that our suggestions were helpful. Thank you for posting back to the forum to let us know that you have resolved the problem and that it was issues in the configuration of IP addressing on the interfaces.
HTH
Rick
ā11-20-2017 07:17 AM
There are multiple things in these configs that need to be addressed.
- your first router is configured for OSPF but not your second or third router. dynamic routing would be one way to establish connectivity between these networks. But if you want to use dynamic routing then it needs to be configured on all three routers.
- your comment suggests that the point of this configuration is about static routes. If that is the case then why is dynamic routing configured on one router?
- the static default route on each of the 3 routers is not correct. You have
ip route 0.0.0.0 0.0.0.0 0.0.0.0
what is not correct is that you are specifying 0.0.0.0 as the next hop address. You need to specify an appropriate IP address that is connected to the router.
- you have configured the serial interfaces but we can not determine what state the interfaces are in. Can you post the output of the command show ip interface brief from each of the routers. It might also be helpful if you post the output of the command show cdp neighbor from each of the routers.
- one of the serial links is configured to use ppp and to authenticate with chap. But I do not see the parameters that would allow chap authentication to be successful.
- the first router is configured with access-class on the vty. But the access list specified for the access-class is not in the config.
HTH
Rick
ā11-20-2017 07:34 AM
Appologies on not including all the required information, I am new to forum posting for guidence. Your reply is greatly appreciated!
OSPF is enabled on ACMER1 because it was me just trying to get it to work initially, but then not removing it after it failed to work. The default route was also me just trying something to see if it'd work. I know this is not the way to troubleshoot, but I've been tearing my hair out to at this point. Bellow is the task I am currently on in my assignment:
"
Task 3: Configure Routing
You should be using as few static routes as possible in this assignment, any unnecessary static routes (e.g. because of an incorrectly configured routing protocol) will cause a loss of some marks.
- You are to assume that ACME, OtherISP and ISP are all separate autonomous systems that are part of the Internet and that there may be many more autonomous systems connected to ISP and OtherISP that are not shown.
- Configure OSPF and BGP in the appropriate places based on the correct use of interior and external gateway protocols. The Autonomous System (AS) numbers are given to you in the separate web page (each student has unique AS numbers).
- Configure appropriate default and static routes (keeping these to the absolute minimum). Default route(s) should be distributed appropriately.
- Note that dynamic routing does not currently work across GRE so you should only use static routes inside the SOHO network (and to the SOHO network). You should note that, at this stage, you should have internal connectivity inside the ACME network, but only connectivity to Internet systems using public source addresses (e.g. from the ACMEWebServer). Other connectivity depends upon NAT and the GRE tunnel."
"cdp is not enabled" on all three routers
Bellow is the "show ip brief" result on all three routers:
ACMER1
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 unassigned YES unset up down
FastEthernet0/1 10.1.18.126 YES manual up up
Serial0/0/0 172.16.1.153 YES manual up down
Serial0/0/1 172.16.0.73 YES manual up down
Vlan1 unassigned YES unset administratively down down
ACMER2
Interface IP-Address OK? Method Status Protocol
GigabitEthernet0/0 202.202.18.155 YES manual up up
GigabitEthernet0/1 unassigned YES unset administratively down down
GigabitEthernet0/2 unassigned YES unset administratively down down
Serial0/0/0 172.16.0.74 YES manual up down
Serial0/0/1 172.16.2.73 YES manual up up
Serial0/1/0 unassigned YES unset administratively down down
Serial0/1/1 unassigned YES unset administratively down down
Vlan1 unassigned YES unset administratively down down
ACMER3
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 10.2.21.126 YES manual up down
FastEthernet0/1 unassigned YES unset administratively down down
Serial0/0/0 172.16.1.154 YES manual up down
Serial0/0/1 172.16.2.74 YES manual up up
Vlan1 unassigned YES unset administratively down down
ā11-20-2017 07:50 AM
Thanks for the additional information. Based on this I believe that your attempt to configure OSPF was the direction in which you need to focus. And what was in your original post for the first router was a reasonable start. You would want similar configurations on both other routers. This would provide connectivity between the networks in this AS.
The biggest reason that things are not working at this point is some issue with configuration of the serial interfaces. As you can see in this output
Serial0/0/0 172.16.1.153 YES manual up down
Serial0/0/1 172.16.0.73 YES manual up down
So you need to figure out why these interfaces are line protocol down.
The good news is that one of your serial interfaces is up/up
Serial0/0/1 172.16.2.73 YES manual up up
HTH
Rick
ā11-20-2017 07:27 AM
Hi @ITgrad
Let me help you in some config:
On router ACMER1 you create dynamic routing and one static route, but, the static route is incorrect:
ip route 0.0.0.0 0.0.0.0 0.0.0.0
the correct should be:
ip route 0.0.0.0 0.0.0.0 172.16.0.74
Router ACMER2 know both route so they dont need static route.
On router ACMER3, you didn't create any routing statement, but you should have:
ip route 0.0.0.0 0.0.0.0 0.0.0.0 172.16.2.73
This way, you should be able to ping among routers.
Try this and let me know. If possible, attach you pkt file below. You need to rename it to txt file otherwise you can“t attach.
-If I helped you somehow, please, rate it as useful.-
ā11-20-2017 07:53 AM
ā11-20-2017 07:29 AM
Hello,
in addition to Richard's post...can you post the .pkt file ? You need to rename it to .jpg first, otherwise you cannot upload...
ā11-20-2017 07:42 AM
ā11-20-2017 07:58 AM
Try to add dynamic and static route as required and test again, this should work. If you fail, then, let me know.
-If I helped you somehow, please, rate it as useful.-
ā11-20-2017 08:24 AM
ā11-20-2017 08:49 AM
Which version of Packet Tracer are you using ? I cannot open this in 6.2, 6.3, 7.0, or 7.1.
ā11-20-2017 07:42 AM
Please decide which way you want to go
1. Static Routing
2. Dynamic Routing
3. Mixed Environment.
1. Static Routing, You might want to point default to other router if want to use static.
ip route 0.0.0.0 0.0.0.0 a.b.c.d ( Replace this with 0.0.0.0 and put other router's IP address )
Its better to give more specific routes instead of 0.0.0.0, if you know the networks on other side ( unless you want to send traffic to internet )
2. Dynamic Routing :- Please do similar config of Router 2 and Router 3 ( as its done on router 1 ) .
3 Mixed Routing :- Please configure two with dynamic and point a default of third one to any of the dynamically configured Router.
ā11-20-2017 07:45 AM
I am required to set up a varition of a static route(s), and then implement ospf across the ACMER routers
ā11-20-2017 07:53 AM
You can do dynamic routing between 1 and 2 and static between 2 and 3.
Just setup OSPF on 2 and static on 3 and you are good.
You're going to decide out that OSPF on serial link may require some additional commands but as you're leaning, this is nice for you.
-If I helped you somehow, please, rate it as useful.-
ā11-20-2017 08:15 AM
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide