11-20-2017 06:37 AM - edited 03-05-2019 09:31 AM
I'm a third year comp-sci student, and having trouble with some basic setup of my network in packet tracer. My main issue is that I cannot send packets between ACMER1 to ACMER2, and ACMER1 to ACMER3. I am pretty sure I'm supposed to implement some variation of a static route, but for the life of me cannot figure out why I can't get it to work. I am sure this a simple fix and that I'll kick myself if I figure it out.
My network topology:
Here are my "show running-config"'s below:
ACMER1:
Current configuration : 1451 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
service password-encryption
!
hostname Router
!
login block-for 300 attempts 2 within 120
!
!
enable secret 5 $1$mERr$hx5rVt7rPNoS4wqbXKX7m0
!
!
!
!
!
!
no ip cef
Router#
Router#
Router#show running-config
Building configuration...
Current configuration : 1451 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
service password-encryption
!
hostname Router
!
login block-for 300 attempts 2 within 120
!
!
enable secret 5 $1$mERr$hx5rVt7rPNoS4wqbXKX7m0
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
username ACMER1 password 7 0822455D0A16
!
!
!
!
!
!
!
!
no ip domain-lookup
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.1.18.126 255.255.255.128
duplex auto
speed auto
!
interface Serial0/0/0
ip address 172.16.1.153 255.255.255.252
clock rate 2000000
!
interface Serial0/0/1
ip address 172.16.0.73 255.255.255.252
encapsulation ppp
ppp authentication chap
clock rate 2000000
!
interface Vlan1
no ip address
shutdown
!
router ospf 1
router-id 1.1.1.1
log-adjacency-changes
network 10.1.18.0 0.0.0.127 area 1
network 172.16.1.152 0.0.0.3 area 0
network 172.16.0.72 0.0.0.3 area 0
!
ip classless
ip route 0.0.0.0 0.0.0.0 0.0.0.0
!
ip flow-export version 9
!
!
ip access-list extended sl_def_acl
deny tcp any any eq telnet
deny tcp any any eq www
deny tcp any any eq 22
permit tcp any any eq 22
!
no cdp run
!
banner motd ^C
This router is managed by 1404956 ^C
!
!
!
!
line con 0
password 7 0822455D0A16
login
!
line aux 0
!
line vty 0 4
access-class TELNET in
password 7 0822455D0A16
login
line vty 5 15
password 7 0822455D0A16
login
!
!
!
end-------------------------------------------------
Current configuration : 1451 bytes
!
version 15.1
service timestamps log datetime msec
no service timestamps debug datetime msec
service password-encryption
!
hostname Router
!
logging userinfo
!
!
enable secret 5 $1$mERr$hx5rVt7rPNoS4wqbXKX7m0
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
username ACMER2 password 7 0822455D0A16
!
!
license udi pid CISCO2911/K9 sn FTX15240EF0
license boot module c2900 technology-package securityk9
!
!
!
!
!
!
!
!
!
no ip domain-lookup
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
ip address 202.202.18.155 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface GigabitEthernet0/2
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/0/0
ip address 172.16.0.74 255.255.255.252
encapsulation ppp
ppp authentication chap
clock rate 2000000
!
interface Serial0/0/1
ip address 172.16.2.73 255.255.255.252
clock rate 2000000
!
interface Serial0/1/0
no ip address
clock rate 2000000
shutdown
!
interface Serial0/1/1
no ip address
clock rate 2000000
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 0.0.0.0
!
ip flow-export version 9
!
!
!
no cdp run
!
banner motd ^C
This router is managed by 1404956 ^C
!
!
!
!
no logging trap
line con 0
password 7 0822455D0A16
login
!
line aux 0
!
line vty 0 4
password 7 0822455D0A16
login
line vty 5 15
password 7 0822455D0A16
login
!
!
!
end-------------------------------------------------
ACMER3
Current configuration : 900 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
service password-encryption
!
hostname Router
!
!
!
enable secret 5 $1$mERr$hx5rVt7rPNoS4wqbXKX7m0
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
no ip domain-lookup
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/0
ip address 10.2.21.126 255.255.255.128
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/0/0
ip address 172.16.1.154 255.255.255.252
clock rate 2000000
!
interface Serial0/0/1
ip address 172.16.2.74 255.255.255.252
!
interface Vlan1
no ip address
shutdown
!
ip classless
!
ip flow-export version 9
!
!
!
no cdp run
!
!
!
!
!
line con 0
password 7 0822455D0A16
login
!
line aux 0
!
line vty 0 4
password 7 0822455D0A16
login
line vty 5 15
password 7 0822455D0A16
login
!
!
!
end-------------------------------------------------
Any help/guidence is greatly appreciated
Solved! Go to Solution.
11-20-2017 08:23 AM
Line up protocol down is can be Layer two protocol problem and not OSPF. I saw you tried to use PPP but you can also use HDLC which is Cisco´s default Serial Link encapsulation.
Try to do not specify the encapsulation, unless you really need PPP. Then, enable OSPF as it should and let me know.
-If I helped you somehow, please, rate it as useful.-
11-20-2017 08:27 AM
11-20-2017 08:51 AM
11-20-2017 09:04 AM
You need to define username and password.
Follow this for both router:
R1(config)#username R2 password CISCO R1(config)#int s1/1 R1(config-if)#ppp authentication chap R2(config)#username R1 password CISCO
R2(config)#int s1/1 R2(config-if)#ppp authentication chap
11-20-2017 10:11 AM
11-20-2017 10:19 AM
share the config again please.
-If I helped you somehow, please, rate it as useful.-
11-20-2017 10:27 AM - edited 11-20-2017 10:28 AM
The debug reports?
I've made sure that the passwords are the same for the CHAP authentication, and that the username is that of the other router
11-20-2017 10:29 AM
Can be show run from both router.
11-20-2017 10:34 AM - edited 11-20-2017 10:36 AM
Current runnoing configs
ACMER1
ACMER1#show running-config
Building configuration...
Current configuration : 1571 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
service password-encryption
!
hostname ACMER1
!
login block-for 300 attempts 2 within 120
!
!
enable secret 5 $1$mERr$hx5rVt7rPNoS4wqbXKX7m0
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
username ACMER1 password 7 0822455D0A16
username ACMER2 password 7 0822455D0A16
username AMCER1 password 7 0822455D0A16
username R1 password 7 0822455D0A16
no ip domain-lookup
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.1.18.126 255.255.255.128
duplex auto
speed auto
!
interface Serial0/0/0
ip address 172.16.1.153 255.255.255.252
clock rate 2000000
!
interface Serial0/0/1
ip address 172.16.0.73 255.255.255.252
encapsulation ppp
ppp authentication chap
clock rate 2000000
!
interface Vlan1
no ip address
shutdown
!
router ospf 1
router-id 1.1.1.1
log-adjacency-changes
network 10.1.18.0 0.0.0.127 area 1
network 172.16.1.152 0.0.0.3 area 0
network 172.16.0.72 0.0.0.3 area 0
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.0.74
!
ip flow-export version 9
!
!
ip access-list extended sl_def_acl
deny tcp any any eq telnet
deny tcp any any eq www
deny tcp any any eq 22
permit tcp any any eq 22
!
no cdp run
!
banner motd ^C
This router is managed by 1404956 ^C
!
!
!
!
line con 0
password 7 0822455D0A16
login
!
line aux 0
!
line vty 0 4
access-class TELNET in
password 7 0822455D0A16
login
line vty 5 15
password 7 0822455D0A16
login
ACMER2
Current configuration : 1628 bytes
!
version 15.1
service timestamps log datetime msec
no service timestamps debug datetime msec
service password-encryption
!
hostname ACMER2
!
logging userinfo
!
!
enable secret 5 $1$mERr$hx5rVt7rPNoS4wqbXKX7m0
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
username ACMER1 password 7 0822455D0A16
username ACMER2 password 7 0822455D0A16
!
!
license udi pid CISCO2911/K9 sn FTX15240EF0
license boot module c2900 technology-package securityk9
!
!
!
!
!
!
!
!
!
no ip domain-lookup
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
ip address 202.202.18.155 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface GigabitEthernet0/2
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/0/0
ip address 172.16.0.74 255.255.255.252
encapsulation ppp
ppp authentication chap
clock rate 2000000
!
interface Serial0/0/1
ip address 172.16.2.73 255.255.255.252
clock rate 2000000
!
interface Serial0/1/0
no ip address
clock rate 2000000
shutdown
!
interface Serial0/1/1
no ip address
clock rate 2000000
shutdown
!
interface Vlan1
no ip address
shutdown
!
router ospf 1
router-id 2.2.2.2
log-adjacency-changes
network 172.16.0.72 0.0.0.3 area 0
network 172.16.2.72 0.0.0.3 area 0
network 202.202.18.128 0.0.0.127 area 2
!
ip classless
!
ip flow-export version 9
!
!
!
no cdp run
!
banner motd ^C
This router is managed by 1404956 ^C
!
!
!
!
no logging trap
line con 0
password 7 0822455D0A16
login
!
line aux 0
!
line vty 0 4
password 7 0822455D0A16
login
line vty 5 15
password 7 0822455D0A16
login
11-20-2017 10:46 AM
On Router ACMER1 you need only this:
username ACMER2 password 7 0822455D0A16
delete this:
username ACMER1 password 7 0822455D0A16
username AMCER1 password 7 0822455D0A16
username R1 password 7 0822455D0A16
On the Router ACMER2 you need this:
username ACMER1 password 7 0822455D0A16
Delete this:
username ACMER2 password 7 0822455D0A16
Lets see now.
-If I helped you somehow, please, rate it as useful.-
11-20-2017 10:58 AM
11-20-2017 11:24 AM
I just got this to work on the Packet Tracer. Please find attached.
Try to compare with your config and make the necessary adjustment. Packet Tracer is a bit limited to play with PPP as we dont have all the commands available but it works.
Unfortunately my Packet Tracer did not open your file due version conflict.
-If I helped you somehow, please, rate it as useful.-
11-20-2017 11:51 AM
11-20-2017 11:55 AM
That's weird. Mine worked seamlessly.
Try to pickup another project and start over with new router.
This is supposed to be easy.
-If I helped you somehow, please, rate it as useful.-
11-20-2017 03:07 PM
Perhaps a debug on ppp negotiation and/or chap authentication might show what is going on?
In previous posts there seems to be suggestion that the line protocol down might be related to configuring OSPF on the interface. That is highly unlikely to be the case. Line protocol up or down is a layer 2 function and configuring OSPF is a layer 3 function. Line protocol down might be caused by problems with interface clocking, or might be caused by mismatched protocols on the interface (HDLC on one side and PPP on the other), or failure of hello messages. But if it is true (as I understand one of the previous posts to say) that removing chap authentication allows the interface to come to state up/up and then ping is successful, then clearly the problem is an issue about chap authentication. That is the immediate issue that we need to solve.
HTH
Rick
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide