11-14-2017 04:51 AM - edited 03-05-2019 09:29 AM
Hello all, I have been trying to configure a Cisco 877W router so that I can remotely access it via SSH, but I can not seem to get it to work. I have configured an IP address to VLAN 1 and I have even created another VLAN (VLAN 2) to make sure that I have applied an IP address. Every time I try to ping the IP address, I get an error message:
ping 192.168.178.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.178.2, timeout is 2 seconds.
Can someone help me with this problem?
11-14-2017 05:05 AM
Hi Trev,
Are you trying to SSH to the 877 from a remote location or from within the LAN?
Can you share the running config with us?
cheers,
Seb.
11-14-2017 05:26 AM
I am trying to SSH from my LAN.
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Trevr1
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$O1IK$MAGmjSNlZMf24GEUcDpDW1
enable password john1
!
no aaa new-model
!
!
dot11 syslog
ip cef
!
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
!
interface Loopback0
ip address 9.1.1.0 255.0.0.0
!
interface ATM0
no ip address
shutdown
no atm ilmi-keepalive
dsl operating-mode auto
!
interface FastEthernet0
switchport access vlan 2
no cdp enable
!
interface FastEthernet1
switchport access vlan 2
no cdp enable
!
interface FastEthernet2
switchport access vlan 2
no cdp enable
!
interface FastEthernet3
switchport access vlan 2
no cdp enable
!
interface Dot11Radio0
no ip address
shutdown
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
station-role root
no cdp enable
!
interface Vlan1
ip address 10.10.10.1 255.0.0.0
!
interface Vlan2
ip address 192.168.178.2 255.255.255.0
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
no modem enable
line aux 0
line vty 0 4
password cisco
login
!
scheduler max-task-time 5000
no process cpu extended
no process cpu autoprofile hog
11-14-2017 05:40 AM
Can you just add this command to speed things up a bit:
! int range fa0-3 spanning-tree portfast !
Also to setup SSH:
! ip domain name <somedomain.com> ! crypto key generate rsa module 2048 ! ip ssh version 2 ! line vty 0 4 transport input ssh !
What is the output from:
sh mac-address dynamic vlan 2
sh ip arp vlan 2
Can you ping your device from the switch?
cheers,
Seb.
11-14-2017 05:48 AM
Trevr1#sh mac-address dynamic vlan 2
Non-static Address Table:
Destination Address Address Type VLAN Destination Port
------------------- ------------ ---- --------------------
11-14-2017 05:50 AM
hmm ok, which switchport is your device connected to?
sh int status
11-14-2017 05:55 AM
I have two Cisco 3750 switches connected to fa2 and fa3. I have just started studying for the ICND1, so excuse my ignorance.
11-14-2017 06:00 AM
I guess I was wrong about where I connected the switches.
Port Name Status Vlan Duplex Speed Type
Fa0 connected 2 a-full a-100 10/100BaseTX
Fa1 notconnect 2 auto auto 10/100BaseTX
Fa2 notconnect 2 auto auto 10/100BaseTX
Fa3 notconnect 2 auto auto 10/100BaseTX
11-14-2017 05:52 AM
Trevr1(config)#int range fa0 - 3
Trevr1(config-if-range)#spann
Trevr1(config-if-range)#spanning-tree por
Trevr1(config-if-range)#spanning-tree portf
Trevr1(config-if-range)#spanning-tree portfast
%Warning: portfast should only be enabled on ports connected to a single host.
Connecting hubs, concentrators, switches, bridges, etc.to this interface
when portfast is enabled, can cause temporary spanning tree loops.
Use with CAUTION
%Portfast has been configured on FastEthernet0 but will only
have effect when the interface is in a non-trunking mode.
%Warning: portfast should only be enabled on ports connected to a single host.
Connecting hubs, concentrators, switches, bridges, etc.to this interface
when portfast is enabled, can cause temporary spanning tree loops.
Use with CAUTION
%Portfast has been configured on FastEthernet1 but will only
have effect when the interface is in a non-trunking mode.
%Warning: portfast should only be enabled on ports connected to a single host.
Connecting hubs, concentrators, switches, bridges, etc.to this interface
when portfast is enabled, can cause temporary spanning tree loops.
Use with CAUTION
%Portfast has been configured on FastEthernet2 but will only
have effect when the interface is in a non-trunking mode.
%Warning: portfast should only be enabled on ports connected to a single host.
Connecting hubs, concentrators, switches, bridges, etc.to this interface
when portfast is enabled, can cause temporary spanning tree loops.
Use with CAUTION
%Portfast has been configured on FastEthernet3 but will only
have effect when the interface is in a non-trunking mode.
Trevr1(config-if-range)#
11-14-2017 05:54 AM
That's fine, they are all access ports and connected to single hosts, not switches, right?? :)
11-14-2017 05:57 AM
The router is connected to two Cisco 3750 switches.
11-14-2017 06:03 AM
11-14-2017 06:09 AM
Trevr1#sh mac-address dynamic vlan 2
Non-static Address Table:
Destination Address Address Type VLAN Destination Port
Trevr1#sh ip arp vlan 2
Protocol Address Age (min) Hardware Addr Type Interface
Internet 192.168.178.2 - 0026.cb23.fc5c ARPA Vlan2
11-14-2017 06:12 AM
So a 3750 is connected to fa0 ? In which case remove the spanning-tree command
! int fa0 no spanning-tree portfast !
What does the config of the switch connected to Fa0 look like?
cheers,
Seb.
11-14-2017 06:12 AM
I have already set up the router for SSH, that is when I found out that I could not ping the IP address that I assigned. The router will also not allow me to configure an IP address to any of the fa ports. It keeps telling me that:
Trevr1(config-if)#ip address 192.168.178.2 255.255.255.0
% IP addresses may not be configured on L2 links.
Trevr1(config-if)#
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide