- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
09-26-2018 11:44 PM - edited 09-26-2018 11:45 PM
i've got 2 N7700 and some c9500. First I wanted to route ISIS between all of these devices. So I redistributed a default and a static route from the n77k and its working fine. Then I moved the n77k out of the ISIS. I put the default and the static routes on a c95k and its not working. I tried it first with a route-map:
router isis backbone
...
redistribute static route-map static-map
default-information originate route-map static-map
ip route 0.0.0.0 0.0.0.0 10.1.1.1 tag 120
ip route 172.16.0.0 255.255.0.0 10.10.1.1 tag 120
route-map dna-map permit 10
match tag 120
That was not working on the c95k. So I tried this with the same result:
router isis backbone
...
redistribute static ip
default-information originate
The rest of the ISIS is working
Solved! Go to Solution.
- Labels:
-
Routing Protocols
Accepted Solutions
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
10-30-2018 07:19 AM - edited 10-30-2018 07:20 AM
I found my problem.
Thats the solution: You have to say in the route-map that this map is a level-1 type.
router isis backbone
net 49.0000. ...
is-type level-1
authentication mode md5 level-1
authentication key-chain isis-password
metric-style wide
log-adjacency-changes
nsf ietf
redistribute static ip route-map static-map level-1
default-information originate route-map static-map
bfd all-interfaces
route-map static-map permit 10
set level level-1
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
09-27-2018 04:56 AM
Try adding the ip keyword in your redistribute command. I have added ip after static in the redistribute command.
router isis backbone
redistribute static ip route-map static-map
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
09-27-2018 05:11 AM
Sorry, I failed to notice that you already tried it with the ip keyword. Is it possible to remove the isis instance and re-create it and then try again to redistribute static routes with and without ip keyword?
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
09-27-2018 05:22 AM
Hello
@florianlocker wrote:
i've got 2 N7700 and some c9500. First I wanted to route ISIS between all of these devices. So I redistributed a default and a static route from the n77k and its working fine. Then I moved the n77k out of the ISIS. I put the default and the static routes on a c95k and its not working. I tried it first with a route-map:
router isis backbone
redistribute static route-map static-map
default-information originate route-map static-map
route-map dna-map permit 10
Is this a typo in your OP and the specified route-map isnt the one being applied in the ISIS process
Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.
Kind Regards
Paul
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
10-01-2018 01:30 AM
I renamed the acl before. Its the same map with the same name (on the router), just a copy and paste mistake here in the forum.
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
10-30-2018 07:19 AM - edited 10-30-2018 07:20 AM
I found my problem.
Thats the solution: You have to say in the route-map that this map is a level-1 type.
router isis backbone
net 49.0000. ...
is-type level-1
authentication mode md5 level-1
authentication key-chain isis-password
metric-style wide
log-adjacency-changes
nsf ietf
redistribute static ip route-map static-map level-1
default-information originate route-map static-map
bfd all-interfaces
route-map static-map permit 10
set level level-1
