09-21-2023 03:32 PM
Hello,
I need some help with route statements for subnets that were provided to me. Some background: I have three locations, each with Catalyst 9300 stacks, connected via fiber that forms a triangle among the locations. Each location has two SFP modules - G1/1/1 and G2/1/1 with multiple vlans. The goal is to route our traffic across the system. The switches are on 17.9.3
I was given five subnets: 192.168.1.0/26, 192.168.1.64/26, 192.168.1.128/26, 192.168.1.192/26 and 192.220.1.176/29.
Can someone help me with the route statements using ospf (or something different based on your opinion). I think the problem I'm having is that the subnets bounce up to each other versus having a different third octet. Would I still use 192.168.1.0 for the route statement or do I break it up using ospf wild card statements?
Thank you for your help
09-21-2023 03:43 PM
Hello
When you enable ospf on an interface, the network that is assigned to it is advertised, so you do not need to use any network statements.
example:
router ospf x
router-id x.x.x.x
int x/x
ip ospf x area x
int x/y
ip ospf x area x
etc...
09-21-2023 05:22 PM
"Route" statements or routing protocol network statements?
For OSPF, you can selectively "wild" card interface IPs you want to include in the OSPF topology.
For example:
router ospf 1
network 192.168.1.0 0.0.0.255
Would match: 192.168.1.0/26, 192.168.1.64/26, 192.168.1.128/26, 192.168.1.192/26
router ospf 1
network 192.220.1.176 0.0.0.7
Would match 192.220.1.176/29.
09-22-2023 01:54 AM
Thank you. I'm confused by "Catalyst 9300 stacks are up and properly configured with the correct IP addresses and subnet masks." Are you talking about G1/1/1 and G2/1/1 for the fiber connections? If so, what address should I use? Do I create generic IPs (like 10.10.10.x) and include that in the router ospf network statements?
09-22-2023 03:10 AM
Where do I place "ip ospf 1 area 0"? It doesnt seem to work with the vlans but I was able to see neighbors when applied to the fiber ports. I cant ping anything yet, even though I'm seeing neighbors. I've read other places that I should address them with a generic IP and include that in the network statements. I've tried it and that doesnt seem to work either.
Does "ip ospf 1 area 1" need to be placed on all the interfaces?
09-22-2023 06:34 AM
Hello @b-krull ,
from your inital post
>> Each location has two SFP modules - G1/1/1 and G2/1/1 with multiple vlans
is possible that your three Cat 9300 stacks are interconnected with L2 802.1Q trunks ? if that is the case your subnets are spread over all three locations ?
if so you just need inter VLAN routing to work.
Otherwise to use OSPF you would need one additional VLAN to be used as backbone to build OSPF neighboships over it and each stack needs to have an IP address on the backbone subnet.
Hope to help
Giuseppe
09-22-2023 03:48 AM
Hello
@b-krull wrote:
Thank you. I'm confused by "Catalyst 9300 stacks are up and properly configured with the correct IP addresses and subnet masks." Are you talking about G1/1/1 and G2/1/1 for the fiber connections? If so, what address should I use? Do I create generic IPs (like 10.10.10.x) and include that in the router ospf network statements?
Is the 9300 stack performing the intervlan-routing, does it have multiple L3 SVI interfaces (VLANs), if so apply ospf on those L3 interfaces
Example
int vlan 10
ip address 192.168.1.1 255.255.255.192
ip ospf 1 area 0
int vlan 11
ip address 192.168.1.65 255.255.255.192
ip ospf 1 area 0
int vlan 12
ip address 192.168.1.129 255.255.255.192
ip ospf 1 area 0
int vlan 13
ip address 192.168.1.193 255.255.255.192
ip ospf 1 area 0
int vlan 14
ip address 192.220.1.177 255.255.255.248
ip ospf 1 area 0
09-28-2023 08:02 AM
Thanks Paul. Those instructions worked. Can I send a different vlan across the same connection that's not subnetted? I'd like to have a private network that spans both switches.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide