09-04-2012 08:13 AM - edited 03-04-2019 05:28 PM
What commands do I need to enter to correctly authenticate with my DSL PPPOE provider? I need to have the ID and Password entered into the router.
Thanks
mtnvictory69
09-04-2012 08:21 AM
You can search this forum or Cisco.com for answers on your questions, that has been discussed many, many times.
09-04-2012 08:22 AM
Hi Michael,
If your router is configured for PPPoE access, it should have a Dialer interface configured. On this interface, enter these commands:
ppp chap hostname YOUR_LOGIN
ppp chap password YOUR_PASSWORD
ppp pap sent-username YOUR_LOGIN password YOUR_PASSWORD
These commands configure your router for both PAP and CHAP authentication mechanisms. If you know exactly which authentication mechanism you will be using, use just the appropriate command(s) and you may omit the configuration of the other mechanism. If in doubt, use all three commands.
Best regards,
Peter
09-04-2012 09:07 AM
09-04-2012 09:34 AM
Michael,
Your router does not appear to be configured for any PPPoE at all. It is currently configured for plain IP conectivity. Are you sure you're using PPPoE? Can you describe how this router is connected to a DSL service? If there is another DSL router at your premises then it is that router which has to be configured for PPPoE, not this one.
Best regards,
Peter
09-04-2012 09:34 AM
I do not have a Dialer interface configured on this router. How would that be done please?
Thanks
09-04-2012 09:38 AM
Michael,
First, I need to understand your network topology, i.e. what devices you have, what is their function and how they are interconnected. Only then I can suggest how you should configure your router. Please try to describe in as much detail as possible how this Cisco router is connected to the surrounding network and to the DSL service provider.
Best regards,
Peter
09-04-2012 09:43 AM
The remote office just installed a DSL line and we have 5 dedicated IP's from CenturyLink with a modem. I am configuring this router for VPN to HQ. I know that the DSL modem needs to be setup as a bridge which has been done. Now I need to configure the router to use PPPOE authentication but not sure how since I have never used DSL in front. Hopefully this will help you.
Thanks
09-04-2012 11:04 AM
Hello Michael,
Now I have a better insight into your situation. Thank you for the additional explanation. Can I assume that the current configuration of the router is a remainder of some previous deployment and can be freely modified as needed? In particular, is the IP addressing of the Fa1 interface valid or not?
Your configuration should be modified as follows (you should paste the following commands into your global configuration mode directly, as they will perform the necessary modifications):
interface FastEthernet1
no crypto map VPN
no service-policy output VOIP
no ip access-group FIREWALL in
no ip nat outside
no ip inspect FIREWALL out
no ip address
pppoe-client dial-pool-number 1
exit
!
interface Dialer1
dialer pool 1
encapsulation ppp
ppp chap hostname YOUR_LOGIN
ppp chap password YOUR_PASSWORD
ppp pap sent-username YOUR_LOGIN password YOUR_PASSWORD
ip address negotiated
ip mtu 1492
ip tcp adjust-mss 1452
ip nat outside
ip inspect FIREWALL out
ip access-group FIREWALL in
service-policy output VOIP
crypto map VPN
!
no ip route 0.0.0.0 0.0.0.0
ip route 0.0.0.0 0.0.0.0 Dialer1
This configuration is not guaranteed to work out of the box. In particular, I am not sure how will the ip address negotiated command work - I do not know if the provider will assign IP addresses to you automatically or if you are supposed to configure static addressing yourself.
It is supposed that the DSL modem is set to bridge mode and that the Cisco router is connected to the DSL modem via its Fa1 interface.
In any case, after applying this configuration and waiting a minute or so, please post the output of the following commands:
show ip interface brief
show ip route
show pppoe session
These commands will help me find out if the configuration worked at least partially.
Best regards,
Peter
09-04-2012 11:22 AM
We have 5 dedicated IP's from the ISP. Yes the FastEthernet1 is configured correctly which is one of our dedicated IP's from the ISP. Yes the current config is the remainder of previous config and updates that I have done already. This router can be freely modified. I am also doing VOIP via QOS across the VPN.
I saw that you said no ip for the FastEthernet1 interface Why?
09-04-2012 11:27 AM
Hello Michael,
Yes the FastEthernet1 is configured correctly which is one of our dedicated IP's from the ISP.
Hmmm, I understand but I have to verify if this is the way the ISP wants you to configure your router. It is possible that the provider will assign some sort of private address on the Dialer interface dynamically and that these addresses are supposed to be located "behind" your router. We'll see that easily - either the Dialer1 interface will negotiate its IP address dynamically, or it will remain address-less, in which case we will configure it with a static IP address.
I saw that you said no ip for the FastEthernet1 interface Why?
Because the FastEthernet1 interface is not supposed to send IP packets directly. Instead, the IP packets have to be first encapsulated into PPP+PPPoE headers and only then sent via the Fa1 interface. Therefore the Fa1 interface will no longer be configured with any IP settings, and instead, they will all move to the Dialer interface that represents the "end", or the termination, of the PPPoE session.
Best regards,
Peter
09-04-2012 11:47 AM
09-04-2012 02:05 PM
09-04-2012 02:28 PM
Hello Michael,
I believe we are not far from having the issue solved completely. The command outputs I have requested show that the Dialer1 interface is up and running and has been dynamically assigned the IP address 70.58.191.198. Also, the show pppoe session confirms that the PPPoE session has been successfully established. The show ip route also confirms that the ISP's IP address is 184.99.0.201.
What I missed is the NAT configuration: currently, you have this line in your configuration:
ip nat inside source route-map DYNAMIC interface FastEthernet1 overload
It is currently wrong as it tries to perform NAT to the IP address of the Fa1 interface - which does not have any IP address anymore. Please paste the following lines into your configuration:
interface Fa1
no ip virtual-reassembly
exit
!
no ip nat inside source route-map DYNAMIC interface FastEthernet1 overload
ip nat inside source route-map DYNAMIC interface Dialer1 overload
Please let me know the result. Thank you!
Best regards,
Peter
09-04-2012 03:04 PM
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide