cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
2167
Views
15
Helpful
11
Replies
Highlighted
Beginner

cisco 1841 easy configuration help

Hi, can someone please help with the following configuration?

I have an ADSL modem, IP 192.168.1.1 which is connected to FastEthernet0/0 IP address 192.168.1.2 and then I would like to use the other ethernet interfaces to attach to it two wireless routers and possibly a machine or a third router.

For example I have interface 192.168.120.1 attached to a consumer router which has IP address 192.168.120.2 and it is connected LAN to LAN. I know, brutal setup, but I can't even get this to work. Everything is on subnet 255.255.255.0

The Cisco can ping the internet, it can ping the routers that are attached to it, it can also ping the machines I attach to the slave routers, say, 192.168.120.161 no problem. Here is the routing table

Router_1841#show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.1.1 to network 0.0.0.0

C    192.168.120.0/24 is directly connected, FastEthernet0/1/1

C    192.168.1.0/24 is directly connected, FastEthernet0/0

S*   0.0.0.0/0 [1/0] via 192.168.1.1

Router_1841#

The machines can ping the ethernet interface of the cisco, the one connected to their slave router, but can't ping beyond that, ie, they can't ping external cisco interface 192.168.1.2 nor the modem 192.168.1.1 and obviously not the internet. The slave router can't ping either, not the internet and not the interface to outside 192.168.1.2 nor the modem. I suppose I have problems in the routing table which does not forward properly the internal network to the outside, I tried to do that, but it says incompatible netmasks or something and I can't figure out how to do properly. Perhaps I also have access-list problems. Setting this up is above my head and I am at my wit's end. Thank you a lot.

Router_1841#show run

Building configuration...

Current configuration : 1890 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router_1841

!

boot-start-marker

boot-end-marker

!

logging message-counter syslog

enable secret xxxxxxxxxxxxxxxxxxxxx

enable password xxxxxxxxxxxxxxxxxx

!

no aaa new-model

dot11 syslog

ip source-route

!

!

!

ip dhcp pool poolcisco

   network 10.1.10.0 255.255.255.0

   dns-server 8.8.8.8

   default-router 192.168.1.2

!

!

ip cef

ip name-server 91.80.37.100

ip name-server 8.8.8.8

no ipv6 cef

!

multilink bundle-name authenticated

!

!

!

!

!

archive

log config

  hidekeys

!

!

!

!

!

!

!

!

interface FastEthernet0/0

description outside

ip address 192.168.1.2 255.255.255.0

ip nat outside

ip virtual-reassembly

speed auto

full-duplex

no mop enabled

!

interface FastEthernet0/1

description dlinkLAN

ip address 192.168.125.1 255.255.255.0

ip nat inside

ip virtual-reassembly

speed auto

full-duplex

!

interface Serial0/0/0

no ip address

shutdown

clock rate 2000000

!

interface Serial0/0/1

no ip address

shutdown

clock rate 2000000

!

interface FastEthernet0/1/0

description linksysLAN

ip address 192.168.130.1 255.255.255.0

ip nat inside

ip virtual-reassembly

speed auto

full-duplex

!

interface FastEthernet0/1/1

description dlink2LAN

ip address 192.168.120.1 255.255.255.0

ip nat inside

ip virtual-reassembly

speed auto

full-duplex

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 192.168.1.1

no ip http server

no ip http secure-server

!

!

!

access-list 10 permit 192.168.96.0 0.0.30.255

access-list 101 permit ip 10.1.10.0 0.0.0.255 any

access-list 102 permit ip any 10.1.10.0 0.0.0.255

access-list 103 permit tcp any any

access-list 103 permit udp any any

access-list 103 permit icmp any any

!

!

!

!

!

!

control-plane

!

!

!

line con 0

line aux 0

line vty 0 4

password xxxxxxxxxxxxxxxxxx

login

!

scheduler allocate 20000 1000

end

1 ACCEPTED SOLUTION

Accepted Solutions
Advisor

cisco 1841 easy configuration help

Hi,

remove the  nat inside and nat outside from the interfaces as i told you to

in the 1841 config you posted I see you have an interface in 192.168.120.0/24 subnet which is connected to other router so where is this 192.168.120.161 host located ? how is this slave router connected to the 1841 ? what is this slave router model ?

Regards.

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
11 REPLIES 11
Advisor

cisco 1841 easy configuration help

Hi,

try to remove the ip nat statements from the interfaces and on your adsl modem just configure static routes to the

120,125 and 130 network as well as to LAN devices subnet.

on the other routers put a static default route pointing to next-hop ip

if you still got problem pinging 192.168.1.2 then on 1841 do this:

logging buffered debug

logging buffered 100000

service timestamp debug uptime

access-list 190 permit icmp any any

do debug ip pack det 190

do debug ip icmp

then ping with a count of 2 from machine to 192.168.1.2 and issue do sh log then hit enter and paste output.

Regards.

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
Beginner

Re: cisco 1841 easy configuration help

Hi and thank you,

I am not sure the ADSL modem will allow me to set a route, because it is consumer equipment and a cheap one. Not that the operator is any better, see below, I suspect there is some gross misconfiguration. I have not implemented anything yet, this is logging of current state.

Why do I need to set a static route on the modem? It only has one connection in and another out. Should it not be able to do subnet masks and know which way to send things?

How do I remove nat? Like this for every interface?

no ip nat outside source route-map NAT interface FastEthernet0/0 
no ip nat inside source route-map NAT interface FastEthernet0/1 

.........

Thanks again

Router_1841#ping 8.8.8.8

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 56/59/60 ms

Router_1841#

1d00h: IP: s=192.168.1.2 (local), d=8.8.8.8, len 100, local feature

1d00h:     ICMP type=8, code=0, NAT(2), rtype 0, forus FALSE, sendself FALSE, mt

u 0, fwdchk FALSE

1d00h: FIBipv4-packet-proc: route packet from (local) src 192.168.1.2 dst 8.8.8.

8

1d00h: FIBipv4-packet-proc: packet routing succeeded

1d00h: IP: s=192.168.1.2 (local), d=8.8.8.8 (FastEthernet0/0), len 100, sending

1d00h:     ICMP type=8, code=0

1d00h: IP: s=192.168.1.2 (local), d=8.8.8.8 (FastEthernet0/0), len 100, output f

eature

1d00h:     ICMP type=8, code=0, Post-routing NAT Outside(17), rtype 1, forus FAL

SE, sendself FALSE, mtu 0, fwdchk FALSE

1d00h: IP: s=192.168.1.2 (local), d=8.8.8.8 (FastEthernet0/0), len 100, output f

eature

1d00h:     ICMP type=8, code=0, Stateful Inspection(20), rtype 1, forus FALSE, s

endself FALSE, mtu 0, fwdchk FALSE

1d00h: IP: s=192.168.1.2 (local), d=8.8.8.8 (FastEthernet0/0), len 100, sending

full packet

1d00h:     ICMP type=8, code=0

1d00h: IP: s=8.8.8.8 (FastEthernet0/0), d=192.168.1.2, len 92, input feature

1d00h:     ICMP type=0, code=0, Stateful Inspection(4), rtype 0, forus FALSE, se

ndself FALSE, mtu 0, fwdchk FALSE

1d00h: IP: s=8.8.8.8 (FastEthernet0/0), d=192.168.1.2, len 92, input feature

1d00h:     ICMP type=0, code=0, Virtual Fragment Reassembly(21), rtype 0, forus

FALSE, sendself FALSE, mtu 0, fwdchk FALSE

1d00h: IP: s=8.8.8.8 (FastEthernet0/0), d=192.168.1.2, len 92, input feature

1d00h:     ICMP type=0, code=0, Virtual Fragment Reassembly After IPSec Decrypti

on(32), rtype 0, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE

1d00h: IP: s=8.8.8.8 (FastEthernet0/0), d=192.168.1.2, len 92, input feature

1d00h:     ICMP type=0, code=0, NAT Outside(53), rtype 0, forus FALSE, sendself

FALSE, mtu 0, fwdchk FALSE

1d00h: IP: s=8.8.8.8 (FastEthernet0/0), d=192.168.1.2, len 92, input feature

1d00h:     ICMP type=0, code=0, MCI Check(64), rtype 0, forus FALSE, sendself FA

LSE, mtu 0, fwdchk FALSE

1d00h: FIBipv4-packet-proc: route packet from FastEthernet0/0 src 8.8.8.8 dst 19

2.168.1.2

1d00h: FIBfwd-proc: Default:192.168.1.2/32 receive entry

1d00h: FIBipv4-packet-proc: packet routing failed

1d00h: IP: tableid=0, s=8.8.8.8 (FastEthernet0/0), d=192.168.1.2 (FastEthernet0/

0), routed via RIB

1d00h: IP: s=8.8.8.8 (FastEthernet0/0), d=192.168.1.2 (FastEthernet0/0), len 92,

output feature

1d00h:     ICMP type=0, code=0, Post-routing NAT Outside(17), rtype 1, forus FAL

SE, sendself FALSE, mtu 0, fwdchk FALSE

1d00h: IP: s=8.8.8.8 (FastEthernet0/0), d=192.168.1.2 (FastEthernet0/0), len 92,

output feature

1d00h:     ICMP type=0, code=0, Stateful Inspection(20), rtype 1, forus FALSE, s

endself FALSE, mtu 0, fwdchk FALSE

1d00h: IP: s=8.8.8.8 (FastEthernet0/0), d=192.168.1.2 (FastEthernet0/0), len 92,

rcvd 3

1d00h:     ICMP type=0, code=0

1d00h: IP: s=8.8.8.8 (FastEthernet0/0), d=192.168.1.2, len 92, stop process pak

for forus packet

1d00h:     ICMP type=0, code=0

1d00h: ICMP: echo reply rcvd, src 8.8.8.8, dst 192.168.1.2

1d00h: IP: s=192.168.1.2 (local), d=8.8.8.8, len 100, local feature

1d00h:     ICMP type=8, code=0, NAT(2), rtype 0, forus FALSE, sendself FALSE, mt

u 0, fwdchk FALSE

1d00h: FIBipv4-packet-proc: route packet from (local) src 192.168.1.2 dst 8.8.8.

8

1d00h: FIBipv4-packet-proc: packet routing succeeded

1d00h: IP: s=192.168.1.2 (local), d=8.8.8.8 (FastEthernet0/0), len 100, sending

1d00h:     ICMP type=8, code=0

1d00h: IP: s=192.168.1.2 (local), d=8.8.8.8 (FastEthernet0/0), len 100, output f

eature

1d00h:     ICMP type=8, code=0, Post-routing NAT Outside(17), rtype 1, forus FAL

SE, sendself FALSE, mtu 0, fwdchk FALSE

1d00h: IP: s=192.168.1.2 (local), d=8.8.8.8 (FastEthernet0/0), len 100, output f

eature

1d00h:     ICMP type=8, code=0, Stateful Inspection(20), rtype 1, forus FALSE, s

endself FALSE, mtu 0, fwdchk FALSE

1d00h: IP: s=192.168.1.2 (local), d=8.8.8.8 (FastEthernet0/0), len 100, sending

full packet

1d00h:     ICMP type=8, code=0

1d00h: IP: s=8.8.8.8 (FastEthernet0/0), d=192.168.1.2, len 92, input feature

1d00h:     ICMP type=0, code=0, Stateful Inspection(4), rtype 0, forus FALSE, se

ndself FALSE, mtu 0, fwdchk FALSE

1d00h: IP: s=8.8.8.8 (FastEthernet0/0), d=192.168.1.2, len 92, input feature

1d00h:     ICMP type=0, code=0, Virtual Fragment Reassembly(21), rtype 0, forus

FALSE, sendself FALSE, mtu 0, fwdchk FALSE

1d00h: IP: s=8.8.8.8 (FastEthernet0/0), d=192.168.1.2, len 92, input feature

1d00h:     ICMP type=0, code=0, Virtual Fragment Reassembly After IPSec Decrypti

on(32), rtype 0, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE

1d00h: IP: s=8.8.8.8 (FastEthernet0/0), d=192.168.1.2, len 92, input feature

1d00h:     ICMP type=0, code=0, NAT Outside(53), rtype 0, forus FALSE, sendself

FALSE, mtu 0, fwdchk FALSE

1d00h: IP: s=8.8.8.8 (FastEthernet0/0), d=192.168.1.2, len 92, input feature

1d00h:     ICMP type=0, code=0, MCI Check(64), rtype 0, forus FALSE, sendself FA

LSE, mtu 0, fwdchk FALSE

1d00h: FIBipv4-packet-proc: route packet from FastEthernet0/0 src 8.8.8.8 dst 19

2.168.1.2

1d00h: FIBfwd-proc: Default:192.168.1.2/32 receive entry

1d00h: FIBipv4-packet-proc: packet routing failed

1d00h: IP: tableid=0, s=8.8.8.8 (FastEthernet0/0), d=192.168.1.2 (FastEthernet0/

0), routed via RIB

1d00h: IP: s=8.8.8.8 (FastEthernet0/0), d=192.168.1.2 (FastEthernet0/0), len 92,

output feature

1d00h:     ICMP type=0, code=0, Post-routing NAT Outside(17), rtype 1, forus FAL

SE, sendself FALSE, mtu 0, fwdchk FALSE

1d00h: IP: s=8.8.8.8 (FastEthernet0/0), d=192.168.1.2 (FastEthernet0/0), len 92,

output feature

1d00h:     ICMP type=0, code=0, Stateful Inspection(20), rtype 1, forus FALSE, s

endself FALSE, mtu 0, fwdchk FALSE

1d00h: IP: s=8.8.8.8 (FastEthernet0/0), d=192.168.1.2 (FastEthernet0/0), len 92,

rcvd 3

1d00h:     ICMP type=0, code=0

1d00h: IP: s=8.8.8.8 (FastEthernet0/0), d=192.168.1.2, len 92, stop process pak

for forus packet

1d00h:     ICMP type=0, code=0

1d00h: ICMP: echo reply rcvd, src 8.8.8.8, dst 192.168.1.2

1d00h: IP: s=192.168.1.2 (local), d=8.8.8.8, len 100, local feature

1d00h:     ICMP type=8, code=0, NAT(2), rtype 0, forus FALSE, sendself FALSE, mt

u 0, fwdchk FALSE

1d00h: FIBipv4-packet-proc: route packet from (local) src 192.168.1.2 dst 8.8.8.

8

1d00h: FIBipv4-packet-proc: packet routing succeeded

1d00h: IP: s=192.168.1.2 (local), d=8.8.8.8 (FastEthernet0/0), len 100, sending

1d00h:     ICMP type=8, code=0

1d00h: IP: s=192.168.1.2 (local), d=8.8.8.8 (FastEthernet0/0), len 100, output f

eature

1d00h:     ICMP type=8, code=0, Post-routing NAT Outside(17), rtype 1, forus FAL

SE, sendself FALSE, mtu 0, fwdchk FALSE

1d00h: IP: s=192.168.1.2 (local), d=8.8.8.8 (FastEthernet0/0), len 100, output f

eature

1d00h:     ICMP type=8, code=0, Stateful Inspection(20), rtype 1, forus FALSE, s

endself FALSE, mtu 0, fwdchk FALSE

1d00h: IP: s=192.168.1.2 (local), d=8.8.8.8 (FastEthernet0/0), len 100, sending

full packet

1d00h:     ICMP type=8, code=0

1d00h: IP: s=8.8.8.8 (FastEthernet0/0), d=192.168.1.2, len 92, input feature

1d00h:     ICMP type=0, code=0, Stateful Inspection(4), rtype 0, forus FALSE, se

ndself FALSE, mtu 0, fwdchk FALSE

1d00h: IP: s=8.8.8.8 (FastEthernet0/0), d=192.168.1.2, len 92, input feature

1d00h:     ICMP type=0, code=0, Virtual Fragment Reassembly(21), rtype 0, forus

FALSE, sendself FALSE, mtu 0, fwdchk FALSE

1d00h: IP: s=8.8.8.8 (FastEthernet0/0), d=192.168.1.2, len 92, input feature

1d00h:     ICMP type=0, code=0, Virtual Fragment Reassembly After IPSec Decrypti

on(32), rtype 0, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE

1d00h: IP: s=8.8.8.8 (FastEthernet0/0), d=192.168.1.2, len 92, input feature

1d00h:     ICMP type=0, code=0, NAT Outside(53), rtype 0, forus FALSE, sendself

FALSE, mtu 0, fwdchk FALSE

1d00h: IP: s=8.8.8.8 (FastEthernet0/0), d=192.168.1.2, len 92, input feature

1d00h:     ICMP type=0, code=0, MCI Check(64), rtype 0, forus FALSE, sendself FA

LSE, mtu 0, fwdchk FALSE

1d00h: FIBipv4-packet-proc: route packet from FastEthernet0/0 src 8.8.8.8 dst 19

2.168.1.2

1d00h: FIBfwd-proc: Default:192.168.1.2/32 receive entry

1d00h: FIBipv4-packet-proc: packet routing failed

1d00h: IP: tableid=0, s=8.8.8.8 (FastEthernet0/0), d=192.168.1.2 (FastEthernet0/

0), routed via RIB

1d00h: IP: s=8.8.8.8 (FastEthernet0/0), d=192.168.1.2 (FastEthernet0/0), len 92,

output feature

1d00h:     ICMP type=0, code=0, Post-routing NAT Outside(17), rtype 1, forus FAL

SE, sendself FALSE, mtu 0, fwdchk FALSE

1d00h: IP: s=8.8.8.8 (FastEthernet0/0), d=192.168.1.2 (FastEthernet0/0), len 92,

output feature

1d00h:     ICMP type=0, code=0, Stateful Inspection(20), rtype 1, forus FALSE, s

endself FALSE, mtu 0, fwdchk FALSE

1d00h: IP: s=8.8.8.8 (FastEthernet0/0), d=192.168.1.2 (FastEthernet0/0), len 92,

rcvd 3

1d00h:     ICMP type=0, code=0

1d00h: IP: s=8.8.8.8 (FastEthernet0/0), d=192.168.1.2, len 92, stop process pak

for forus packet

1d00h:     ICMP type=0, code=0

1d00h: ICMP: echo reply rcvd, src 8.8.8.8, dst 192.168.1.2

1d00h: IP: s=192.168.1.2 (local), d=8.8.8.8, len 100, local feature

1d00h:     ICMP type=8, code=0, NAT(2), rtype 0, forus FALSE, sendself FALSE, mt

u 0, fwdchk FALSE

1d00h: FIBipv4-packet-proc: route packet from (local) src 192.168.1.2 dst 8.8.8.

8

1d00h: FIBipv4-packet-proc: packet routing succeeded

1d00h: IP: s=192.168.1.2 (local), d=8.8.8.8 (FastEthernet0/0), len 100, sending

1d00h:     ICMP type=8, code=0

1d00h: IP: s=192.168.1.2 (local), d=8.8.8.8 (FastEthernet0/0), len 100, output f

eature

1d00h:     ICMP type=8, code=0, Post-routing NAT Outside(17), rtype 1, forus FAL

SE, sendself FALSE, mtu 0, fwdchk FALSE

1d00h: IP: s=192.168.1.2 (local), d=8.8.8.8 (FastEthernet0/0), len 100, output f

eature

1d00h:     ICMP type=8, code=0, Stateful Inspection(20), rtype 1, forus FALSE, s

endself FALSE, mtu 0, fwdchk FALSE

1d00h: IP: s=192.168.1.2 (local), d=8.8.8.8 (FastEthernet0/0), len 100, sending

full packet

1d00h:     ICMP type=8, code=0

1d00h: IP: s=8.8.8.8 (FastEthernet0/0), d=192.168.1.2, len 92, input feature

1d00h:     ICMP type=0, code=0, Stateful Inspection(4), rtype 0, forus FALSE, se

ndself FALSE, mtu 0, fwdchk FALSE

1d00h: IP: s=8.8.8.8 (FastEthernet0/0), d=192.168.1.2, len 92, input feature

1d00h:     ICMP type=0, code=0, Virtual Fragment Reassembly(21), rtype 0, forus

FALSE, sendself FALSE, mtu 0, fwdchk FALSE

1d00h: IP: s=8.8.8.8 (FastEthernet0/0), d=192.168.1.2, len 92, input feature

1d00h:     ICMP type=0, code=0, Virtual Fragment Reassembly After IPSec Decrypti

on(32), rtype 0, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE

1d00h: IP: s=8.8.8.8 (FastEthernet0/0), d=192.168.1.2, len 92, input feature

1d00h:     ICMP type=0, code=0, NAT Outside(53), rtype 0, forus FALSE, sendself

FALSE, mtu 0, fwdchk FALSE

1d00h: IP: s=8.8.8.8 (FastEthernet0/0), d=192.168.1.2, len 92, input feature

1d00h:     ICMP type=0, code=0, MCI Check(64), rtype 0, forus FALSE, sendself FA

LSE, mtu 0, fwdchk FALSE

1d00h: FIBipv4-packet-proc: route packet from FastEthernet0/0 src 8.8.8.8 dst 19

2.168.1.2

1d00h: FIBfwd-proc: Default:192.168.1.2/32 receive entry

1d00h: FIBipv4-packet-proc: packet routing failed

1d00h: IP: tableid=0, s=8.8.8.8 (FastEthernet0/0), d=192.168.1.2 (FastEthernet0/

0), routed via RIB

1d00h: IP: s=8.8.8.8 (FastEthernet0/0), d=192.168.1.2 (FastEthernet0/0), len 92,

output feature

1d00h:     ICMP type=0, code=0, Post-routing NAT Outside(17), rtype 1, forus FAL

SE, sendself FALSE, mtu 0, fwdchk FALSE

1d00h: IP: s=8.8.8.8 (FastEthernet0/0), d=192.168.1.2 (FastEthernet0/0), len 92,

output feature

1d00h:     ICMP type=0, code=0, Stateful Inspection(20), rtype 1, forus FALSE, s

endself FALSE, mtu 0, fwdchk FALSE

1d00h: IP: s=8.8.8.8 (FastEthernet0/0), d=192.168.1.2 (FastEthernet0/0), len 92,

rcvd 3

1d00h:     ICMP type=0, code=0

1d00h: IP: s=8.8.8.8 (FastEthernet0/0), d=192.168.1.2, len 92, stop process pak

for forus packet

1d00h:     ICMP type=0, code=0

1d00h: ICMP: echo reply rcvd, src 8.8.8.8, dst 192.168.1.2

1d00h: IP: s=192.168.1.2 (local), d=8.8.8.8, len 100, local feature

1d00h:     ICMP type=8, code=0, NAT(2), rtype 0, forus FALSE, sendself FALSE, mt

u 0, fwdchk FALSE

1d00h: FIBipv4-packet-proc: route packet from (local) src 192.168.1.2 dst 8.8.8.

8

1d00h: FIBipv4-packet-proc: packet routing succeeded

1d00h: IP: s=192.168.1.2 (local), d=8.8.8.8 (FastEthernet0/0), len 100, sending

1d00h:     ICMP type=8, code=0

1d00h: IP: s=192.168.1.2 (local), d=8.8.8.8 (FastEthernet0/0), len 100, output f

eature

1d00h:     ICMP type=8, code=0, Post-routing NAT Outside(17), rtype 1, forus FAL

SE, sendself FALSE, mtu 0, fwdchk FALSE

1d00h: IP: s=192.168.1.2 (local), d=8.8.8.8 (FastEthernet0/0), len 100, output f

eature

1d00h:     ICMP type=8, code=0, Stateful Inspection(20), rtype 1, forus FALSE, s

endself FALSE, mtu 0, fwdchk FALSE

1d00h: IP: s=192.168.1.2 (local), d=8.8.8.8 (FastEthernet0/0), len 100, sending

full packet

1d00h:     ICMP type=8, code=0

1d00h: IP: s=8.8.8.8 (FastEthernet0/0), d=192.168.1.2, len 92, input feature

1d00h:     ICMP type=0, code=0, Stateful Inspection(4), rtype 0, forus FALSE, se

ndself FALSE, mtu 0, fwdchk FALSE

1d00h: IP: s=8.8.8.8 (FastEthernet0/0), d=192.168.1.2, len 92, input feature

1d00h:     ICMP type=0, code=0, Virtual Fragment Reassembly(21), rtype 0, forus

FALSE, sendself FALSE, mtu 0, fwdchk FALSE

1d00h: IP: s=8.8.8.8 (FastEthernet0/0), d=192.168.1.2, len 92, input feature

1d00h:     ICMP type=0, code=0, Virtual Fragment Reassembly After IPSec Decrypti

on(32), rtype 0, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE

1d00h: IP: s=8.8.8.8 (FastEthernet0/0), d=192.168.1.2, len 92, input feature

1d00h:     ICMP type=0, code=0, NAT Outside(53), rtype 0, forus FALSE, sendself

FALSE, mtu 0, fwdchk FALSE

1d00h: IP: s=8.8.8.8 (FastEthernet0/0), d=192.168.1.2, len 92, input feature

1d00h:     ICMP type=0, code=0, MCI Check(64), rtype 0, forus FALSE, sendself FA

LSE, mtu 0, fwdchk FALSE

1d00h: FIBipv4-packet-proc: route packet from FastEthernet0/0 src 8.8.8.8 dst 19

2.168.1.2

1d00h: FIBfwd-proc: Default:192.168.1.2/32 receive entry

1d00h: FIBipv4-packet-proc: packet routing failed

1d00h: IP: tableid=0, s=8.8.8.8 (FastEthernet0/0), d=192.168.1.2 (FastEthernet0/

0), routed via RIB

1d00h: IP: s=8.8.8.8 (FastEthernet0/0), d=192.168.1.2 (FastEthernet0/0), len 92,

output feature

1d00h:     ICMP type=0, code=0, Post-routing NAT Outside(17), rtype 1, forus FAL

SE, sendself FALSE, mtu 0, fwdchk FALSE

1d00h: IP: s=8.8.8.8 (FastEthernet0/0), d=192.168.1.2 (FastEthernet0/0), len 92,

output feature

1d00h:     ICMP type=0, code=0, Stateful Inspection(20), rtype 1, forus FALSE, s

endself FALSE, mtu 0, fwdchk FALSE

1d00h: IP: s=8.8.8.8 (FastEthernet0/0), d=192.168.1.2 (FastEthernet0/0), len 92,

rcvd 3

1d00h:     ICMP type=0, code=0

1d00h: IP: s=8.8.8.8 (FastEthernet0/0), d=192.168.1.2, len 92, stop process pak

for forus packet

1d00h:     ICMP type=0, code=0

1d00h: ICMP: echo reply rcvd, src 8.8.8.8, dst 192.168.1.2

Router_1841#

Advisor

Re: cisco 1841 easy configuration help

Hi,

first you had no nat stement except the nat inside and nat outside on your interfaces on the original post where you posted the config.

second what you did is ping from 1841 to 8.8.8.8 but that is not what i was asking for: take a machine connected to a far router and ping 192.168.1.2 and do clear log before then post log again as well as sh ip nat trans output but could you also post your nat config too please:

sh run | s nat|access-list|route-map

But you'll need a default route on each router and  static routes on the 1841 for the subnets behind the router connected to 1841 as well  as on intermediary routers behind the 1841 or else you could use a routing protocol like rip.

Regards.

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
Beginner

Re: cisco 1841 easy configuration help

Hi and thank you.

I don't understand the NAT and I am not sure what it does exactly, because I am not really connecting subnets e.g. from different service providers. Right now, I am trying the most simple configurations. But, before I put it, it did not ping anything. As you can see below, it is empty. 

I tried to do what you said and nothing happened at all, if I try to ping 192.168.1.2 from the machine which is 192.168.120.161 and also I get nothing if I ping from slaverouter 192.168.120.2

Router_1841#sh ip nat trans

Router_1841#sh run | s nat|access-list|route-map

ip nat outside

ip nat inside

ip nat inside

ip nat inside

access-list 10 permit 192.168.96.0 0.0.30.255

access-list 101 permit ip 10.1.10.0 0.0.0.255 any

access-list 102 permit ip any 10.1.10.0 0.0.0.255

access-list 103 permit tcp any any

access-list 103 permit udp any any

access-list 103 permit icmp any any

access-list 190 permit icmp any any

Router_1841#

Advisor

cisco 1841 easy configuration help

Hi,

remove the  nat inside and nat outside from the interfaces as i told you to

in the 1841 config you posted I see you have an interface in 192.168.120.0/24 subnet which is connected to other router so where is this 192.168.120.161 host located ? how is this slave router connected to the 1841 ? what is this slave router model ?

Regards.

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
Beginner

Re: cisco 1841 easy configuration help

Thank you a lot, it looks like I finally successfully removed the NAT. Apologies, I have to look up the commands

I tried again pinging from the machine and nothing happened. Log is still enabled. Cisco can ping the slave router, but it can not ping the machine any more.

Router_1841#show run

Building configuration...

Current configuration : 1828 bytes

!

version 12.4

service timestamps debug uptime

service timestamps log datetime msec

no service password-encryption

!

hostname Router_1841

!

boot-start-marker

boot-end-marker

!

logging message-counter syslog

logging buffered 100000

enable secret 5 $1$vCYN$eOwyxxxxxxxxxxxxx

enable password xxxxxxxxxxxxxxxxxx

!

no aaa new-model

dot11 syslog

ip source-route

!

!

!

ip dhcp pool poolcisco

   network 10.1.10.0 255.255.255.0

   dns-server 8.8.8.8

   default-router 192.168.1.2

!

!

ip cef

ip name-server 91.80.37.100

ip name-server 8.8.8.8

no ipv6 cef

!

multilink bundle-name authenticated

!

!

!

!

!

archive

log config

  hidekeys

!

!

!

!

!

!

!

!

interface FastEthernet0/0

description outside

ip address 192.168.1.2 255.255.255.0

speed auto

full-duplex

no mop enabled

!

interface FastEthernet0/1

description dlinkLAN

ip address 192.168.125.1 255.255.255.0

speed auto

full-duplex

!

interface Serial0/0/0

no ip address

shutdown

clock rate 2000000

!

interface Serial0/0/1

no ip address

shutdown

clock rate 2000000

!

interface FastEthernet0/1/0

description linksysLAN

ip address 192.168.130.1 255.255.255.0

speed auto

full-duplex

!

interface FastEthernet0/1/1

description dlink2LAN

ip address 192.168.120.1 255.255.255.0

ip nat inside

ip virtual-reassembly

speed auto

full-duplex

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 192.168.1.1

no ip http server

no ip http secure-server

!

!

!

access-list 10 permit 192.168.96.0 0.0.30.255

access-list 101 permit ip 10.1.10.0 0.0.0.255 any

access-list 102 permit ip any 10.1.10.0 0.0.0.255

access-list 103 permit tcp any any

access-list 103 permit udp any any

access-list 103 permit icmp any any

access-list 190 permit icmp any any

!

!

!

!

!

!

control-plane

!

!

!

line con 0

line aux 0

line vty 0 4

password xxxxxxxxxxxx

login

!

scheduler allocate 20000 1000

end

Router_1841#

Advisor

cisco 1841 easy configuration help

Hi,

interface FastEthernet0/1/1

description dlink2LAN

ip address 192.168.120.1 255.255.255.0

ip nat inside

ip virtual-reassembly

speed auto

full-duplex

Remove this also and  post a diagram please.

Regards.

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
Beginner

cisco 1841 easy configuration help

in the 1841 config you posted I see you have an interface in 192.168.120.0/24 subnet which is connected to other router 

Yes, I have a physical cable that goes from the FE0/1/1 to a LAN port of this router. Previously, I tried to use WAN-LAN connection and call the interface 192.168.120.1 and the router 192.168.121.1 et cetera, but this did not work either.

so where is this 192.168.120.161 host located ? 



This is a little embedded PC and I have it connected to the slave router via ethernet.

how is this slave router connected to the 1841 ? 

via ethernet cable, LAN to LAN as I mentioned before. The embedded also has a browser window from which I access the slaverouter and do things such as pinging.

what is this slave router model ?

Since I know that consumer equipment can be wierd, after a few days of problems I have made sure to have various options available. At the moment the 120.2 is a D-link DIR-825, the 130.2 is a Lynksys (i figured it's more Cisco-friendly) wrt-54gl, and the 125.2 is an old di-524.

I can try and connect a machine directly to the Cisco1841 ethernet if it is helpful.

Thanks again, and I am rating 5* all your posts. This is extremely helpful.

Beginner

cisco 1841 easy configuration help

Yes hold on, I will post the diagram. But I can't seem to get rid of the NAT

Router_1841#configure

Configuring from terminal, memory, or network [terminal]?

Enter configuration commands, one per line.  End with CNTL/Z.

Router_1841(config)#interface fastethernet0/1/1

Router_1841(config-if)#no ip nat inside

Router_1841(config-if)#end

Router_1841#

*Nov  7 16:35:54.849: %SYS-5-CONFIG_I: Configured from console by console

Router_1841#

Router_1841#

and there is more

Router_1841#show ip interface brief

Interface                  IP-Address      OK? Method Status                Prot

ocol

FastEthernet0/0            192.168.1.2     YES manual up                    up

FastEthernet0/1            192.168.125.1   YES manual up                    up

Serial0/0/0                unassigned      YES NVRAM  administratively down down

Serial0/0/1                unassigned      YES NVRAM  administratively down down

FastEthernet0/1/0          192.168.130.1   YES manual up                    up

FastEthernet0/1/1          192.168.120.1   YES manual up                    up

NVI0                       192.168.1.2     YES unset  up                    up

Router_1841#

On the other hand it seems gone from show run

interface FastEthernet0/1/1

description dlink2LAN

ip address 192.168.120.1 255.255.255.0

speed auto

full-duplex

Beginner

Re: cisco 1841 easy configuration help

sorry, i am with mobile connection, I hope my sketch is readable, thanks again

Advisor

cisco 1841 easy configuration help

Hi,

send me a Private message

Regards.

Alain

Don't forget to rate helpful posts.
CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards