01-28-2011 02:56 PM - edited 03-04-2019 11:14 AM
Not sure if this is the right place to put my problem but I have a problem with my cisco router and I have no clue what is causing it. I tried using QoS and the problem still occurs. Any time during a game or streaming video I would lose connection for example in wow I will be able frozen can't cast or do anything. If I'm watching a streaming video it would lose connection.
I had a linksys WRT54G and it would work fine. No disconnects or freezing during gameplay.
Also if i'm using pandora it works fine. When I get a DC or frozen game I can still surf the internet.
here is my config.
!
darkorb#show run
Building configuration...
Current configuration : 7387 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname darkorb
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
enable secret 5
enable password 7
!
aaa new-model
!
!
aaa authentication login default local
aaa authorization exec default local
!
!
aaa session-id common
!
dot11 syslog
!
dot11 ssid GuestWLAN
vlan 20
authentication open
authentication key-management wpa
wpa-psk ascii 7
!
dot11 ssid MyWIFI
vlan 1
authentication open
authentication key-management wpa
guest-mode
wpa-psk ascii 7
!
ip source-route
!
!
ip dhcp excluded-address 192.168.1.1 192.168.1.99
ip dhcp excluded-address 192.168.2.1 192.168.2.99
!
ip dhcp pool Internal-net
import all
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
domain-name darkorb.local
lease 4
!
ip dhcp pool VLAN20
import all
network 192.168.2.0 255.255.255.0
default-router 192.168.2.1
domain-name darkorb.local
lease 4
!
!
ip cef
no ip domain lookup
ip domain name darkorb.local
ip inspect name MYFW appfw MYFW
ip inspect name MYFW tcp
ip inspect name MYFW udp
no ipv6 cef
!
appfw policy-name MYFW
application http
strict-http action allow
port-misuse tunneling action allow
port-misuse p2p action reset alarm
audit-trail on
!
multilink bundle-name authenticated
!
!
!
username admin privilege 15 password 7
!
!
!
archive
log config
hidekeys
!
!
!
class-map match-any WebEmail
match protocol http
match protocol secure-http
match protocol ftp
match protocol smtp
match protocol pop3
class-map match-any VoIP
match protocol skype
class-map match-any sdm_p2p_kazaa
match protocol fasttrack
match protocol kazaa2
class-map match-any sdm_p2p_edonkey
match protocol edonkey
class-map match-any sdm_p2p_gnutella
match protocol gnutella
class-map match-any sdm_p2p_bittorrent
match protocol bittorrent
class-map match-any counterstrike
match access-group name counterstrike
!
!
policy-map sdmappfwp2p_MYFW
class sdm_p2p_edonkey
drop
class sdm_p2p_gnutella
drop
class sdm_p2p_kazaa
drop
class sdm_p2p_bittorrent
drop
policy-map MyQoSPolicy
class sdm_p2p_bittorrent
drop
class VoIP
set dscp ef
priority percent 25
class counterstrike
bandwidth remaining percent 40
class WebEmail
bandwidth remaining percent 35
class sdm_p2p_edonkey
drop
class sdm_p2p_gnutella
drop
class sdm_p2p_kazaa
drop
class class-default
fair-queue
!
!
bridge irb
!
!
interface FastEthernet0
spanning-tree portfast
!
interface FastEthernet1
spanning-tree portfast
!
interface FastEthernet2
spanning-tree portfast
!
interface FastEthernet3
spanning-tree portfast
!
interface FastEthernet4
description Your WAN Interface to the Internet running at 1000
bandwidth 1000
ip address dhcp
ip access-group Internet-inbound-ACL in
ip access-group Internet-outbound-ACL out
ip nbar protocol-discovery
ip nat outside
ip inspect MYFW out
ip virtual-reassembly
ip tcp adjust-mss 1460
load-interval 30
duplex auto
speed auto
no cdp enable
service-policy input sdmappfwp2p_MYFW
!
interface Dot11Radio0
no ip address
no dot11 extension aironet
!
encryption vlan 1 mode ciphers tkip
!
encryption vlan 20 mode ciphers tkip
!
ssid WTF321
!
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
channel 2412
station-role root
no cdp enable
!
interface Dot11Radio0.1
encapsulation dot1Q 1 native
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface Dot11Radio0.20
description Guest wireless LAN - routed WLAN
encapsulation dot1Q 20
ip address 192.168.2.1 255.255.255.0
ip access-group Guest-ACL in
ip nat inside
ip inspect MYFW out
ip virtual-reassembly
shutdown
service-policy input sdmappfwp2p_MYFW
service-policy output sdmappfwp2p_MYFW
!
interface Vlan1
description Internal Network
no ip address
ip nat inside
ip virtual-reassembly
bridge-group 1
bridge-group 1 spanning-disabled
!
interface BVI1
description Bridge to Internal Network
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 dhcp
ip http server
ip http secure-server
!
!
ip nat inside source list 1 interface FastEthernet4 overload
!
ip access-list extended Guest-ACL
deny ip any 192.168.1.0 0.0.0.255
permit ip any any
ip access-list extended Internet-inbound-ACL
permit udp any eq bootps any eq bootpc
permit icmp any any echo
permit icmp any any echo-reply
permit icmp any any traceroute
permit gre any any
permit esp any any
ip access-list extended Internet-outbound-ACL
permit ip any any
permit ip 192.168.1.0 0.0.0.55 host 192.168.1.50
ip access-list extended counterstrike
permit tcp any any range 27030 27039
permit tcp any any range 27015 27020
permit udp any any range 27000 27015
permit udp any any range 1119 1120
permit tcp any any range 1119 1120
!
access-list 1 permit 192.168.1.0 0.0.0.255
access-list 1 permit 192.168.2.0 0.0.0.255
!
!
!
!
!
control-plane
!
bridge 1 route ip
!
line con 0
password 7
no modem enable
line aux 0
line vty 0 4
password 7
!
scheduler max-task-time 5000
end
darkorb#
01-29-2011 05:42 AM
Try to remove the following commands from int fa4:
ip nbar protocol-discovery
ip inspect MYFW out
service-policy input sdmappfwp2p_MYFW
Try this both one by one or in any valid combination and see if the problem disappears.
This will lower your security but if one of these is the cause, its the only way to find out.
In general, always triple-check your security settings when something from the Internet is not working.
regards,
Leo
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide