01-12-2011 01:30 AM - edited 03-04-2019 11:03 AM
Hi,
I have problem with my PPP connection. Router detects network, provider, signal strength and that is all ok. But my GSM profile is INACTIVE. How to activate it?
cellular 0 gsm profile create 1 APNTest ppp pap usertest pass123
Profile Information
====================
Profile 1 = INACTIVE*
--------
PDP Type = PPP
Access Point Name (APN) = APNTest
Authentication = PAP
Username: usertest, Password: pass123
* - Default profile
Solved! Go to Solution.
01-12-2011 02:08 AM
Hi,
The profile you created is using PPP instead of IPv4, as PDP Type.
PPP is supported only on DoCoMo networks in Japan.
Can you try to remove the profile and recreate it with IPv4 type?
cellular 0 gsm profile delete 1
cellular 0 gsm profile create 1 APNTest ipv4 pap usertest pass123
Note: in show cell 0 all, the profile will always be inactive, until cellular interface is up/up.
If you still have issues after the changes, can you collect these debugs, while doing a ping test? and also paste the config
- deb ppp nego
- deb dialer
- deb chat
Hope this helps
Marco
* Don't forget to rate posts when useful *
01-26-2011 03:23 AM
Hi Aleks,
Can you try the following steps:
1. the previous profile you sent me was configured with "pap usertest pass123", but in the dialer you are using "ppp pap sent-username User1 password 0 123451".
Can you configure the same user and password on both?
2. If that does not work, can you change both config (profile and dialer) to use CHAP instead of PAP?
3. I'd also remove the dialer configuration. The cellular interface is already a dialer per-se. You can move all the configuration under the cellular interface, it also simplify the troubleshooting.
I would use the following:
chat-script INTERNET "" "ATDT*99#" TIMEOUT 60 "CONNECT"
interface Cellular0
ip address negotiated
encapsulation ppp
dialer in-band
dialer string INTERNET
dialer-group 1
async mode interactive
ppp chap hostname usertest
ppp chap password 0 pass123
ppp ipcp dns request
ip route 0.0.0.0 0.0.0.0 Cellular0
access-list 1 permit any
dialer-list 1 protocol ip list 1
line 3
exec-timeout 0 0
script dialer INTERNET
login
modem InOut
no exec
transport input all
transport output all
Cheers
Marco
01-12-2011 02:08 AM
Hi,
The profile you created is using PPP instead of IPv4, as PDP Type.
PPP is supported only on DoCoMo networks in Japan.
Can you try to remove the profile and recreate it with IPv4 type?
cellular 0 gsm profile delete 1
cellular 0 gsm profile create 1 APNTest ipv4 pap usertest pass123
Note: in show cell 0 all, the profile will always be inactive, until cellular interface is up/up.
If you still have issues after the changes, can you collect these debugs, while doing a ping test? and also paste the config
- deb ppp nego
- deb dialer
- deb chat
Hope this helps
Marco
* Don't forget to rate posts when useful *
01-12-2011 07:33 AM
Hi,
we also had to configure ipv4 instead of ppp in the cellular 0 gsm profile create command.
Dont forget to unlock the SIM card with
cellular 0 gsm sim unlock
And we had to tell our pcex to use the right "band" with "at!band=08" .
Some debugging showed that an "at&s0" may be nessassary but it should be default and was already set
(and is usually ignored by wireless modems).
"Dec 23 14:53:27.883: TTY3: Async Int reset: Dropping DTR"
Finally, we found with the mobile carrier that the user was still logged in,
they thought the mobile just leaved the radio-reach of the base-station.
Timeout is quite long, and "ppp" ist just beetween the umts-stick and the router,
the umts-way is IPv4, so PPP LCP Keepalives are not end-to end but local inside your 881gg
and so a little bit useless.
So the carrier cleared the session and voila! the router could login again.
Also, on our dialer interface, ip unnumbered loopback 0 did not function but
ip address negotiated works.
we use c880data-universalk9-mz.151-1.T2.bin since the tested and some months working
c880data-universalk9-mz.124-20.T1.bin does not recognise the new umts dongle,
lloks like ppp negotiation is now different.
We found this usefull:
http://www.davidsudjiman.info/2009/05/29/cisco-881g-and-pcex-3g-hspa-configuration-cheat-sheet/
hth,
Juergen.
01-20-2011 03:33 AM
Hi folks,
since I've seen many customers getting confused by the PDP Type field in the profile, I've created a new document in Cisco Support Community:
https://supportforums.cisco.com/docs/DOC-14786
Hope this will helpful.
Marco
* Don't forget to rate posts when useful *
01-26-2011 01:22 AM
Hi,
I changed PDP type to IPv4
rest of the configuration is
chat-script INTERNET "" "ATD*99***1#" TIMEOUT 60 CONNECT
interface Cellular0
no ip address
ip virtual-reassembly
encapsulation ppp
load-interval 60
dialer in-band
dialer pool-member 1
async mode interactive
ppp pap sent-username User1 password 0 12345
ppp ipcp dns request
interface Dialer1
ip address negotiated
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer idle-timeout 0
dialer string INTERNET
dialer persistent
no cdp enable
line 3
exec-timeout 0 0
script dialer INTERNET
modem InOut
no exec
transport input all
transport output none
rxspeed 7200000
txspeed 5760000
Output on debug ppp negotioation
debug dialer
debug chat
*Jan 26 08:55:03.363: CHAT3: Attempting async line dialer script
*Jan 26 08:55:03.363: CHAT3: Dialing using Modem script: INTERNET & System script: none
*Jan 26 08:55:03.363: CHAT3: process started
*Jan 26 08:55:03.363: CHAT3: Asserting DTR
*Jan 26 08:55:03.367: CHAT3: Chat script INTERNET started
*Jan 26 08:55:03.367: CHAT3: Sending string: ATD*99***1#
*Jan 26 08:55:03.367: CHAT3: Expecting string: CONNECT
*Jan 26 08:55:03.379: CHAT3: Completed match for expect: CONNECT
*Jan 26 08:55:03.379: CHAT3: Chat script INTERNET finished, status = Success
*Jan 26 08:55:05.455: %LINK-3-UPDOWN: Interface Cellular0, changed state to up
*Jan 26 08:55:05.455: Ce0 DDR: Dialer statechange to up
*Jan 26 08:55:05.455: %DIALER-6-BIND: Interface Ce0 bound to profile Di1
*Jan 26 08:55:05.455: Ce0 DDR: Dialer call has been placed
*Jan 26 08:55:05.455: Ce0 PPP: Sending cstate UP notification
*Jan 26 08:55:05.455: Ce0 PPP: Processing CstateUp message
*Jan 26 08:55:05.455: PPP: Alloc Context [84FA4E48]
*Jan 26 08:55:05.455: ppp412 PPP: Phase is ESTABLISHING
*Jan 26 08:55:05.455: Ce0 PPP: Using dialer call direction
*Jan 26 08:55:05.455: Ce0 PPP: Treating connection as a callout
*Jan 26 08:55:05.455: Ce0 PPP: Session handle[33000030] Session id[412]
*Jan 26 08:55:05.455: Ce0 LCP: Event[OPEN] State[Initial to Starting]
*Jan 26 08:55:05.455: Ce0 PPP: No remote authentication for call-out
*Jan 26 08:55:05.455: Ce0 LCP: O CONFREQ [Starting] id 1 len 20
*Jan 26 08:55:05.455: Ce0 LCP: ACCM 0x000A0000 (0x0206000A0000)
*Jan 26 08:55:05.455: Ce0 LCP: MagicNumber 0xB46B5CB7 (0x0506B46B5CB7)
*Jan 26 08:55:05.455: Ce0 LCP: PFC (0x0702)
*Jan 26 08:55:05.455: Ce0 LCP: ACFC (0x0802)
*Jan 26 08:55:05.459: Ce0 LCP: Event[UP] State[Starting to REQsent]
*Jan 26 08:55:05.459: Ce0 LCP: I CONFREQ [REQsent] id 187 len 25
*Jan 26 08:55:05.459: Ce0 LCP: ACCM 0x00000000 (0x020600000000)
*Jan 26 08:55:05.459: Ce0 LCP: AuthProto CHAP (0x0305C22305)
*Jan 26 08:55:05.459: Ce0 LCP: MagicNumber 0xC3CD3260 (0x0506C3CD3260)
*Jan 26 08:55:05.459: Ce0 LCP: PFC (0x0702)
*Jan 26 08:55:05.459: Ce0 LCP: ACFC (0x0802)
*Jan 26 08:55:05.459: Ce0 LCP: O CONFACK [REQsent] id 187 len 25
*Jan 26 08:55:05.459: Ce0 LCP: ACCM 0x00000000 (0x020600000000)
*Jan 26 08:55:05.459: Ce0 LCP: AuthProto CHAP (0x0305C22305)
*Jan 26 08:55:05.459: Ce0 LCP: MagicNumber 0xC3CD3260 (0x0506C3CD3260)
*Jan 26 08:55:05.459: Ce0 LCP: PFC (0x0702)
*Jan 26 08:55:05.459: Ce0 LCP: ACFC (0x0802)
*Jan 26 08:55:05.459: Ce0 LCP: Event[Receive ConfReq+] State[REQsent to ACKsent]
*Jan 26 08:55:05.459: Ce0 LCP: I CONFACK [ACKsent] id 1 len 20
*Jan 26 08:55:05.459: Ce0 LCP: ACCM 0x000A0000 (0x0206000A0000)
*Jan 26 08:55:05.459: Ce0 LCP: MagicNumber 0xB46B5CB7 (0x0506B46B5CB7)
*Jan 26 08:55:05.459: Ce0 LCP: PFC (0x0702)
*Jan 26 08:55:05.459: Ce0 LCP: ACFC (0x0802)
*Jan 26 08:55:05.459: Ce0 LCP: Event[Receive ConfAck] State[ACKsent to Open]
*Jan 26 08:55:05.467: Ce0 PPP: Queue CHAP code[1] id[1]
*Jan 26 08:55:05.479: Ce0 PPP: Phase is AUTHENTICATING, by the peer
*Jan 26 08:55:05.479: Ce0 CHAP: Redirect packet to Ce0
*Jan 26 08:55:05.479: Ce0 CHAP: I CHALLENGE id 1 len 35 from "UMTS_CHAP_SRVR"
*Jan 26 08:55:05.479: Ce0 LCP: State is Open
*Jan 26 08:55:05.479: Ce0 CHAP: Unable to authenticate for peer
*Jan 26 08:55:05.479: Ce0 PPP DISC: User failed CHAP authentication
*Jan 26 08:55:05.479: Ce0 LCP: O TERMREQ [Open] id 2 len 4
*Jan 26 08:55:05.479: Ce0 LCP: Event[CLOSE] State[Open to Closing]
*Jan 26 08:55:05.479: Ce0 PPP: Phase is TERMINATING
*Jan 26 08:55:05.483: Ce0 LCP: I TERMACK [Closing] id 2 len 4
*Jan 26 08:55:05.483: Ce0 PPP: No remote authentication for call-out
*Jan 26 08:55:05.483: Ce0 LCP: Event[Receive TermAck] State[Closing to Closed]
*Jan 26 08:55:05.483: Ce0 LCP: Event[DOWN] State[Closed to Initial]
*Jan 26 08:55:05.483: Ce0 PPP: Phase is DOWN
*Jan 26 08:55:07.487: %LINK-5-CHANGED: Interface Cellular0, changed state to reset
*Jan 26 08:55:07.487: Ce0 DDR: has total 0 call(s), dial_out 0, dial_in 0
*Jan 26 08:55:07.487: %DIALER-6-UNBIND: Interface Ce0 unbound from profile Di1
*Jan 26 08:55:07.487: Ce0 PPP: Sending cstate DOWN notification
*Jan 26 08:55:07.487: Ce0 PPP: Processing CstateDown message
*Jan 26 08:55:08.487: Di1 DDR: No free dialer - starting fast idle timer
*Jan 26 08:55:09.487: Di1 DDR: No free dialer - starting fast idle timer
*Jan 26 08:55:10.563: Di1 DDR: No free dialer - starting fast idle timer
*Jan 26 08:55:11.563: Di1 DDR: No free dialer - starting fast idle timer
*Jan 26 08:55:12.563: %LINK-3-UPDOWN: Interface Cellular0, changed state to down
*Jan 26 08:55:12.563: Ce0 PPP: Sending cstate DOWN notification
*Jan 26 08:55:12.563: Di1 DDR: No free dialer - starting fast idle timer
*Jan 26 08:55:12.563: Ce0 PPP: Processing CstateDown message
*Jan 26 08:55:13.563: Di1 DDR: No free dialer - starting fast idle timer
*Jan 26 08:55:14.563: Di1 DDR: No free dialer - starting fast idle timer
*Jan 26 08:55:15.563: Di1 DDR: No free dialer - starting fast idle timer
*Jan 26 08:55:16.563: Di1 DDR: No free dialer - starting fast idle timer
*Jan 26 08:55:17.563: Di1 DDR: No free dialer - starting fast idle timer
*Jan 26 08:55:18.563: Di1 DDR: No free dialer - starting fast idle timer
*Jan 26 08:55:19.563: Di1 DDR: No free dialer - starting fast idle timer
*Jan 26 08:55:20.563: Di1 DDR: No free dialer - starting fast idle timer
*Jan 26 08:55:21.563: Di1 DDR: No free dialer - starting fast idle timer
*Jan 26 08:55:22.487: Ce0 DDR: re-enable timeout
*Jan 26 08:55:22.563: Ce0 DDR: rotor dialout [best] least recent failure is also most recent failure
*Jan 26 08:55:22.563: Ce0 DDR: rotor dialout [best] also has most recent failure
*Jan 26 08:55:22.563: Ce0 DDR: rotor dialout [best]
*Jan 26 08:55:22.563: Di1 DDR: Nailing up the Dialer profile [attempt 788259]
*Jan 26 08:55:22.563: Di1 DDR: Dialer dialing - persistent dialer profile
*Jan 26 08:55:22.563: Ce0 DDR: Dialing cause Persistent Dialer Profile
*Jan 26 08:55:22.563: Ce0 DDR: Attempting to dial INTERNET
*Jan 26 08:55:22.563: CHAT3: Attempting async line dialer script
*Jan 26 08:55:22.563: CHAT3: Dialing using Modem script: INTERNET & System script: none
*Jan 26 08:55:22.563: CHAT3: process started
*Jan 26 08:55:22.563: CHAT3: Asserting DTR
*Jan 26 08:55:22.567: CHAT3: Chat script INTERNET started
*Jan 26 08:55:22.567: CHAT3: Sending string: ATD*99***1#
*Jan 26 08:55:22.567: CHAT3: Expecting string: CONNECT
*Jan 26 08:56:22.567: CHAT3: Timeout expecting: CONNECT
*Jan 26 08:56:22.567: CHAT3: Chat script INTERNET finished, status = Connection timed out; remote ho
st not responding
*Jan 26 08:56:22.567: Ce0 DDR: disconnecting call
*Jan 26 08:56:37.567: Ce0 DDR: re-enable timeout
*Jan 26 08:56:38.567: Ce0 DDR: rotor dialout [best] least recent failure is also most recent failure
*Jan 26 08:56:38.567: Ce0 DDR: rotor dialout [best] also has most recent failure
*Jan 26 08:56:38.567: Ce0 DDR: rotor dialout [best]
*Jan 26 08:56:38.567: Di1 DDR: Nailing up the Dialer profile [attempt 788260]
*Jan 26 08:56:38.567: Di1 DDR: Dialer dialing - persistent dialer profile
*Jan 26 08:56:38.567: Ce0 DDR: Dialing cause Persistent Dialer Profile
*Jan 26 08:56:38.567: Ce0 DDR: Attempting to dial INTERNET
*Jan 26 08:56:38.567: CHAT3: Attempting async line dialer script
*Jan 26 08:56:38.567: CHAT3: Dialing using Modem script: INTERNET & System script: none
*Jan 26 08:56:38.567: CHAT3: process started
*Jan 26 08:56:38.567: CHAT3: Asserting DTR
*Jan 26 08:56:38.567: CHAT3: Chat script INTERNET started
*Jan 26 08:56:38.571: CHAT3: Sending string: ATD*99***1#
*Jan 26 08:56:38.571: CHAT3: Expecting string: CONNECT
*Jan 26 08:57:38.571: CHAT3: Timeout expecting: CONNECT
*Jan 26 08:57:38.571: CHAT3: Chat script INTERNET finished, status = Connection timed out; remote ho
st not responding
*Jan 26 08:57:38.571: Ce0 DDR: disconnecting call
As I can see even if chat script is successful connection couldn't be established. What can be the reason?
Regards,
Aleksandar
01-26-2011 03:23 AM
Hi Aleks,
Can you try the following steps:
1. the previous profile you sent me was configured with "pap usertest pass123", but in the dialer you are using "ppp pap sent-username User1 password 0 123451".
Can you configure the same user and password on both?
2. If that does not work, can you change both config (profile and dialer) to use CHAP instead of PAP?
3. I'd also remove the dialer configuration. The cellular interface is already a dialer per-se. You can move all the configuration under the cellular interface, it also simplify the troubleshooting.
I would use the following:
chat-script INTERNET "" "ATDT*99#" TIMEOUT 60 "CONNECT"
interface Cellular0
ip address negotiated
encapsulation ppp
dialer in-band
dialer string INTERNET
dialer-group 1
async mode interactive
ppp chap hostname usertest
ppp chap password 0 pass123
ppp ipcp dns request
ip route 0.0.0.0 0.0.0.0 Cellular0
access-list 1 permit any
dialer-list 1 protocol ip list 1
line 3
exec-timeout 0 0
script dialer INTERNET
login
modem InOut
no exec
transport input all
transport output all
Cheers
Marco
01-27-2011 05:54 AM
I also had like this problem. BUT NOW IT IS SOLVED.
I used this debugs:
debug modem
debug chat
debug ppp negotiation
debug ppp error
debug ppp authentication
debug ppp authorization
debug dialer
And .. I got this:
*Jan 27 06:04:32.511: Ce0 PPP DISC: User failed CHAP authentication
So, just add
int cel 0
ppp chap refuse..
Look at this.. also https://supportforums.cisco.com/thread/2064440
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide