cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
2301
Views
0
Helpful
15
Replies
Highlighted
Beginner

Cisco 887VA M K9 on domestic (dynamic IP) BT ADSL

Does anyone have a working config for this setup, I configured using the BT instructions but still no internet, I have tried various solutions from the forums but still no internet or ability to ping outside networks. I have in vain tried to get the latest BT firmware for the router but no joy so far.

Thanks in advance

Lee

Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions
VIP Advisor

Re: Cisco 887VA M K9 on domestic (dynamic IP) BT ADSL

Hello Lee

Okay then just change the dhcp pool to have your isp dns server address instead of  your router then you should be good to go.

You can remove the two virgin dns server address also is you wish.

res

Paul

Please don't forget to rate any posts that have been helpful.

Thanks.



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
15 REPLIES 15
Beginner

Cisco 887VA M K9 on domestic (dynamic IP) BT ADSL

config I have at the moment

Current configuration : 1810 bytes

!

! Last configuration change at 08:25:23 UTC Mon Apr 22 2013

!

version 15.1

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Uzi

!

boot-start-marker

boot-end-marker

!

!

enable password ******

!

no aaa new-model

memory-size iomem 10

crypto pki token default removal timeout 0

!

!

ip source-route

!

!

!

!

ip dhcp pool sdm-pool

   import all

   network 192.168.0.0 255.255.255.0

   default-router 192.168.0.9

   lease 0 2

!

!

ip cef

no ipv6 cef

!

!

license udi pid CISCO887VA-M-K9 sn FCZ1513C57J

!

!

!

!

!

!

controller VDSL 0

!

!

!

!

!

!

!

!

interface Ethernet0

no ip address

shutdown

!

interface ATM0

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip flow ingress

no atm ilmi-keepalive

!

interface ATM0.1 point-to-point

pvc 0/38

  encapsulation aal5mux ppp dialer

  dialer pool-member 1

!

!

interface FastEthernet0

description Ethernet

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface Vlan1

ip address 192.168.0.9 255.255.255.0

ip nat inside

ip virtual-reassembly in

!

interface Dialer0

ip address negotiated

ip mtu 1492

ip nat outside

ip virtual-reassembly in

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication chap callin

ppp chap hostname anything@btinternet.com

ppp chap password 0 passwd

no cdp enable

!

ip forward-protocol nd

ip http server

no ip http secure-server

!

ip nat inside source list 101 interface Dialer0 overload

ip route 0.0.0.0 0.0.0.0 Dialer0

!

logging esm config

access-list 101 permit ip 192.168.0.0 0.0.255.255 any

access-list 101 permit ip 0.0.0.0 255.255.255.0 any

!

!

!

!

!

control-plane

!

!

line con 0

no modem enable

line aux 0

line vty 0 4

password ********

login

transport input all

!

end

VIP Advisor

Re: Cisco 887VA M K9 on domestic (dynamic IP) BT ADSL

Hello

What dsl technology are you supposed to be using? - ADSL/VDSL etcc..

Do you get an ip address from the ISP -

sh int dialer 0

Try rebooting the adsl/vdsl modem

res

Paul

Please don't forget to rate any posts that have been helpful.

Thanks.



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Beginner

Cisco 887VA M K9 on domestic (dynamic IP) BT ADSL

Hi there

dsl is ADSL2 and Ip is allocated dynamically from ISP

dialer0 config

Uzi#sh int dialer0

Dialer0 is up, line protocol is up (spoofing)

  Hardware is Unknown

  Internet address is 109.150.72.199/32

  MTU 1500 bytes, BW 56 Kbit/sec, DLY 20000 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation PPP, LCP Closed, loopback not set

  Keepalive set (10 sec)

  DTR is pulsed for 1 seconds on reset

  Interface is bound to Vi2

  Last input never, output never, output hang never

  Last clearing of "show interface" counters 00:03:16

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: weighted fair

  Output queue: 0/1000/64/0 (size/max total/threshold/drops)

     Conversations  0/0/16 (active/max active/max total)

     Reserved Conversations 0/0 (allocated/max allocated)

     Available Bandwidth 42 kilobits/sec

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     7 packets input, 448 bytes

     22 packets output, 858 bytes

Bound to:

Virtual-Access2 is up, line protocol is up

  Hardware is Virtual Access interface

  MTU 1500 bytes, BW 895 Kbit/sec, DLY 20000 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation PPP, LCP Open

  Open: IPCP

  PPPoATM vaccess, cloned from Dialer0

  Vaccess status 0x44

  Bound to ATM0.1 VCD: 1, VPI: 0, VCI: 38, loopback not set

  Keepalive set (10 sec)

  DTR is pulsed for 5 seconds on reset

  Interface is bound to Di0 (Encapsulation PPP)

  Last input 00:00:05, output never, output hang never

  Last clearing of "show interface" counters 00:01:56

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     30 packets input, 1920 bytes, 0 no buffer

     Received 0 broadcasts (0 IP multicasts)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

     28 packets output, 973 bytes, 0 underruns

     0 output errors, 0 collisions, 0 interface resets

     0 unknown protocol drops

     0 output buffer failures, 0 output buffers swapped out

     0 carrier transitions

Uzi#

The PPP light is now on and it looks like a get an address from my ISP

I cannot ping outside my network? and have no internet access

Could this be a NAT issue

Thanks

Lee

Beginner

Cisco 887VA M K9 on domestic (dynamic IP) BT ADSL

I cannot ping from A LAN machine but I can ping eg 4.2.2.2 from the router interface

VIP Advisor

Re: Cisco 887VA M K9 on domestic (dynamic IP) BT ADSL

Hello,

your  nat seems okay,

I see you are using subnet 0 in this ip range for dhcp,  try changing it

service dhcp

ip dhcp excluded-address 192.168.1.9

ip dhcp pool sdm-pool

   network 192.168.1.0 255.255.255.0

   default-router 192.168.1.9

   lease 0 2

and ammend your acl,

no  access-list 101

Access-list 101 permit ip 192.168.1.0 0.0.0.255 any

interface Vlan1

ip address 192.168.1.9 255.255.255.0

res

Paul

Please don't forget to rate any posts that have been helpful.

Thanks.



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Beginner

Re: Cisco 887VA M K9 on domestic (dynamic IP) BT ADSL

Hi Paul

Uzi#sh config

Using 1808 out of 262136 bytes

!

! Last configuration change at 09:39:39 UTC Mon Apr 29 2013

!

version 15.1

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Uzi

!

boot-start-marker

boot-end-marker

!

!

enable password *********

!

no aaa new-model

memory-size iomem 10

crypto pki token default removal timeout 0

!

!

ip source-route

!

!

!

ip dhcp excluded-address 192.168.1.9

!

ip dhcp pool sdm-pool

   import all

   network 192.168.1.0 255.255.255.0

   default-router 192.168.1.9

   lease 0 2

!

!

ip cef

no ipv6 cef

!

!

license udi pid CISCO887VA-M-K9 sn FCZ1513C57J

!

!

!

!

!

!

controller VDSL 0

!

!

!

!

!

!

!

!

interface Ethernet0

no ip address

shutdown

no fair-queue

!

interface ATM0

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip flow ingress

no atm ilmi-keepalive

!

interface ATM0.1 point-to-point

pvc 0/38

  encapsulation aal5mux ppp dialer

  dialer pool-member 1

!

!

interface FastEthernet0

description Ethernet

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface Vlan1

ip address 192.168.1.9 255.255.255.0

ip nat inside

ip virtual-reassembly in

!

interface Dialer0

ip address negotiated

ip mtu 1492

ip nat outside

ip virtual-reassembly in

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication chap callin

ppp chap hostname anything@btinternet.com

ppp chap password 0 passwd

no cdp enable

!

ip forward-protocol nd

ip http server

no ip http secure-server

!

ip nat inside source list 101 interface Dialer0 overload

ip route 0.0.0.0 0.0.0.0 Dialer0

!

logging esm config

access-list 101 permit ip 192.168.1.0 0.0.0.255 any

!

!

!

!

!

control-plane

!

!

line con 0

no modem enable

line aux 0

line vty 0 4

password **********

login

transport input all

!

end

Ping results

Uzi#ping 4.2.2.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 4.2.2.2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 24/28/36 ms

Uzi#ping www.google.com

Translating "www.google.com"...domain server (255.255.255.255)

% Unrecognized host or address, or protocol not running.

Uzi#

Thanks

Lee

VIP Advisor

Re: Cisco 887VA M K9 on domestic (dynamic IP) BT ADSL

Hello lee,

You dont say where you pinging this from, however you can add a dns server for the dhcp clinets  and for the router is you wish.

ip dhcp pool sdm-pool

dns-server 192.168.1.9

exit

ip name-server 8.8.8.8 194.168.4.100 194.168.8.100

res

Paul

Please don't forget to rate any posts that have been helpful.

Thanks.



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Beginner

Re: Cisco 887VA M K9 on domestic (dynamic IP) BT ADSL

Now were getting somewhere

ping sent from the router interface (via telnet)

Uzi#ping www.google.com

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 173.194.34.179, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 28/30/32 ms

Uzi#

ping sent from local machine attached to router via ethernet cable

pinging 173.194.34.179 succeedes with 4 good replies

pinging www.google.com

Ping request could not find host www.google.com. Please check the name and try again

VIP Advisor

Re: Cisco 887VA M K9 on domestic (dynamic IP) BT ADSL

Hello Lee,

Did you amend you dhcp pool to included the dns server 192.168.1.9

Do an ipconfig /all on local  machine and see if they have a dns server allocated

if not

ipconfig /release

ipconfig /renew

ipconfig /registerdns

then try again

res

Paul



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Beginner

Re: Cisco 887VA M K9 on domestic (dynamic IP) BT ADSL

Just to check I changed the last couple of name servers to a couple supplied by my ISP (British Telecom), exactly the same result, cannot resolve a website name but can find an IP address? puzzled!

VIP Advisor

Re: Cisco 887VA M K9 on domestic (dynamic IP) BT ADSL

Hello Lee

Just to confirm,  you can ping the internet from the client now  but cannot resolve the FQDN ( dns name) correct?

Have you refreshed the clients pc ip address as I suggested?

res

Paul

Please don't forget to rate any posts that have been helpful.

Thanks.



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Beginner

Re: Cisco 887VA M K9 on domestic (dynamic IP) BT ADSL

build so far

Uzi#sh config

Using 1970 out of 262136 bytes

!

! Last configuration change at 11:44:39 UTC Mon Apr 29 2013

!

version 15.1

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Uzi

!

boot-start-marker

boot-end-marker

!

!

enable password *******

!

no aaa new-model

memory-size iomem 10

crypto pki token default removal timeout 0

!

!

ip source-route

!

!

!

ip dhcp excluded-address 192.168.1.9

!

ip dhcp pool sdm-pool

   import all

   network 192.168.1.0 255.255.255.0

   default-router 192.168.1.9

   dns-server 192.168.1.9

   lease 0 2

!

!

ip cef

ip name-server 8.8.8.8

ip name-server 194.168.4.100

ip name-server 194.168.8.100

ip name-server 62.6.40.178

ip name-server 62.6.40.162

no ipv6 cef

!

!

license udi pid CISCO887VA-M-K9 sn FCZ1513C57J

!

!

!

!

!

!

controller VDSL 0

!

!

!

!

!

!

!

!

interface Ethernet0

no ip address

shutdown

no fair-queue

!

interface ATM0

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip flow ingress

no atm ilmi-keepalive

!

interface ATM0.1 point-to-point

pvc 0/38

  encapsulation aal5mux ppp dialer

  dialer pool-member 1

!

!

interface FastEthernet0

description Ethernet

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface Vlan1

ip address 192.168.1.9 255.255.255.0

ip nat inside

ip virtual-reassembly in

!

interface Dialer0

ip address negotiated

ip mtu 1492

ip nat outside

ip virtual-reassembly in

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication chap callin

ppp chap hostname anything@btinternet.com

ppp chap password 0 passwd

no cdp enable

!

ip forward-protocol nd

ip http server

no ip http secure-server

!

ip nat inside source list 101 interface Dialer0 overload

ip route 0.0.0.0 0.0.0.0 Dialer0

!

logging esm config

access-list 101 permit ip 192.168.1.0 0.0.0.255 any

!

!

!

!

!

control-plane

!

!

line con 0

no modem enable

line aux 0

line vty 0 4

password ******

login

transport input all

!

end

tried same ping tests on another pc and same results,

have saved config, rebooted router, restarted PC's

network cards are set to get ip address automatically from DHCP (and they do get an address in the 192.168.1. range)

use DNS servers is set to automatic. (if i add a DNS server manually such as 62.6.40.178) then ping and internet work fine.

some settings collected fron network card;

dhcp server shows 192.168.1.9

default gateway  192.168.1.9

ipv4 address 192.168.1.1

windows ip configuration

host name...............uziLaptop-win8

primary dns suffix......

node type.................hybrid

ip routing enabled......no

wins proxy enabled....no

I did try the refresh dns settings as well

Thanks

Lee

VIP Advisor

Re: Cisco 887VA M K9 on domestic (dynamic IP) BT ADSL

Hello Lee

Okay then just change the dhcp pool to have your isp dns server address instead of  your router then you should be good to go.

You can remove the two virgin dns server address also is you wish.

res

Paul

Please don't forget to rate any posts that have been helpful.

Thanks.



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Beginner

Re: Cisco 887VA M K9 on domestic (dynamic IP) BT ADSL

Perfect

Solved

I will post a finished running config when I get back tomorrow

Thanks

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards