cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
354
Views
0
Helpful
9
Replies
Highlighted
Beginner

Cisco ASA 5505 version 6.4

Hi,

We have cisco 5505 with device manager version 6.4

I am trying to run nat (inside,outside) cli commands and its not taking in. Do we have incompatibility with those commands on this version?

 

Just trying to configure l2tp vpn for win 10 users but cisco tutorial command are not working on this device. Following this below tutorial

https://www.cisco.com/c/en/us/support/docs/ip/layer-two-tunnel-protocol-l2tp/200340-Configure-L2TP-Over-IPsec-Between-Window.html

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Master

Re: Cisco ASA 5505 version 6.4

@paul driver asks a good question to verify interface names. And the posted config does confirm that nameif are inside and outside. So that is not the issue.

 

The original post asks a key question " Do we have incompatibility with those commands on this version?"  And I believe that the answer is yes there is a version incompatibility. The original post does not supply the specifics of what they are attempting to configure. But it sure does suggest that the tutorial that they were following uses the now current syntax for address translation for ASA. That syntax was introduced in release 8.3. Since this ASA is running 8.2(5) it would be using the old syntax for address translation.

 

HTH

 

Rick

View solution in original post

9 REPLIES 9
VIP Advisor

Re: Cisco ASA 5505 version 6.4

what is the ASA Version here ?

BB
*** Rate All Helpful Responses ***
Beginner

Re: Cisco ASA 5505 version 6.4

It says Cisco Adaptive Security Appliance Software Version 8.2 (5)

VIP Advisor

Re: Cisco ASA 5505 version 6.4

Hello


@Talha wrote:

Hi,

We have cisco 5505 with device manager version 6.4

I am trying to run nat (inside,outside) cli commands and its not taking in. Do we have incompatibility with those commands on this version?


Curious are the lan/wan interfaces name inside/outside?

 

 



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Beginner

Re: Cisco ASA 5505 version 6.4

Here is what is saying

 

User Access Verification

Username: dennis
Password: ***********
Type help or '?' for a list of available commands.
tds-asa5505> en
Password: ***********
tds-asa5505# sh int ip bri
Interface                  IP-Address      OK? Method Status                Protocol
Ethernet0/0                unassigned      YES unset  up                    up
Ethernet0/1                unassigned      YES unset  down                  down
Ethernet0/2                unassigned      YES unset  up                    up
Ethernet0/3                unassigned      YES unset  up                    up
Ethernet0/4                unassigned      YES unset  down                  down
Ethernet0/5                unassigned      YES unset  down                  down
Ethernet0/6                unassigned      YES unset  down                  down
Ethernet0/7                unassigned      YES unset  down                  down
Internal-Data0/0           unassigned      YES unset  up                    up
Internal-Data0/1           unassigned      YES unset  up                    up
Vlan1                      192.168.200.1   YES CONFIG up                    up
Vlan2                      Public IP x.x.x.x    YES CONFIG up                    up
Vlan5                      172.168.18.1    YES CONFIG down                  down
Virtual0                   127.0.0.1       YES unset  up                    up
tds-asa5505#

VIP Advisor

Re: Cisco ASA 5505 version 6.4

Can you post the configuration output

 

show run

 

BB
*** Rate All Helpful Responses ***
Beginner

Re: Cisco ASA 5505 version 6.4

tds-asa5505#    sh run
: Saved
:
ASA Version 8.2(5)
!
hostname tds-asa5505

names
name 192.168.200.66 ProviewCamera description Security Camera
name 192.168.200.2 DHCPRelay description TDS DHCP
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.200.1 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 pppoe client vpdn group BELL
 ip address pppoe setroute
!
interface Vlan5
 no forward interface Vlan2
 nameif dmz
 security-level 50
 ip address 172.168.18.1 255.255.255.0
!
ftp mode passive
dns server-group DefaultDNS
 domain-name tds.local
same-security-traffic permit intra-interface
object-group service camera tcp
 port-object eq 6036
 port-object eq 82
object-group network PPTPServer
object-group network obj-192.168.200.2
object-group network INTERNAL-SUBNET
 network-object 192.168.200.0 255.255.255.0
object-group network L2TP-SUBNET
 network-object 10.10.20.0 255.255.255.0
access-list tds_splitTunnelAcl standard permit 172.168.18.0 255.255.255.0
access-list tds_splitTunnelAcl standard permit 192.168.200.0 255.255.255.0
access-list inside_nat0_outbound extended deny ip any 192.168.200.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip 172.168.18.0 255.255.255.0 192.168.200.64 255.255.255.192
access-list inside_nat0_outbound extended permit ip 172.168.18.0 255.255.255.0 192.168.200.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip 192.168.200.0 255.255.255.0 host 172.168.18.99
access-list inside_nat0_outbound extended permit ip 192.168.200.0 255.255.255.0 192.168.100.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip any 10.10.100.0 255.255.255.128
access-list inside_nat0_outbound extended permit ip any 192.168.100.64 255.255.255.192
access-list dmz_in extended permit ip any any
access-list out_in extended permit tcp any interface outside eq www
access-list out_in extended permit tcp any interface outside eq https
access-list out_in extended permit tcp any interface outside object-group camera
access-list out_in extended permit ip any any

access-list TCP extended permit ip any host 192.168.200.200
access-list TCP extended permit ip host 192.168.200.200 any
access-list inside_access_out extended permit ip any any
pager lines 24
logging enable
logging buffered debugging
logging asdm informational
mtu inside 1500
mtu outside 1500
mtu dmz 1500
ip local pool tdsvpn 192.168.100.90-192.168.100.99 mask 255.255.255.0
ip local pool TDS 10.10.100.1-10.10.100.100 mask 255.255.255.0
ip local pool L2TP-POOL 10.10.20.1-10.10.20.100
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (inside) 1 interface
global (outside) 1 interface
global (dmz) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) tcp interface https 192.168.200.200 https netmask 255.255.255.255
static (inside,outside) tcp interface 82 ProviewCamera www netmask 255.255.255.255
static (inside,outside) tcp interface 6036 ProviewCamera 6036 netmask 255.255.255.255
static (inside,inside) tcp 70.20.x.x www 192.168.200.200 www netmask 255.255.255.255
static (inside,outside) tcp interface www 192.168.200.200 www netmask 255.255.255.255
static (inside,outside) tcp interface pptp DHCPRelay pptp netmask 255.255.255.255
access-group inside_access_out out interface inside
access-group out_in in interface outside
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
aaa authentication telnet console LOCAL
http server enable
http 192.168.200.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
sysopt noproxyarp inside
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac

crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec transform-set TRANS_ESP_3DES_SHA esp-3des esp-sha-hmac
crypto ipsec transform-set TRANS_ESP_3DES_SHA mode transport
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map outside_map interface outside
crypto ca trustpoint _SmartCallHome_ServerCA
 crl configure
crypto ca certificate chain _SmartCallHome_ServerCA
 certificate ca 6ecc7aa5a7032009b8cebcf4e952d491
    308205ec 308204d4 a0030201 0202106e cc7aa5a7 032009b8 cebcf4e9 52d49130
    0d06092a 864886f7 0d010105 05003081 ca310b30 09060355 04061302 55533117
    30150603 55040a13 0e566572 69536967 6e2c2049 6e632e31 1f301d06 0355040b
    13165665 72695369 676e2054 72757374 204e6574 776f726b 313a3038 06035504
    0b133128 63292032 30303620 56657269 5369676e 2c20496e 632e202d 20466f72
    20617574 686f7269 7a656420 75736520 6f6e6c79 31453043 06035504 03133c56
    65726953 69676e20 436c6173 73203320 5075626c 69632050 72696d61 72792043
    65727469 66696361 74696f6e 20417574 686f7269 7479202d 20473530 1e170d31
    30303230 38303030 3030305a 170d3230 30323037 32333539 35395a30 81b5310b
    30090603 55040613 02555331 17301506 0355040a 130e5665 72695369 676e2c20
    496e632e 311f301d 06035504 0b131656 65726953 69676e20 54727573 74204e65
    74776f72 6b313b30 39060355 040b1332 5465726d 73206f66 20757365 20617420
    68747470 733a2f2f 7777772e 76657269 7369676e 2e636f6d 2f727061 20286329
    3130312f 302d0603 55040313 26566572 69536967 6e20436c 61737320 33205365
    63757265 20536572 76657220 4341202d 20473330 82012230 0d06092a 864886f7
    0d010101 05000382 010f0030 82010a02 82010100 b187841f c20c45f5 bcab2597
    a7ada23e 9cbaf6c1 39b88bca c2ac56c6 e5bb658e 444f4dce 6fed094a d4af4e10
    9c688b2e 957b899b 13cae234 34c1f35b f3497b62 83488174 d188786c 0253f9bc
    7f432657 5833833b 330a17b0 d04e9124 ad867d64 12dc744a 34a11d0a ea961d0b
    15fca34b 3bce6388 d0f82d0c 948610ca b69a3dca eb379c00 48358629 5078e845
    63cd1941 4ff595ec 7b98d4c4 71b350be 28b38fa0 b9539cf5 ca2c23a9 fd1406e8
    18b49ae8 3c6e81fd e4cd3536 b351d369 ec12ba56 6e6f9b57 c58b14e7 0ec79ced
    4a546ac9 4dc5bf11 b1ae1c67 81cb4455 33997f24 9b3f5345 7f861af3 3cfa6d7f
    81f5b84a d3f58537 1cb5a6d0 09e4187b 384efa0f 02030100 01a38201 df308201
    db303406 082b0601 05050701 01042830 26302406 082b0601 05050730 01861868
    7474703a 2f2f6f63 73702e76 65726973 69676e2e 636f6d30 12060355 1d130101
    ff040830 060101ff 02010030 70060355 1d200469 30673065 060b6086 480186f8
    45010717 03305630 2806082b 06010505 07020116 1c687474 70733a2f 2f777777
    2e766572 69736967 6e2e636f 6d2f6370 73302a06 082b0601 05050702 02301e1a
    1c687474 70733a2f 2f777777 2e766572 69736967 6e2e636f 6d2f7270 61303406
    03551d1f 042d302b 3029a027 a0258623 68747470 3a2f2f63 726c2e76 65726973
    69676e2e 636f6d2f 70636133 2d67352e 63726c30 0e060355 1d0f0101 ff040403
    02010630 6d06082b 06010505 07010c04 61305fa1 5da05b30 59305730 55160969
    6d616765 2f676966 3021301f 30070605 2b0e0302 1a04148f e5d31a86 ac8d8e6b
    c3cf806a d448182c 7b192e30 25162368 7474703a 2f2f6c6f 676f2e76 65726973
    69676e2e 636f6d2f 76736c6f 676f2e67 69663028 0603551d 11042130 1fa41d30
    1b311930 17060355 04031310 56657269 5369676e 4d504b49 2d322d36 301d0603
    551d0e04 1604140d 445c1653 44c1827e 1d20ab25 f40163d8 be79a530 1f060355
    1d230418 30168014 7fd365a7 c2ddecbb f03009f3 4339fa02 af333133 300d0609
    2a864886 f70d0101 05050003 82010100 0c8324ef ddc30cd9 589cfe36 b6eb8a80
    4bd1a3f7 9df3cc53 ef829ea3 a1e697c1 589d756c e01d1b4c fad1c12d 05c0ea6e
    b2227055 d9203340 3307c265 83fa8f43 379bea0e 9a6c70ee f69c803b d937f47a
    6decd018 7d494aca 99c71928 a2bed877 24f78526 866d8705 404167d1 273aeddc
    481d22cd 0b0b8bbc f4b17bfd b499a8e9 762ae11a 2d876e74 d388dd1e 22c6df16
    b62b8214 0a945cf2 50ecafce ff62370d ad65d306 4153ed02 14c8b558 28a1ace0
    5becb37f 954afb03 c8ad26db e6667812 4ad99f42 fbe198e6 42839b8f 8f6724e8
    6119b5dd cdb50b26 058ec36e c4c875b8 46cfe218 065ea9ae a8819a47 
  quit
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
telnet 0.0.0.0 0.0.0.0 inside
telnet timeout 60
ssh timeout 5
console timeout 0
management-access inside
vpdn group BELL request dialout pppoe
vpdn group BELL localname logon336@bellnet.ca
vpdn group BELL ppp authentication pap

dhcp-client update dns server both
dhcpd auto_config outside
!

threat-detection basic-threat
threat-detection statistics access-list
threat-detection statistics tcp-intercept rate-interval 30 burst-rate 400 average-rate 200
webvpn
group-policy DefaultRAGroup internal
group-policy DefaultRAGroup attributes
 dns-server value 8.8.8.8 4.4.4.2
 vpn-tunnel-protocol l2tp-ipsec
 default-domain value tds.local
group-policy DefaultRAGroup_1 internal
group-policy DefaultRAGroup_1 attributes
 dns-server value 8.8.8.8 4.4.4.2
 vpn-tunnel-protocol l2tp-ipsec
 default-domain value tds.local
group-policy tds internal
group-policy tds attributes
 dns-server value 192.168.200.2
 vpn-tunnel-protocol IPSec l2tp-ipsec
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value tds_splitTunnelAcl
 default-domain value tds.local
group-policy GroupPolicy1 internal
group-policy GroupPolicy1 attributes
 vpn-tunnel-protocol IPSec l2tp-ipsec
group-policy support internal
group-policy support attributes
 vpn-tunnel-protocol IPSec
 default-domain value tds.local
group-policy TDS internal
group-policy TDS attributes
 dns-server value 8.8.8.8
 vpn-tunnel-protocol l2tp-ipsec
 default-domain value tds.local

username accsoft password AD7dCkG5m4Q5Fv3T encrypted
username accsoft attributes
 service-type remote-access
username jhenderson password IRSAW1Xim0wDou5L encrypted
username jhenderson attributes
 service-type remote-access
username kimrichards password 8uueUjwBIZt99D0j encrypted
username absdeveloper password /EC.g3H8oVOowiLS encrypted privilege 0
username absdeveloper attributes
 service-type remote-access
username tgovpn password vFLOd0qezHmcYKb1 encrypted
username tgovpn attributes
 service-type remote-access
username support password wH9IjqZ2/g6/l6X2 encrypted privilege 0
username support attributes
 vpn-group-policy tds
username melanie password QabVs9lU4FWkvyC2 encrypted
username melanie attributes
 service-type remote-access
username krichards password HhlZz8dQ3zQEDdu3 encrypted
username christina password mZ2Eyf1Ga48XNBNU encrypted
username christina attributes
 service-type remote-access
username shady password 3gTvfiXK4mb2hx/rgA/8ig== nt-encrypted
username shady attributes
 service-type admin
tunnel-group DefaultRAGroup general-attributes
 address-pool tdsvpn
 address-pool TDS
 default-group-policy DefaultRAGroup_1
tunnel-group DefaultRAGroup ipsec-attributes
 pre-shared-key *****
tunnel-group tds type remote-access
tunnel-group tds general-attributes
 address-pool tdsvpn
 default-group-policy tds
tunnel-group tds ipsec-attributes
 pre-shared-key *****
tunnel-group support type remote-access
tunnel-group support general-attributes
 address-pool tdsvpn
 default-group-policy support
tunnel-group support ipsec-attributes
 pre-shared-key *****
tunnel-group TDS type remote-access
tunnel-group TDS general-attributes
 address-pool tdsvpn
 default-group-policy TDS
tunnel-group TDS ipsec-attributes
 pre-shared-key *****
!
class-map TCP
 match access-list TCP
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum client auto
  message-length maximum 512
policy-map TCP
 class TCP
  set connection advanced-options tcp-state-bypass
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
  inspect ip-options
  inspect pptp
!
service-policy global_policy global
service-policy TCP interface inside
prompt hostname context
service call-home
call-home reporting anonymous
call-home
 contact-email-addr 
 profile CiscoTAC-1
  destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
  destination address email 
  destination transport-method http
  subscribe-to-alert-group diagnostic
  subscribe-to-alert-group environment
  subscribe-to-alert-group inventory periodic monthly
  subscribe-to-alert-group configuration periodic monthly
  subscribe-to-alert-group telemetry periodic daily
Cryptochecksum:9ae6c11b49ff6490f526c7daac47dc5e
: end
tds-asa5505#

Hall of Fame Master

Re: Cisco ASA 5505 version 6.4

@paul driver asks a good question to verify interface names. And the posted config does confirm that nameif are inside and outside. So that is not the issue.

 

The original post asks a key question " Do we have incompatibility with those commands on this version?"  And I believe that the answer is yes there is a version incompatibility. The original post does not supply the specifics of what they are attempting to configure. But it sure does suggest that the tutorial that they were following uses the now current syntax for address translation for ASA. That syntax was introduced in release 8.3. Since this ASA is running 8.2(5) it would be using the old syntax for address translation.

 

HTH

 

Rick

View solution in original post

Beginner

Re: Cisco ASA 5505 version 6.4

Hi Rick,
Can you please also suggest what commands will work here in place of nat ( inside, outside).I am trying to configure l2tp remote access vpn.
Sent from Yahoo Mail on Android
Hall of Fame Master

Re: Cisco ASA 5505 version 6.4

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards