03-29-2023
03:54 AM
- last edited on
04-03-2023
02:57 AM
by
Translator
Hi,
I am new to networking, and I am trying to setup a simple config for a Cisco C1117 to work over cellular network, but I am having issues with getting internet access, I can ping IP's but not the names from the router and when my laptop is connected, and I am not sure what I am missing from the DNS side of things?
I am using Cellular0/2/0 as the interface with the SIM, and connecting my laptop to g0/1/0
Any ideas, config below
!
version 16.9
service timestamps debug datetime msec
service timestamps log datetime msec
service internal
service call-home
platform qfp utilization monitor load 80
no platform punt-keepalive disable-kernel-core
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
call-home
! If contact email address in call-home is configured as sch-smart-licensing@cisco.com
! the email address configured in Cisco Smart License Portal will be used as contact email address to send SCH notifications.
contact-email-addr sch-smart-licensing@cisco.com
profile "CiscoTAC-1"
active
destination transport-method http
no destination transport-method email
!
!
!
ip name-server 8.8.8.8
ip dhcp excluded-address 192.168.1.0
ip dhcp excluded-address 192.168.1.255 255.255.255.255
!
ip dhcp pool WEBUIPool
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 8.8.8.8
!
!
!
!
!
!
!
!
!
!
subscriber templating
!
!
multilink bundle-name authenticated
!
!
!
crypto pki trustpoint TP-self-signed-1011696673
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-1011696673
revocation-check none
rsakeypair TP-self-signed-1011696673
!
crypto pki trustpoint SLA-TrustPoint
enrollment pkcs12
revocation-check crl
!
!
quit
!
license udi pid xxx sn xxx
license smart enable
license smart conversion automatic
!
diagnostic bootup level minimal
!
spanning-tree extend system-id
!
!
!
redundancy
mode none
!
controller Cellular 0/2/0
lte sim data-profile 1 attach-profile 1 slot 0
lte modem link-recovery rssi onset-threshold -110
lte modem link-recovery monitor-timer 20
lte modem link-recovery wait-timer 10
lte modem link-recovery debounce-count 6
!
controller VDSL 0/3/0
!
!
vlan internal allocation policy ascending
!
!
!
!
!
!
interface GigabitEthernet0/0/0
no ip address
negotiation auto
!
interface GigabitEthernet0/1/0
!
interface GigabitEthernet0/1/1
!
interface GigabitEthernet0/1/2
!
interface GigabitEthernet0/1/3
!
interface Cellular0/2/0
description Primary_
ip address negotiated
ip nat outside
dialer in-band
dialer idle-timeout 0
dialer-group 1
pulse-time 1
!
interface Cellular0/2/1
no ip address
!
interface ATM0/3/0
no ip address
atm oversubscribe factor 2
no atm enable-ilmi-trap
!
interface Ethernet0/3/0
no ip address
no negotiation auto
!
interface Vlan1
ip address 192.168.1.1 255.255.255.0
ip nat inside
!
ip nat inside source list 1 interface Cellular0/2/0 overload
ip nat inside source list 197 interface Cellular0/2/0 overload
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
ip route 0.0.0.0 0.0.0.0 Cellular0/2/0
!
!
access-list 1 permit any
access-list 197 permit ip any any
dialer-list 1 protocol ip permit
!
!
!
!
control-plane
!
!
line con 0
transport input none
stopbits 1
line vty 0 4
login
!
!
!
!
!
!
end
Solved! Go to Solution.
03-30-2023
04:40 AM
- last edited on
04-03-2023
03:01 AM
by
Translator
If you looking to resolve from your Router you need to add the below command :
(config)#ip domain lookup
Also to make it neat you do not need both NAT config- you can use any of them as below :
ip nat inside source list 1 interface Cellular0/2/0 overload
no ip nat inside source list 197 interface Cellular0/2/0 overload
Rather any - i go granular for internal subnet as below :
no access-list 1 permit any
access-list 1 permit 192.168.1.0 0.0.0.255 any
03-30-2023
03:57 AM
- last edited on
04-03-2023
02:59 AM
by
Translator
This is what I get from a Ping
Router#ping 8.8.8.8
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/48/56 ms
Router#ping cisco.com
% Unrecognized host or address, or protocol not running.
03-30-2023 04:05 AM
I see a lot of this issue these day,
I think it SP issue not your wrong config,
anyway
try use
8.8.4.4 instead of 8.8.8.8 in dhcp pool and check again
03-30-2023
04:40 AM
- last edited on
04-03-2023
03:01 AM
by
Translator
If you looking to resolve from your Router you need to add the below command :
(config)#ip domain lookup
Also to make it neat you do not need both NAT config- you can use any of them as below :
ip nat inside source list 1 interface Cellular0/2/0 overload
no ip nat inside source list 197 interface Cellular0/2/0 overload
Rather any - i go granular for internal subnet as below :
no access-list 1 permit any
access-list 1 permit 192.168.1.0 0.0.0.255 any
03-30-2023
05:17 AM
- last edited on
04-03-2023
03:02 AM
by
Translator
Excellent, I can now ping from the router to DNS, I think it was this command, thanks
access-list 1 permit 192.168.1.0 0.0.0.255 any
now when I plug my laptop into g0/1/0, it does the same cant ping address, but can IP's, will I just need add the vlan1 to this access list 1?
03-31-2023
04:29 AM
- last edited on
04-03-2023
03:23 AM
by
Translator
Let's address 1 issue at a time, Now you can ping from Router using the DNS name,
Now the issue you have is a host is connected to Router and not able to resolve the DNS Lookup ( are you manually configuring the PC IP address -Hope so ?)
Post from the command
ipconfig /all
or configure as below and test it.
03-31-2023 02:55 AM
Adding to access list 1 didn't seem to help either, what else am I missing ?
03-31-2023 03:53 AM
did you change the DNS server to 8.8.4.4 ??
03-31-2023 06:41 AM
All sorted, my fault had some strange settings on my laptop, thanks for the help!
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide