01-10-2020 11:59 AM - edited 01-10-2020 12:02 PM
Hi.
I bought a ISR 1111-8p for testing and i want to set the wan port with this parameters
PPPoATM (or PPPoA or PPP Over ATM);VPI=8; VCI=35; encapsulation VC-Mux (sended me by ISP)
I want to apply these commands taken here
https://www.cisco.com/en/US/docs/ios/bbdsl/configuration/guide/bba_agg_ppp_atm.html
But when i type "interface atm 0", It return error because of atm command doesn't exists, instead atm-acr exists.
Why atm command not exists and how can i do ti set the wan Port of the router?
Solved! Go to Solution.
01-10-2020 02:41 PM
Hello,
make the changes marked in bold to your configuration. I made some assumptions regarding the IP addresses of Vlan 1 and Vlan 2, if yours are different, change them accordingly:
Current configuration : 4510 bytes
!
! Last configuration change at 21:52:51 UTC Fri Jan 10 2020
!
version 16.9
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
platform qfp utilization monitor load 80
no platform punt-keepalive disable-kernel-core
!
hostname CISCO1111
!
boot-start-marker
boot-end-marker
!
enable secret 5 xxxxx
!
no aaa new-model
!
subscriber templating
multilink bundle-name authenticated
vpdn enable
!
vpdn-group 1
request-dialin
protocol pppoe
!
crypto pki trustpoint TP-self-signed-xxxx
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-xxxx
revocation-check none
rsakeypair TP-self-signed-2511702922
!
crypto pki certificate chain TP-self-signed-2511702922
certificate self-signed 01
xxxxxxxxx
quit
!
license udi pid C1111-8P sn xxx
no license smart enable
!
diagnostic bootup level minimal
!
spanning-tree extend system-id
!
username cisco privilege 15 password 7 xxxx
username admin secret 5 xxxxxx
!
redundancy
mode none
!
ip dhcp excluded-address 192.168.1.1
ip dhcp excluded-address 192.168.2.1
!
ip dhcp pool VLAN1
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 8.8.8.8
!
ip dhcp pool VLAN2
network 192.168.2.0 255.255.255.0
default-router 192.168.2.1
dns-server 8.8.8.8
!
vlan internal allocation policy ascending
!
interface GigabitEthernet0/0/0
ip address dhcp
ip nat outside
speed 1000
no negotiation auto
!
interface GigabitEthernet0/0/1
no ip address
speed 1000
no negotiation auto
!
interface GigabitEthernet0/1/0
shutdown
!
interface GigabitEthernet0/1/1
shutdown
!
interface GigabitEthernet0/1/2
!
interface GigabitEthernet0/1/3
shutdown
!
interface GigabitEthernet0/1/4
shutdown
!
interface GigabitEthernet0/1/5
switchport access vlan 2
!
interface GigabitEthernet0/1/6
switchport access vlan 2
spanning-tree portfast
!
interface GigabitEthernet0/1/7
switchport access vlan 2
spanning-tree portfast
!
interface Vlan1
ip address 192.168.1.0 255.255.255.0
ip nat inside
!
interface Vlan2
ip address 192.168.2.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
ip nat inside source list 1 interface GigabitEthernet0/0/0 overload
!
access-list 1 permit 192.168.1.0 0.0.0.255
access-list 1 permit 192.168.2.0 0.0.0.255
!
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0/0 dhcp
!
ip forward-protocol nd
!
ip ssh version 2
!
control-plane
!
line con 0
transport input none
stopbits 1
line vty 0 4
password 7 06555B781D4907
login local
transport input ssh
line vty 5 15
password 7 06555B781D4907
login local
transport input ssh
!
pnp profile pnp_cco_profile
transport https ipv4 xxxxx port xxx
01-10-2020 12:33 PM
Hello,
did you configure the controller?
ISR1111#conf t
ISR1111(config)#controller vdsl slot/subslot/port
ISR1111(config-controller)#operating mode auto
Do you have an ATM interface ?
interface ATM0/3/0
no ip address
no atm oversubscribe
no atm enable-ilmi-trap
no shut
!
interface ATM0/3/0.1 point-to-point
ip address 100.100.100.1 255.255.255.0
no atm enable-ilmi-trap
pvc 1/38
vbr-rt 400 400
01-10-2020 12:53 PM
01-10-2020 01:06 PM
Hello,
your model does not support any ADSL/VDSL. You need the 1112-1116 models. Check the data sheet Table 7:
01-10-2020 01:12 PM
01-10-2020 01:19 PM
Hello,
you need to connect a GigabitEthernet port to the D-Link and set it to 'ip address dhcp'. Then you need to perform double NAT.
Post the running configuration of the ISR so we can fill in the bits and pieces...
01-10-2020 02:07 PM - edited 01-10-2020 02:08 PM
Hello,
ok, with ip address dhcp the router is connected with the internet ( the ping to google.com answer accurately )
Now it needs of the Nat.
This is the show run
Current configuration : 4510 bytes
!
! Last configuration change at 21:52:51 UTC Fri Jan 10 2020
!
version 16.9
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
platform qfp utilization monitor load 80
no platform punt-keepalive disable-kernel-core
!
hostname CISCO1111
!
boot-start-marker
boot-end-marker
!
!
enable secret 5 xxxxx
!
no aaa new-model
!
!
!
!
!
!
!
!
!
!
!
subscriber templating
multilink bundle-name authenticated
vpdn enable
!
vpdn-group 1
request-dialin
protocol pppoe
!
!
!
!
crypto pki trustpoint TP-self-signed-xxxx
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-xxxx
revocation-check none
rsakeypair TP-self-signed-2511702922
!
!
crypto pki certificate chain TP-self-signed-2511702922
certificate self-signed 01
xxxxxxxxx
quit
!
license udi pid C1111-8P sn xxx
no license smart enable
!
diagnostic bootup level minimal
!
spanning-tree extend system-id
!
!
username cisco privilege 15 password 7 xxxx
username admin secret 5 xxxxxx
!
redundancy
mode none
!
!
vlan internal allocation policy ascending
!
!
!
!
!
!
interface GigabitEthernet0/0/0
ip address dhcp
ip nat outside
speed 1000
no negotiation auto
!
interface GigabitEthernet0/0/1
no ip address
speed 1000
no negotiation auto
!
interface GigabitEthernet0/1/0
shutdown
!
interface GigabitEthernet0/1/1
shutdown
!
interface GigabitEthernet0/1/2
!
interface GigabitEthernet0/1/3
shutdown
!
interface GigabitEthernet0/1/4
shutdown
!
interface GigabitEthernet0/1/5
switchport access vlan 2
!
interface GigabitEthernet0/1/6
switchport access vlan 2
!
interface GigabitEthernet0/1/7
switchport access vlan 2
!
interface Vlan1
no ip address
!
interface Vlan2
ip address dhcp
ip nat inside
ip virtual-reassembly
!
router rip
version 2
network 192.168.1.0
network 192.168.2.0
no auto-summary
!
ip default-gateway 192.168.1.1
ip nat inside source list 1 interface Dialer0 overload
ip forward-protocol nd
ip default-network 192.168.1.1
ip ssh version 2
!
!
!
!
!
!
control-plane
!
!
line con 0
transport input none
stopbits 1
line vty 0 4
password 7 06555B781D4907
login local
transport input ssh
line vty 5 15
password 7 06555B781D4907
login local
transport input ssh
!
!
!
!
!
!
!
pnp profile pnp_cco_profile
transport https ipv4 xxxxx port xxx
end
01-10-2020 02:41 PM
Hello,
make the changes marked in bold to your configuration. I made some assumptions regarding the IP addresses of Vlan 1 and Vlan 2, if yours are different, change them accordingly:
Current configuration : 4510 bytes
!
! Last configuration change at 21:52:51 UTC Fri Jan 10 2020
!
version 16.9
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
platform qfp utilization monitor load 80
no platform punt-keepalive disable-kernel-core
!
hostname CISCO1111
!
boot-start-marker
boot-end-marker
!
enable secret 5 xxxxx
!
no aaa new-model
!
subscriber templating
multilink bundle-name authenticated
vpdn enable
!
vpdn-group 1
request-dialin
protocol pppoe
!
crypto pki trustpoint TP-self-signed-xxxx
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-xxxx
revocation-check none
rsakeypair TP-self-signed-2511702922
!
crypto pki certificate chain TP-self-signed-2511702922
certificate self-signed 01
xxxxxxxxx
quit
!
license udi pid C1111-8P sn xxx
no license smart enable
!
diagnostic bootup level minimal
!
spanning-tree extend system-id
!
username cisco privilege 15 password 7 xxxx
username admin secret 5 xxxxxx
!
redundancy
mode none
!
ip dhcp excluded-address 192.168.1.1
ip dhcp excluded-address 192.168.2.1
!
ip dhcp pool VLAN1
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 8.8.8.8
!
ip dhcp pool VLAN2
network 192.168.2.0 255.255.255.0
default-router 192.168.2.1
dns-server 8.8.8.8
!
vlan internal allocation policy ascending
!
interface GigabitEthernet0/0/0
ip address dhcp
ip nat outside
speed 1000
no negotiation auto
!
interface GigabitEthernet0/0/1
no ip address
speed 1000
no negotiation auto
!
interface GigabitEthernet0/1/0
shutdown
!
interface GigabitEthernet0/1/1
shutdown
!
interface GigabitEthernet0/1/2
!
interface GigabitEthernet0/1/3
shutdown
!
interface GigabitEthernet0/1/4
shutdown
!
interface GigabitEthernet0/1/5
switchport access vlan 2
!
interface GigabitEthernet0/1/6
switchport access vlan 2
spanning-tree portfast
!
interface GigabitEthernet0/1/7
switchport access vlan 2
spanning-tree portfast
!
interface Vlan1
ip address 192.168.1.0 255.255.255.0
ip nat inside
!
interface Vlan2
ip address 192.168.2.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
ip nat inside source list 1 interface GigabitEthernet0/0/0 overload
!
access-list 1 permit 192.168.1.0 0.0.0.255
access-list 1 permit 192.168.2.0 0.0.0.255
!
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0/0 dhcp
!
ip forward-protocol nd
!
ip ssh version 2
!
control-plane
!
line con 0
transport input none
stopbits 1
line vty 0 4
password 7 06555B781D4907
login local
transport input ssh
line vty 5 15
password 7 06555B781D4907
login local
transport input ssh
!
pnp profile pnp_cco_profile
transport https ipv4 xxxxx port xxx
01-10-2020 03:25 PM
Also the host are connected to internet. Thanks a lot !!!
Only a step is not clear, not works and i skipped it. This :
interface Vlan1
ip address 192.168.1.0 255.255.255.0
ip nat inside
01-11-2020 01:08 AM
Hello,
it is quite possible that your D-Link router uses 192.168.1.0 as well, so if that is the case, you might have to use a different address space for your Vlan 1...
01-11-2020 03:52 AM
Yes, dlink router use 192.168.1.0 network. I will use another network address for the default vlan 1.
Thank you.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide