cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
796
Views
0
Helpful
2
Replies

Complex connectivity issue involving softswitch, bgp router, vlans & routes

mgdvecima
Level 1
Level 1

I have a rather complex issue that involves a Cisco softswitch, a Cisco router configured for BGP routing, a L2 Cisco switch, and two RAD IPMUXs.

I am including a flat diagram that illustrates the layer 2 connections. On the diagram, the number adjacent to the vertical connection bar is the vlans allowed on that connection, either switchport access or trunk.

I use BGP routing on the router to advertise various routes. The issue is that the routes for the RAD IPMUX216 and RAD24 are both being advertised correctly and can be seen from remote sites. For example, from any remote site, I can ping any address on vlan 60 such as the switch, router, and IMMUX216 IPs. However, I can only ping the vlan 61 IPs for the router and switch, but not the RAD24. Even from the Softswitch and Router, I cannot ping the vlan 61 ip of the RAD24, 172.22.248.6. I can ping the softswitch from the router and vice-versa.

Here is a flat diagram for the network with some snippets of code. I can provide more info if needed. I changed the routable IPs just to hide some of our actual info. If I ping 172.22.248.6 from the softswitch and then issue the "sh arp" command, I get:

Victoria-SW#sh arp

Protocol  Address          Age (min)  Hardware Addr   Type   Interface

Internet  172.22.248.1            0   0016.4650.c411  ARPA   Vlan61

Internet  172.22.255.6            -   0019.5678.7d43  ARPA   Vlan80

Internet  172.22.248.6            0   Incomplete      ARPA

Internet  172.22.240.14           -   0019.5678.7d42  ARPA   Vlan60

Internet  172.22.240.13           0   0020.d239.01a0  ARPA   Vlan60

Internet  172.22.248.5            -   0019.5678.7d44  ARPA   Vlan61

Internet  172.22.240.1           69   0016.4650.c411  ARPA   Vlan60

CiscoLD.jpeg

2 Replies 2

saeedkhalid
Level 1
Level 1

have you tried connecting a second user on the IP MUX on vlan 61 and pinging b/w them ?

also try connecting a vlan 61 user directly on the switch and ping

if possible post the config of switch and IPMUX

Hi, Saeed

I forgot to update my posts. Last week, I did configure a laptop with the IP info of the IPMUX:

ip add: 172.22.248.6/29 and DG of 172.22.248.1 and plugged it into the same port that the IPMUX 24's User3 port was plugged into. I was able to ping this laptop from the switch and the router.

Here are some snippets that relate to network config of the switch, router, and IPMUX24.

Snippet from switch

interface FastEthernet1/0/1

description RAD MUX216 NET

switchport access vlan 50

switchport mode access

spanning-tree portfast

!

interface FastEthernet1/0/2

description RAD MUX216 User

switchport access vlan 60

switchport mode access

spanning-tree portfast

interface FastEthernet1/0/18

description To IPMUX24 Net1

switchport access vlan 44

switchport mode access

speed 100

duplex full

interface FastEthernet1/0/24

description To IPMUX24 User3

switchport access vlan 61

switchport mode access

speed 100

duplex full

!

interface GigabitEthernet1/0/1

description Victoria-GW

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 44,50,60,61

switchport mode trunk

speed 100

duplex full

!

interface GigabitEthernet1/0/2

description to Dropper

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 44

switchport mode trunk

interface Vlan1

no ip address

!

interface Vlan50

ip address 201.153.190.254 255.255.255.240

!

interface Vlan60

ip address 172.22.240.14 255.255.255.240

!

interface Vlan61

ip address 172.22.248.5 255.255.255.248

!

interface Vlan80

ip address 172.22.255.6 255.255.255.248

!

ip classless

ip route 0.0.0.0 0.0.0.0 201.153.190.241

Snippet from router

interface FastEthernet0/1

bandwidth 10000

no ip address

duplex full

speed 100

interface FastEthernet0/1.44

encapsulation dot1Q 44

ip address 216.10.78.1 255.255.255.248

!

interface FastEthernet0/1.50

encapsulation dot1Q 50

ip address 201.153.190.241 255.255.255.240

!

interface FastEthernet0/1.60

encapsulation dot1Q 60

ip address 172.22.240.1 255.255.255.240

!

interface FastEthernet0/1.61

encapsulation dot1Q 61

ip address 172.22.248.1 255.255.255.248

router bgp 6XXXX

no synchronization

no bgp fast-external-fallover

bgp always-compare-med

bgp log-neighbor-changes

network 172.22.0.0 mask 255.255.248.0

network 172.22.240.0 mask 255.255.255.240

network 172.22.248.0 mask 255.255.255.248

network 216.10.78.0 mask 255.255.255.248

network 201.153.190.240 mask 255.255.255.240

ip route 172.22.0.0 255.255.248.0 Null0

ip route 172.22.240.0 255.255.255.240 172.22.240.14

ip route 172.22.248.0 255.255.255.248 Null0

ip route 216.10.78.0 255.255.255.248 Null0

ip route 201.153.190.240 255.255.255.240 Null0

Snippet from IPMUX-24

Configuration>System>Management>Host IP                       

1. IP address                           ... (216.10.78.3)

2. IP mask                              ... (255.255.255.240)   

3. DHCP                                     (Disable)

4. Read Community                       ... (public)

5. Write Community                      ... (private)

6. Trap Community                       ... (SNMP_trap)

7. Encapsulation                        >

Configuration>System>Management>Host IP>Encapsulation

1. Host Tagging                             (Tagged)

2. Host VLAN ID[1 - 4094]               ... (44)

3. Host VLAN Priority[0 - 7]            ... (7)

Configuration>Connection>PW Host IP                            

1. IP address                           ... (172.22.248.6)

2. IP mask                              ... (255.255.255.248)

Configuration>Router

1. Static Route Table            []>

2. Default gateway               ... (216.10.78.2)

Configuration>Router>Static Route Table

  IP Address        IP Mask           Next Hop

  172.22.240.13     255.255.255.240   172.22.248.1

Configuration>Bridge>VLAN Membership

Note: Delete VLAN 2

    VLAN ID[1 - 4094]             ... (44)

1. Egress Tagged Ports           >   (5)

2. Egress Untagged Ports         >   (1)

3. Egress Unmodified Ports       >  

*Configuration>Bridge>VLAN Membership

    VLAN ID[1 - 4094]             ... (61)

1. Egress Tagged Ports           >   (4)

2. Egress Untagged Ports         >   (3)

3. Egress Unmodified Ports       >  

Configuration>Bridge>Bridge Port

    Port Label                         >   (1)

    Bridge Port                        >   (Network-ETH1)

1. Ingress Filtering                      (Enable)

2. Accept Frame Type                      (All)

3. Port Vid \ Stacking Vid[1 - 4094]  ... (44)

4. Default Priority Tag[0 - 7]        ... (0)

5. Egress Tag Handling                    (None)

6. Ingress Tag Handling                   (None)

7. L2CP Handling                      >

Configuration>Bridge>Bridge Port

    Port Label                         >   (2)

    Bridge Port                        >   (Network/User-ETH2)

1. Ingress Filtering                      (Enable)

2. Accept Frame Type                      (All)

3. Port Vid \ Stacking Vid[1 - 4094]  ... (1)

4. Default Priority Tag[0 - 7]        ... (0)

5. Egress Tag Handling                    (None)

6. Ingress Tag Handling                   (None)

7. L2CP Handling                      >

Configuration>Bridge>Bridge Port

    Port Label                         >   (3)

    Bridge Port                        >   (User-ETH3)

1. Ingress Filtering                      (Enable)

2. Accept Frame Type                      (All)

3. Port Vid \ Stacking Vid[1 - 4094]  ... (61)

4. Default Priority Tag[0 - 7]        ... (7)

5. Egress Tag Handling                    (None)

6. Ingress Tag Handling                   (None)

7. L2CP Handling                      >

...guration>Connection>Bundle Connection

TDM channel ID: 1  Bundle ID: 1

1. Destination IP Address                  ... (172.22.240.13)

2. Bundle Name                             ... (Hopscotch)

3. IP TOS[0 - 255]                         ... (0)

4. Connection Status                           (Enable)

5. Destination Bundle[1 - 8063]            ... (1)

6. Redundancy Function                     >   (None )

7. TDM Bytes In Frame(x48 Bytes)[1 - 30]   ... (8)

8. Payload Format                          >   (V2)

9. Far End Type                            >   (T1(ESF))

10. OAM Connectivity                            (Enable)

... (N)

...guration>Connection>Bundle Connection

TDM channel ID: 1  Bundle ID: 1

... (P)

11. Jitter Buffer [msec][2.5 - 180]         ... (8.0)

12. Sensitive                                   (Data)

13. OOS Mode                                    (Tx OOS)

14. VLAN Tagging                                (Enable)

15. VLAN ID[1 - 4094]                       ... (61)

16. VLAN Priority[0 - 7]                    ... (7)

17. RTP Header                                  (Disable)

Review Cisco Networking products for a $25 gift card