01-02-2020 12:14 PM
Team, I would like to use gi0/2 as a way to get my internet in from my ISP. The ONT has an Ethernet port on it, that is currently connected to an HWIC-1FE card which provides me with 100 mbps. Since I'm going to upgrade to 500 mbps, and possibly Gigabit, I need to have a compatible port on this router. Can anyone provide me with some configuration steps on how to do it?
Here's the running config on my router at the moment. Thanks in advance!
Building configuration... Current configuration : 2671 bytes ! ! Last configuration change at 10:43:44 EST Thu Jan 2 2020 ! version 15.7 service timestamps debug datetime msec service timestamps log datetime msec no service password-encryption ! hostname HomeRouter-001 ! boot-start-marker boot system flash:c3900-universalk9-mz.SPA.157-3.M5.bin boot-end-marker ! ! enable secret 5 $1$d.au$f/puBghk0fn9ztVqTehNn. ! no aaa new-model clock timezone EST -5 0 ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ip dhcp excluded-address 192.168.1.1 192.168.1.30 ! ip dhcp pool internal network 192.168.1.0 255.255.255.0 default-router 192.168.1.1 dns-server 8.8.8.8 8.8.4.4 netbios-name-server 192.168.1.1 lease infinite ! ip dhcp pool internal2 network 192.168.2.0 255.255.255.0 default-router 192.168.2.1 dns-server 8.8.8.8 8.8.4.4 netbios-name-server 192.168.2.1 lease infinite ! ! ! ip name-server 8.8.8.8 ip name-server 8.8.4.4 ip cef no ipv6 cef ! ! multilink bundle-name authenticated ! ! ! ! ! ! voice-card 0 ! ! ! ! ! ! ! ! vxml logging-tag license udi pid C3900-SPE150/K9 sn FOC15505HWS license accept end user agreement license boot module c3900 technology-package datak9 ! ! ! redundancy ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! interface Embedded-Service-Engine0/0 no ip address shutdown ! interface GigabitEthernet0/0 ip address 192.168.1.1 255.255.255.0 ip nat inside ip virtual-reassembly in duplex auto speed auto ! interface GigabitEthernet0/1 ip address 192.168.2.1 255.255.255.0 ip nat inside ip virtual-reassembly in duplex auto speed auto ! interface GigabitEthernet0/2 ip address dhcp ip access-group ISP in ip nat outside ip virtual-reassembly in duplex auto speed auto ! interface FastEthernet0/0/0 description INTERNET ip address dhcp ip access-group MY-WAN in ip nat outside ip virtual-reassembly in duplex auto speed auto ! ! ip forward-protocol nd ! no ip http server no ip http secure-server ! ip dns server ip nat inside source list 1 interface FastEthernet0/0/0 overload ! ipv6 ioam timestamp ! nls resp-timeout 1 cpd cr-id 1 ! access-list 1 permit 192.168.1.0 0.0.0.255 access-list 1 permit 192.168.2.0 0.0.0.255 ! control-plane ! ! ! ! ! ! mgcp behavior rsip-range tgcp-only mgcp behavior comedia-role none mgcp behavior comedia-check-media-src disable mgcp behavior comedia-sdp-force disable ! mgcp profile default ! ! ! ! ! ! ! gatekeeper shutdown
Solved! Go to Solution.
01-06-2020 01:39 AM
Hello
If you want to swap the port around well that can be done but you need to change any routing (dynamic/static) any nat configuration pointing to the old interface to the new interface, plus keep in mind your going from a 100mb fastethernet to gigabitethernet so the otherside of the connection needs to be able to support gigabit otherwise you will have to hardcode the gigabit interface down to a lower speed
Example
conf t
default interface gig0/2
default inerface fa0/0/0
no ip nat inside source list 1 interface FastEthernet0/0/0 overload
no ip route 0.0.0.0 0.0.0.0 FastEthernet0/0/0 dhcp
interface GigabitEthernet0/2
description INTERNET
ip address dhcp
ip access-group MY-WAN in
ip nat outside
interface FastEthernet0/0/0
ip address dhcp
ip access-group ISP in
ip nat outside
ip nat inside source list 1 interface GigabitEthernet0/2 overload
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0/0 dhcp
01-02-2020 12:45 PM - edited 01-02-2020 12:47 PM
Hello
You could possibly procure a wan card for one for the EHWIC slots and use that, or if the router has any spare sfp slots use a 1gb copper sfp?
01-02-2020 12:47 PM
I have an EHWIC-4SG card installed in the router, but it doesn't show up in my interfaces and I can't figure out why. I was going to use that, until someone told me that I could use the regular ports on the router to do what I'm trying to do.
01-02-2020 01:02 PM - edited 01-02-2020 01:06 PM
Hello
@RBM01991 wrote:
I have an EHWIC-4SG card installed in the router, but it doesn't show up in my interfaces and I can't figure out why.
Is that card compatible for that router?
Have you tried another HWIC slot?
Have you rebooted the router after inserting the card?
@RBM01991 wrote:
until someone told me that I could use the regular ports on the router to do what I'm trying to do.
You can if you have any spare?
sh inventory
sh version
sh ip int brief
01-02-2020 01:38 PM
I've done all 3 of those and the card still doesn't show up, however if I do sh inventory or sh diag, it comes up there.
01-02-2020 02:02 PM
If you have done all the steps suggest, this module is not hot-swappable as per my experience. and you able to see the show inventory.
then try other suggestions as per the below and let us know how it goes?
You still have an issue, please show below information :
show inventory
show interfaces
show license
01-02-2020 04:49 PM
I'll try those in the morning, thank you.
01-02-2020 04:48 PM
I also do have a Gigabit port on the router itself free, I have Gigabit 0/0 connected to my switch, Gigabit 0/1 connected to my server and Gigabit 0/2 is free and its the one I intend on using for this purpose.
01-02-2020 05:31 PM
if the ports are free you can use them too. (i do not see any issue here)
01-02-2020 05:34 PM
Ok, so would I configure gi0/2 in this instance?
01-02-2020 06:21 PM
you have come configuration already as below :
interface GigabitEthernet0/2 ip address dhcp ip access-group ISP in ip nat outside ip virtual-reassembly in duplex auto speed auto
make appropriate changes and test it, make sure you change the routing from your FastEther to the new port and adjust the config accordingly.
01-05-2020 03:29 PM
Ok, so I did that, but what do you mean change the routing from FE to the new port?
01-06-2020 12:56 AM
since OLD connection connected to FE port, now you moved to Gig Port, so make necessary changes if required to go to internet using new port i mean.
01-06-2020 01:39 AM
Hello
If you want to swap the port around well that can be done but you need to change any routing (dynamic/static) any nat configuration pointing to the old interface to the new interface, plus keep in mind your going from a 100mb fastethernet to gigabitethernet so the otherside of the connection needs to be able to support gigabit otherwise you will have to hardcode the gigabit interface down to a lower speed
Example
conf t
default interface gig0/2
default inerface fa0/0/0
no ip nat inside source list 1 interface FastEthernet0/0/0 overload
no ip route 0.0.0.0 0.0.0.0 FastEthernet0/0/0 dhcp
interface GigabitEthernet0/2
description INTERNET
ip address dhcp
ip access-group MY-WAN in
ip nat outside
interface FastEthernet0/0/0
ip address dhcp
ip access-group ISP in
ip nat outside
ip nat inside source list 1 interface GigabitEthernet0/2 overload
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0/0 dhcp
01-06-2020 01:54 PM
Unfortunatelly that didn't work, as soon as I copied and pasted that configuration and switched the cable over from FE to GI0/2, I lost complete internet connectivity.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide