cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

7400
Views
0
Helpful
4
Replies
Highlighted
Beginner

Configuring Cisco 800 In Bridge mode

Hello Dears , trying to configure Cisco

In the LAN side configured one Interface VLAN and Configure IP address on that and add the AP’s to the VLAN ..

and on the WAN ADSL its p2p with Qtel bridge mode ..

from the Access Point I am able to reach 172.31.30.30 which is the router far interface .

BUT still not able to reach the ISP side 172.31.30.29 .

Router Config

no ip routing

bridge irb

bridge 1 protocol ieee

bridge 1 route ip

interface ATM0

no ip address

no ip route-cache

no atm ilmi-keepalive

pvc 8/35

  encapsulation aal5snap

!

dsl operating-mode auto

bridge-group 1

interface BVI 1

ip address 172.31.30.30 255.255.255.252

interface Vlan1

ip address 172.31.28.113 255.255.255.240

no ip route-cache

interface FastEthernet0

description ### CONNECTED TO THE ACCESS POINT ###

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

ip route 0.0.0.0 0.0.0.0 172.31.30.29

Cisco800#ping 172.31.30.29 source vlan 1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.31.30.29, timeout is 2 seconds:

Packet sent with a source address of 172.31.28.113

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 32/36/48 ms

But from the Access Point am not able to reach it , any suggestions ??

thanks

4 REPLIES 4
Beginner

Configuring Cisco 800 In Bridge mode

Hello there,

not sure why you would be configuring this router as a bridge and not as a router.

You are trying to route IP between 2 different network with a bridge.

Remove

no ip routing

bridge irb

bridge 1 protocol ieee

bridge 1 route ip

!

interface BVI 1

ip address 172.31.30.30 255.255.255.252

and

bridge-group 1

from the ATM interface

add

ip address 172.31.30.30 255.255.255.252

under the ATM interface and then ping happily (provided that your ISP has a route for your 172.31.30.28/28 pointing to 172.31.30.30.

Cheers

Fabio

Beginner

Configuring Cisco 800 In Bridge mode

Hello Fabio ,

thanks for your reply

If I remove 

bridge-group 1

from under the ATM interface I will not be able to ping the service provider side anymore

I think from that they configured something so that I have to use bridge ...

But I will try it again tomorrow , and I will try to put the ip rouring back again , and let you know

Beginner

Configuring Cisco 800 In Bridge mode

Hello there,

if you just remove the bridge group command it is not supposed to work because the IP address is only on the BVI interface you need to add the IP address in the ATM too and issue the ip routing command to remove the no ip routing.

.

The bridging in IOS bridges 2 (or more) interfaces in the same bridge group. You only have one. Then since you have configured IRB a BVI interface is created (its number is the same of the bridge group) and it is used to assign an IP address to the bridge group. You have then disabled IP routing with the no ip routing command.

So the router does not bridge because has only one interface in the bridge group and it does not route because has no ip routing in the config.

The reason why it pings with:

Cisco800#ping 172.31.30.29 source vlan 1

is because is using VLAN1 IP address but sending the pings through BVI1.

When it gets packets from VLAN1 not being able to route to BVI1, gives no alternative to router but to drop the packet.

Cheers

Fabio

Beginner

Re: Configuring Cisco 800 In Bridge mode

Hello Gents,

I am not sure if the suggested changes made any difference but if the issue is persistent, you can try IRB configuration for it is a requisite for some providers. Here I include a sample configuration:

bridge irb            

!

interface Ethernet0

no shut

ip address

no ip directed-broadcast

!

interface ATM0

no shut

no ip address

no ip directed-broadcast

no atm ilmi-keepalive

bundle-enable

!

interface ATM0.1 point-to-point

no ip directed-broadcast

pvc

encapsulation aal5snap

!

bridge-group 1        

!

interface BVI1        

mac-address <“address” from line2 of “sh int bvi1”>

ip address

no ip directed-broadcast

!

ip route 0.0.0.0 0.0.0.0

!

bridge 1 protocol ieee

bridge 1 route ip    

---------------------------

As you can see, we have an ATM subinterface, which is highly recommended. On the other hand, it is also a good idea to add the MAC under the BVI configuration:

Cisco877(config)#do sho int bvi1

BVI1 is down, line protocol is down

  Hardware is BVI, address is 0016.4627.6c5c (bia 0016.4627.6c5c)

  Internet address is 10.201.7.254/24

******* It is also important to highlight that "ip routing" must be part of the configuration.********

I hope it helps.

Regards.

CreatePlease to create content
Content for Community-Ad
FusionCharts will render here