cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1119
Views
2
Helpful
10
Replies

Confusion with "redistributed in" and "advertised by" in show ip route

NetworkingGeek1
Level 1
Level 1

Hello community,

I need help with understanding of what "redistributed in" and "advertised by" really means in "show ip route" output. Originally, I thought that "redistributed in" means that this particular route exist in particular routing protocols, whether this route was redistributed from another routing protocol, was injected with network command or just routes which were received from another router and "advertised by" means that this route is being advertised to the neighbor from particular routing protocol. But seems that my original assumption is not correct, at least for "advertised by". I made some lab with 4 Routers, diagram is attached.

R1 has only EIGRP. There is Lo 0 with ip address: 55.55.55.55 /24. First of all, output of show ip route 55.55.55.55 depends whether route was injected with redistribute command or network command. Example if I used redistribute command:
R1#show ip int br lo0
Interface IP-Address OK? Method Status Protocol
Loopback0 55.55.55.55 YES NVRAM up up
R1#sh running-config | section eigrp
router eigrp 1
network 192.168.1.0
redistribute connected

R1#show ip route 55.55.55.0
Routing entry for 55.55.55.0/24
Known via "connected", distance 0, metric 0 (connected, via interface)
Redistributing via eigrp 1
Advertised by eigrp 1
Routing Descriptor Blocks:
* directly connected, via Loopback0
Route metric is 0, traffic share count is 1
R1#

Example if I used network command:

R1#sh running-config | section eigrp
router eigrp 1
network 55.55.55.0 0.0.0.255
network 192.168.1.0
R1#
R1#show ip route 55.55.55.0
Routing entry for 55.55.55.0/24
Known via "connected", distance 0, metric 0 (connected, via interface)
Redistributing via eigrp 1
Routing Descriptor Blocks:
* directly connected, via Loopback0
Route metric is 0, traffic share count is 1
R1#

As you can see, "Advertised by" appears only if I use redistribute static command under EIGRP.

Now let's check how this route appears on R2 which has EIGRP and OSPF running. R2 has EIGRP adjacency with R1 and R3 and OSPF adjacency with R4. 

R2#show ip route 55.55.55.0
Routing entry for 55.55.55.0/24
Known via "eigrp 1", distance 90, metric 130816, type internal
Redistributing via eigrp 1
Last update from 192.168.1.1 on GigabitEthernet0/0, 00:04:03 ago
Routing Descriptor Blocks:
* 192.168.1.1, from 192.168.1.1, 00:04:03 ago, via GigabitEthernet0/0
Route metric is 130816, traffic share count is 1
Total delay is 5010 microseconds, minimum bandwidth is 1000000 Kbit
Reliability 255/255, minimum MTU 1500 bytes
Loading 1/255, Hops 1

There is route 55.55.55.0/24 in R2, but it has only "Redistributing via" and it doesn't have "Advertised by". But if check R3, it's receiving 55.55.55.0/24 from R2:


R3#show ip route 55.55.55.0
Routing entry for 55.55.55.0/24
Known via "eigrp 1", distance 90, metric 131072, type internal
Redistributing via eigrp 1
Last update from 192.168.1.5 on GigabitEthernet0/1, 00:00:47 ago
Routing Descriptor Blocks:
* 192.168.1.5, from 192.168.1.5, 00:00:47 ago, via GigabitEthernet0/1
Route metric is 131072, traffic share count is 1
Total delay is 5020 microseconds, minimum bandwidth is 1000000 Kbit
Reliability 255/255, minimum MTU 1500 bytes
Loading 1/255, Hops 2
R3#

Let's now redistribute 55.55.55.0/24 from EIGRP to OSPF on R2:

R2#sh running-config | section ospf
router ospf 1
redistribute eigrp 1 subnets
network 192.168.1.8 0.0.0.3 area 0
R2#

And check ip route again:

R2#show ip route 55.55.55.0
Routing entry for 55.55.55.0/24
Known via "eigrp 1", distance 90, metric 130816, type internal
Redistributing via eigrp 1, ospf 1
Advertised by ospf 1 subnets
Last update from 192.168.1.1 on GigabitEthernet0/0, 00:18:15 ago
Routing Descriptor Blocks:
* 192.168.1.1, from 192.168.1.1, 00:18:15 ago, via GigabitEthernet0/0
Route metric is 130816, traffic share count is 1
Total delay is 5010 microseconds, minimum bandwidth is 1000000 Kbit
Reliability 255/255, minimum MTU 1500 bytes
Loading 1/255, Hops 1
R2#

And now we that "Advertised by" appeared in the output. We see that "Redistributing via eigrp 1, ospf 1" and "Advertised by ospf 1 subnets". So, it looks like "Advertised by" appears in "show ip route" output, only if route was redistributed to some protocol. So, the naming "Advertised by" is very confusing.

Can someone please explain what "Redistributed in" and "Advertised by" really means in "show ip route" output?

 

NetworkingGeek1_0-1694177803131.png

 

10 Replies 10

M02@rt37
VIP
VIP

Hello @NetworkingGeek1,

Advertised by indicates which routing protocol or source is responsible for advertising the route to neighboring routers. It specifies which protocol is actively propagating or advertising the route to the network. It is typically used in the context of routes that are actively being advertised to other routers via a routing protocol. It shows which routing protocol or source is responsible for disseminating information about that route to other devices in the network.

Redistributed in or Redistributing via helps you understand the path the route took to enter the current routing protocol's routing table. It's often used when routes are redistributed between different routing protocols (e.g., redistributing from EIGRP into OSPF).

 

Best regards
.ı|ı.ı|ı. If This Helps, Please Rate .ı|ı.ı|ı.

Hello M02@rt37  Please check "show ip route" from R2 and you'll see that there is no "Advertised by" even though it sends route to R3 via EIGRP, "Advertised by" appears on R2 only when I redistribute EIGRP routes in to OSPF process and only then it says "Advertised by OSPF" and why it doesn't tell that it also advertises it via EIGRP?

@NetworkingGeek1

"show ip route" output can be a bit confusing in this context. In the "show ip route" output, the "Advertised by" field typically indicates which routing protocol or source is responsible for advertising the route to neighboring routers. However, it's important to note that not all routes will have an "Advertised by" field, and it's not always shown for every protocol that might be redistributing or advertising the route.

In your specific scenario:

--R2 with EIGRP and OSPF ::  When you redistribute a route from EIGRP into OSPF on R2, it explicitly mentions "Advertised by OSPF." This indicates that R2 is actively advertising this route into the OSPF routing domain.

--R2 without explicit redistribution :: When R2 has the route in its EIGRP routing table but doesn't perform explicit redistribution into OSPF, the "show ip route" output might not display an "Advertised by" field. This doesn't mean that R2 is not advertising the route via EIGRP; it simply means that the output doesn't specify it.

The absence of Advertised by in the output in the latter case might be a design choice in Cisco IOS to avoid redundancy, as the route is already known to be part of the EIGRP routing domain (??!!!) .

In practice, you can assume that if R2 has a route in its routing table and it's running EIGRP, it will advertise that route to its EIGRP neighbors by default. The absence of an explicit "Advertised by" field doesn't necessarily mean the route isn't being advertised; it's just not shown in the output.

 

Best regards
.ı|ı.ı|ı. If This Helps, Please Rate .ı|ı.ı|ı.

Hello,

 

In all likelyhood its just terminology being used to distinguish different ways a route can be seen in the routing table when it comes from a protocol. I did a test and redistributed connected but I limited it by a route-map and the results are below. Speaking of terminology if I ever find the person who named all the OSPF stub areas I'd like to tell them they are not very nice. 

I redistributed the 11.11.11.11/32 network with a route-map referencing a prefix list:

DavidRuess_0-1694186034779.png

 

When you redistribute a route into a routing protocol there is an "assumed" loss of path information so it just defaults to saying "advertised by" as a it could have come from somewhere else but I'm advertising it so use me to get to it kinda logic. I do agree Redistributing via EIGRP 1 is probably a bit poorer terminology when you're only using a network command and not actually "Redistributing". If I had to guess the "Redistributing by" term is for just advertising  the network as is and "Advertised by" is a Redistribution mechanism as I mentioned earlier.

 

Hope that clears up the mud for you a bit

-David

Hello @David Ruess  Thank you for the reply. Honestly, I'm still not clear what "Redistributing via" and especially what "Advertised by" means. Why "Advertised by" appears only when route is redistributed, not injected via network command?

As I mentioned before the loss of path information when you redistribute means that for all purposes from here going forward I am the one advertising the route to my peers. Because the peers may not know what's behind the router so it says if you want to get to that route you come through me. It just boils down to the terminology that the implementers of the code decided to use as that distinction. Heres another example:

DavidRuess_0-1694208582124.png

Route 2.2.2.2 is redistributed. So its "Advertised by" and Route 7.7.7.7 is using the OSPFc3 interface command. It just that's what the distinction is in the code for the IOS.

Its like asking why is the sky called the sky. Because someone or a group of people decided that's what it will be called and implemented it.

-David

@David Ruess  Thanks. So, I if understand correctly, "Advertised by" is just naming convention (probably not the best one) which was chosen by code writers to say that this route was redistributed from one protocol to another? 

I checked the same scenario with BGP and with BGP it's different which makes me even more confused. I configured iBGP adjacency between R2 & R5 and first I added network 55.55.55.0 mask 255.255.255.0 under bgp one R2:
R2#sh running-config | sec bgp
router bgp 65001
bgp log-neighbor-changes
network 55.55.55.0 mask 255.255.255.0
neighbor 192.168.1.14 remote-as 65001

R2#sh ip route 55.55.55.0
Routing entry for 55.55.55.0/24
Known via "eigrp 1", distance 170, metric 130816, type external
Redistributing via eigrp 1
Advertised by bgp 65001
Last update from 192.168.1.1 on GigabitEthernet0/0, 00:06:53 ago
Routing Descriptor Blocks:
* 192.168.1.1, from 192.168.1.1, 00:06:53 ago, via GigabitEthernet0/0
Route metric is 130816, traffic share count is 1
Total delay is 5010 microseconds, minimum bandwidth is 1000000 Kbit
Reliability 255/255, minimum MTU 1500 bytes
Loading 1/255, Hops 1
R2#

So, in this case, it doesn't indicate "Redistributing via" BGP, it only says "Advertised by bgp 65001".

Then I removed network statement and did EIGRP redistribute under BGP:

R2#sh running-config | sec bgp
router bgp 65001
bgp log-neighbor-changes
redistribute eigrp 1
neighbor 192.168.1.14 remote-as 65001
R2#

R2#show ip route 55.55.55.0
Routing entry for 55.55.55.0/24
Known via "eigrp 1", distance 170, metric 130816, type external
Redistributing via eigrp 1, bgp 65001
Advertised by bgp 65001
Last update from 192.168.1.1 on GigabitEthernet0/0, 00:11:17 ago
Routing Descriptor Blocks:
* 192.168.1.1, from 192.168.1.1, 00:11:17 ago, via GigabitEthernet0/0
Route metric is 130816, traffic share count is 1
Total delay is 5010 microseconds, minimum bandwidth is 1000000 Kbit
Reliability 255/255, minimum MTU 1500 bytes
Loading 1/255, Hops 1
R2#

In this case it indicates both "Redistributing via bgp 65001" and "Advertised by bgp 65001".

So, it looks like BGP uses: "Redistributing via" and "Advertised by" differently than OSPF & EIGRP.

So after getting some insight it appears I was wrong as well. I mean there could be better wording choice but that's just my opinion. But it appears to have more to do with the protocol and the routing table than it does with protocol to protocol in terms of redistributing in that sense. Unfortunately since I recently became aware of the workings I cant describe in detail how it works or what it means fully. I would also have to do some more research to figure it out and explain it better as well.

-David

  

Hello @NetworkingGeek1 ,

you have focused in your tests on the fields   "redistributed via" and "Advertised by ".

Your tests have shown that the behaviour depends on the protocols involved so nothing general can be said about these two fields. For IGPs it looks like that "Advertised by" is used on the node that performs redistribution into the IGP, "redistributed via" can be read as propagated into. But your tests on BGP show a different behaviour.

From a practical point of view the most important info in the show ip route <prefix>  are the presence of the prefix in the routing table and from what protocol is learned.

For each protocol like OSPF for example or BGP you have specific show commands to verify if the prefix is propagated to other neighbors  ( show ip ospf database  and show ip bgp neigh x.x.x.x advertise-routes for BGP).

As noted by @David Ruess the fields are used to provide some information using some convention but developers know people will not use this info in a definitive way ( the network admin can use other commands to check if a prefix is propagated in a routing protocol domain)

Hope to help

Giuseppe

Martin L
VIP
VIP

EIGRP is not good example to study meaning of "Redistributing" and "advertised by" in "show ip route" output. First, EIGRP is (or was) Cisco propitiatory protocol, which means they can do whatever they want; Second, show ip route table will show you "Redistributing via eigrp xyz" even if you do not have any Redistribution for this network anywhere. Here, " Known via " is better representation what's going on.  Lastly, very long time ago, I think, Cisco had redistributed routes automatically between either IGRP to EIGRP or between AS(s) numbers - I don't remember which one for sure but that would explain the reason for this Redistributing mess.  (still searching for old book with IGRP as routing protocol) 

Following output shows R4 loopback route as Redistributing via eigrp 100  in R5 RIB despite the fact that R4 does not do any Redistributing via any protocol. R4 and R5 are directly connected. 

R5#sh ip ro 150.1.4.4
Routing entry for 150.1.4.4/32
Known via "eigrp 100", distance 90, metric 409600, type internal
Redistributing via eigrp 100
Last update from 155.1.45.4 on Ethernet0/1.45, 00:03:24 ago
Routing Descriptor Blocks:
* 155.1.45.4, from 155.1.45.4, 00:03:24 ago, via Ethernet0/1.45
Route metric is 409600, traffic share count is 1
Total delay is 6000 microseconds, minimum bandwidth is 10000 Kbit
Reliability 255/255, minimum MTU 1500 bytes
Loading 1/255, Hops 1

Regards, ML
**Please Rate All Helpful Responses **

Review Cisco Networking for a $25 gift card