cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
547
Views
0
Helpful
1
Replies

Default Route redistribution using EIGRP-BGP and VRFs

spencercook
Level 1
Level 1

Hi all.

I'm trying to get a default route published from one side of our network to another.  We have a single EIGRP AS across two geographical areas.  This is joined in the middle by a new device (installed by an outside consultancy, which I've now inherited, and entirely out of my hands other than to fix what doesn't work.)

I've made a mock up in GNS 3 with the details below, but what I'm trying to achieve is for the two "local" side default routes to be published into the "remote" side with high costs for backup/failover.  Once I know this is working, I can fail-over test with our ISP at our gateways.

Note, this mock up doesn't reflect our full organisational ring with multiple VRF's, there's just enough to replicate the center join and re-distribution point with the gateways.

Location 1 - UHND - VRF NORTH

Location 2 - DMH - VRF SOUTH

I can get all the LAN routes to publish and traffic works fine with all devices working (real world and GNS3).  However the one thing I don't seem to be able to get is the default route to publish between UHND and DMH using north/south VRF's.

Here is the layout, with the VSS config's and routing tables.

I can't help thinking I'm overlooking something simple.  

Any help much appreciated.

UHND-VSS#sh run
Building configuration...

Current configuration : 1390 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname UHND-VSS
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
no network-clock-participate slot 1
no network-clock-participate wic 0
no ip icmp rate-limit unreachable
ip cef
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
ip tcp synwait-time 5
!
interface FastEthernet0/0
description DMH-VSS
bandwidth 50000
ip address 192.168.0.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
description CDDFT LAN
bandwidth 100000
ip address 10.97.144.67 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 192.168.192.1 255.255.255.252
duplex auto
speed auto
!
router eigrp 1
network 10.97.144.0 0.0.0.255
network 192.168.0.0 0.0.0.3
network 192.168.192.0 0.0.0.3
no auto-summary
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
route-map DEFAULT-TO-SOUTH permit 10
match ip address prefix-list DEFAULT
set metric 777777
!
control-plane
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end

UHND-VSS#
UHND-VSS#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is 10.97.144.5 to network 0.0.0.0

192.168.192.0/30 is subnetted, 2 subnets
C 192.168.192.0 is directly connected, FastEthernet1/0
D EX 192.168.192.4
[170/1711616] via 192.168.192.2, 00:43:18, FastEthernet1/0
192.168.193.0/30 is subnetted, 2 subnets
D 192.168.193.0 [90/286720] via 192.168.0.2, 00:43:17, FastEthernet0/0
D EX 192.168.193.4 [170/1739776] via 192.168.0.2, 00:43:17, FastEthernet0/0
10.0.0.0/24 is subnetted, 4 subnets
D 10.97.176.0 [90/286720] via 192.168.0.2, 00:43:17, FastEthernet0/0
D EX 10.117.134.0 [170/1739776] via 192.168.0.2, 00:43:18, FastEthernet0/0
D EX 10.117.133.0
[170/1711616] via 192.168.192.2, 00:43:19, FastEthernet1/0
C 10.97.144.0 is directly connected, FastEthernet0/1
192.168.0.0/30 is subnetted, 2 subnets
C 192.168.0.0 is directly connected, FastEthernet0/0
D 192.168.0.4 [90/284160] via 192.168.0.2, 00:43:20, FastEthernet0/0
D*EX 0.0.0.0/0 [170/261120] via 10.97.144.5, 00:43:21, FastEthernet0/1

DMH-VSS#sh run
Building configuration...

Current configuration : 1417 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname DMH-VSS
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
no network-clock-participate slot 1
no network-clock-participate wic 0
no ip icmp rate-limit unreachable
ip cef
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
ip tcp synwait-time 5
!
interface FastEthernet0/0
description UHND-VSS
bandwidth 1000
ip address 192.168.0.5 255.255.255.252
delay 2000
duplex auto
speed auto
!
interface FastEthernet0/1
description CDDFT LAN
bandwidth 100000
ip address 10.97.176.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
description LAN
ip address 192.168.193.1 255.255.255.252
duplex auto
speed auto
!
router eigrp 1
network 10.97.176.0 0.0.0.255
network 192.168.0.4 0.0.0.3
network 192.168.193.0 0.0.0.3
no auto-summary
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
route-map DEFAULT-TO-NORTH permit 10
match ip address prefix-list DEFAULT
set metric 777777
!
!
!
control-plane
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end

DMH-VSS#
DMH-VSS#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is 10.97.176.5 to network 0.0.0.0

192.168.192.0/30 is subnetted, 2 subnets
D 192.168.192.0 [90/3100160] via 192.168.0.6, 00:44:47, FastEthernet0/0
D EX 192.168.192.4 [170/3102720] via 192.168.0.6, 00:44:47, FastEthernet0/0
192.168.193.0/30 is subnetted, 2 subnets
C 192.168.193.0 is directly connected, FastEthernet1/0
D EX 192.168.193.4
[170/1711616] via 192.168.193.2, 00:44:47, FastEthernet1/0
10.0.0.0/24 is subnetted, 4 subnets
C 10.97.176.0 is directly connected, FastEthernet0/1
D EX 10.117.134.0
[170/1711616] via 192.168.193.2, 00:44:49, FastEthernet1/0
D EX 10.117.133.0 [170/3102720] via 192.168.0.6, 00:44:48, FastEthernet0/0
D 10.97.144.0 [90/3100160] via 192.168.0.6, 00:44:48, FastEthernet0/0
192.168.0.0/30 is subnetted, 2 subnets
D 192.168.0.0 [90/3097600] via 192.168.0.6, 00:44:48, FastEthernet0/0
C 192.168.0.4 is directly connected, FastEthernet0/0
D*EX 0.0.0.0/0 [170/261120] via 10.97.176.5, 00:30:29, FastEthernet0/1

TF-VSS#sh run
Building configuration...

Current configuration : 2747 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname TF-VSS
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
ip vrf LINK
!
ip vrf NORTH
rd 5:1
route-target export 5:1
route-target import 5:2
!
ip vrf SOUTH
rd 5:2
route-target export 5:2
route-target import 5:1
!
no ip domain lookup
!
multilink bundle-name authenticated
!

archive
log config
hidekeys
!

ip tcp synwait-time 5
!

interface FastEthernet0/0
ip vrf forwarding NORTH
ip address 192.168.0.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
ip vrf forwarding SOUTH
ip address 192.168.0.6 255.255.255.252
duplex auto
speed auto
!
router eigrp 1
auto-summary
!
address-family ipv4 vrf SOUTH
redistribute bgp 5 metric 1500 10 255 1 1500
network 192.168.0.6 0.0.0.0
no auto-summary
autonomous-system 1
exit-address-family
!
address-family ipv4 vrf NORTH
redistribute bgp 5 metric 1500 10 255 1 1500
network 192.168.0.2 0.0.0.0
no auto-summary
autonomous-system 1
exit-address-family
!
router bgp 5
no synchronization
bgp log-neighbor-changes
no auto-summary
!
address-family ipv4 vrf SOUTH
redistribute connected
redistribute eigrp 1 metric 300 route-map NORTH-EIGRP-BGP
default-information originate
synchronization
bgp redistribute-internal
exit-address-family
!
address-family ipv4 vrf NORTH
redistribute connected
redistribute eigrp 1 metric 300 route-map SOUTH-EIGRP-BGP
default-information originate
synchronization
bgp redistribute-internal
exit-address-family
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
ip prefix-list DEFAULT seq 5 permit 0.0.0.0/0
!
ip prefix-list NORTH-EIGRP-BGP seq 10 permit 0.0.0.0/0 le 32
!
ip prefix-list SOUTH-EIGRP-BGP seq 10 permit 0.0.0.0/0 le 32
no cdp log mismatch duplex
!

route-map SOUTH-EIGRP-BGP permit 10
match ip address prefix-list DEFAULT
set metric 5000 1000000 255 150 1500
!
route-map SOUTH-EIGRP-BGP permit 20
match ip address prefix-list SOUTH-EIGRP-BGP
set metric 1000000 10 155 1 1500
!
route-map SOUTH-EIGRP-BGP deny 100
!
route-map NORTH-EIGRP-BGP permit 10
match ip address prefix-list DEFAULT
set metric 5000 1000000 255 150 1500
!
route-map NORTH-EIGRP-BGP permit 20
match ip address prefix-list NORTH-EIGRP-BGP
set metric 1000000 10 155 1 1500
!
route-map NORTH-EIGRP-BGP deny 100
!

control-plane
!

line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end

TF-VSS#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

TF-VSS#sh ip route vrf NORTH

Routing Table: NORTH
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.0.1 to network 0.0.0.0

192.168.192.0/30 is subnetted, 2 subnets
D 192.168.192.0 [90/284160] via 192.168.0.1, 00:46:24, FastEthernet0/0
D EX 192.168.192.4 [170/1737216] via 192.168.0.1, 00:46:24, FastEthernet0/0
192.168.193.0/30 is subnetted, 2 subnets
B 192.168.193.0
[20/284160] via 192.168.0.5 (SOUTH), 01:08:03, FastEthernet0/1
B 192.168.193.4
[20/1737216] via 192.168.0.5 (SOUTH), 01:08:03, FastEthernet0/1
10.0.0.0/24 is subnetted, 4 subnets
B 10.97.176.0
[20/284160] via 192.168.0.5 (SOUTH), 01:08:04, FastEthernet0/1
B 10.117.134.0
[20/1737216] via 192.168.0.5 (SOUTH), 01:08:05, FastEthernet0/1
D EX 10.117.133.0 [170/1737216] via 192.168.0.1, 00:46:26, FastEthernet0/0
D 10.97.144.0 [90/284160] via 192.168.0.1, 00:46:26, FastEthernet0/0
192.168.0.0/30 is subnetted, 2 subnets
C 192.168.0.0 is directly connected, FastEthernet0/0
B 192.168.0.4 is directly connected, 01:24:20, FastEthernet0/1
D*EX 0.0.0.0/0 [170/286720] via 192.168.0.1, 00:46:26, FastEthernet0/0
TF-VSS#sh ip route vrf SOUTH

Routing Table: SOUTH
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.0.5 to network 0.0.0.0

192.168.192.0/30 is subnetted, 2 subnets
B 192.168.192.0
[20/284160] via 192.168.0.1 (NORTH), 01:07:54, FastEthernet0/0
B 192.168.192.4
[20/1737216] via 192.168.0.1 (NORTH), 01:07:39, FastEthernet0/0
192.168.193.0/30 is subnetted, 2 subnets
D 192.168.193.0 [90/284160] via 192.168.0.5, 00:46:41, FastEthernet0/1
D EX 192.168.193.4 [170/1737216] via 192.168.0.5, 00:46:41, FastEthernet0/1
10.0.0.0/24 is subnetted, 4 subnets
D 10.97.176.0 [90/284160] via 192.168.0.5, 00:46:42, FastEthernet0/1
D EX 10.117.134.0 [170/1737216] via 192.168.0.5, 00:46:42, FastEthernet0/1
B 10.117.133.0
[20/1737216] via 192.168.0.1 (NORTH), 01:07:41, FastEthernet0/0
B 10.97.144.0
[20/284160] via 192.168.0.1 (NORTH), 01:07:56, FastEthernet0/0
192.168.0.0/30 is subnetted, 2 subnets
B 192.168.0.0 is directly connected, 01:24:27, FastEthernet0/0
C 192.168.0.4 is directly connected, FastEthernet0/1
D*EX 0.0.0.0/0 [170/286720] via 192.168.0.5, 00:32:25, FastEthernet0/1

1 Reply 1

Hello,

Why does TF-VSS has two legs in two different VRF while you have mixed both VRF routing tables?

Review Cisco Networking for a $25 gift card