cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1213
Views
5
Helpful
5
Replies

Dialout using 877 + External Analogue Modem

AdamPage1
Level 1
Level 1

Hi All,

I'm trying to get a solution together for a dial backup to an ADSL service, using an Analogue modem.

The kit list is as follows:

Cisco 877

Multitech MT5656ZDX External Analogue Modem

or

USR 5630D External Analogue Modem

Rolled patch cable

RJ45 to DB25M adapter (pinout from a cisco guide)

So far I am unable to get the router/modem to dial out at all. I know the modems work, I have tested them from Windows.

I have attached a couple of outputs from "show line" and "show line 1" from the router and also what I think are the relevent lines of config although it will be too much config and probably jumbled by now as I've tried quite a few things to try and get this working.

Can anybody advise on the best type of external modem to use for dialing out and also, any help with the config would be much appreciated.

I am more concerned with the config relating to the connection of the analogue modem than the routing element.

Thanks in advance

5 Replies 5

j-marenda
Level 1
Level 1

Adam,

at least your config must have

!

line con 0

modem enable

!

so the logical line aux 0 is connected to the physical port.

You may try to speak with the modem by " telnet router-ip 2001 "

I strongly recommend USR Courier Modems since you can program them per DIP Jumpers,

so forgetting config-settings in their nvram after some weeks or months powered off

will be no issue.

Some "white" USR Sportsterr Modems had those Jumpers also .

Find attached relevant Parts of the working configuration of a 1720 with real aux port

(line 5 ---> int async 5, telnet ... 2005 )

and USR Courier Modem.

Hope this help's,

Juergen.

Hi Juergen,

Many thanks for your reply.

I have since started using an 887 to make sure of the AUX port functionality, as it transpires the 877 has Console only port, while it seems the 887 has Console+AUX combined port which may make use of config such as yours easier.

Could you advise what it means when the speed in the config constantly changes? when I do a show run, the below line changes itself

sh run....

line aux 0
exec-timeout 0 0
script dialer DIALOUT
modem InOut
modem autoconfigure type MY_USR_MODEM
no exec
transport preferred ssh
transport input all
stopbits 1
speed 300

sh run....

line aux 0
exec-timeout 0 0
script dialer DIALOUT
modem InOut
modem autoconfigure type MY_USR_MODEM
no exec
transport preferred ssh
transport input all
stopbits 1
speed 19200

sh run....

line aux 0
exec-timeout 0 0
script dialer DIALOUT
modem InOut
modem autoconfigure type MY_USR_MODEM
no exec
transport preferred ssh
transport input all
stopbits 1
speed 1200

and it will cycle the various speeds continuously!

Adam,

i am very sure that the 87x CON/AUX may function as AUX port since we

had some devices (hanging firewalls) serial console connected to it, and then telneted to router-ip 2001 .

(876, 878 and , yes, we have a 877 in UK).

line con 0

modem enable

did the trick.

Either the modem autoconfig or the modem are changing speed on the port

to see which one works...

debug confmodem should show you whats going on.

try:"no flush-at-activation" on the line aux 0 .

Juergen.

Hi Juergen,

I'm nearly to the point my dial backup is working, but I cannot quite get it just right, at the moment, the modem dials up as soon as the ADSL goes down, which is not quite what I want. I would like it to dial out only when something wants to talk to the outside world.

The second thing is, I can't get the routing right, if I leave in the route to d0, nothing ends up going down d1

interface Async1
no ip address
ip virtual-reassembly in
encapsulation ppp
no ip route-cache cef
no ip route-cache
dialer in-band
dialer pool-member 3
async mode interactive
no keepalive
!
interface Dialer1
ip address negotiated
ip access-group 101 out
ip nat outside
ip virtual-reassembly in
encapsulation ppp
no ip route-cache cef
no ip route-cache
dialer pool 3
dialer idle-timeout 30
dialer string *********
dialer hold-queue 10
dialer watch-group 3
dialer-group 3
no peer default ip address
ppp chap hostname ********
ppp chap password ********
no cdp enable
!
ip forward-protocol nd
!
ip nat inside source list 101 interface Dialer1 overload
ip route 0.0.0.0 0.0.0.0 Dialer0
ip route 0.0.0.0 0.0.0.0 Dialer1 50
!
logging esm config
access-list 101 permit ip any any log
access-list 105 permit ip 10.1.1.0 0.0.0.15 any
dialer watch-list 3 ip 10.xx.xx.xx 255.255.255.255
dialer-list 1 protocol ip permit
dialer-list 3 protocol ip list 105

Adam,

the problem with dialer 0 is, that it will not go down, so the default route pointing to it will not disappear.

In the ISDN/BRI/Modem case, that is fine, since outgoing traffic gets routed to the interface which is "up (spoofing)" and

triggers (thru the dailer-group/list pair) the dail-out process.

For allways-online xdsl "dial-"connections with "dialer persistent" and "time-flat" charging, this brings those backup problems.

One solution is, iff the remote side never changes and has allways the same IP adress

(on my dail-infrastructure this is true, even over several dial-in devices.

On the backup interface, i have "no peer neighbor route".

You may set the "dsl" default route to the IP of the ISP's router (that is the peer-ip-address for which the router installs noramlly a host route to the dialer interface). During successful login, you see this ip address using "show users" .

For the backup dialer, the default-route may then go to the dialer interface with higher "cost" .

An other solution would be a track monitoring the state of the atm0 interface

an discarding the default route to your dialer0

track 11 interface ATM0 line-protocol

ip route 0.0.0.0 0.0.0.0 dailer0 track 11

The dialer watch is not nessassary if you want to dail the backup-device on demand.

The dialer watch watches the route and calls the backup line when the route disappers.

Discussion of the differnet backup-strategies in

http://www.cisco.com/en/US/tech/tk801/tk133/technologies_tech_note09186a008009457d.shtml

if the route you watch is the host-ip of the remote-side,

you should use this as the next hop fore the normal/dsl default-route and remove the dialer watch commands.

Hope this help's,

Juergen.

here, you have a floating staic route as the default route which gets recursively resolved when the peer neighbor (host)-route

gets installed during PPP negotiation of the main interface.

If dsl goes down, or the ppp data flow stoppes (even when dsl is in sync!) the interface will go down ofter

5 ppp lcp keepalive packets got lost. Default (cisco) is every 10 seconds to send a keepalive,

most xDSL Carrier equipment and home-routers use every 30 seconds.

Tune with

keepalive 1

to every one second, may not work depending on Carrier and ISPside.

After that, the peer neighbor route diappers.

The default route will be dropped when the process checking them runs next,

you may tune that with

ip route static adjust-time 10

to every 10 seconds (works on 87x without too much cpu load).

gate#sh users

...

Interface User Mode  Idle     Peer Address

Vi1            PPPoE 00:00:00 aaa.bbb.ccc.ddd

gate# sh run

! ...

interface Dialer0

description DSL Dialer

dialer pool 1

dialer idle-timeout 0

dialer persistent

dialer-group 1

no cdp enable

!...

!

interface Dialer1

description ISDN/PSTN Dialer Backup

dialer pool 2

dialer-group 2

no peer neighbor-route

no keepalive

no cdp enable

! ...

!

ip route 0.0.0.0 0.0.0.0 aaa.bbb.ccc.ddd

ip route 0.0.0.0 0.0.0.0 dialer1 100

! ...

Review Cisco Networking for a $25 gift card