03-17-2023 06:17 PM
Hi,
I am doing dmvpn I am unable to ping 10.1.1.2 which is spoke from hub
and i cant't see any route in hub routing table on tunnel interface
and i am doing eigrp on overlay
but i am unable to create eigrp adjacency between hub and spoke
this is my config
Hub
conf ter
hostname Hub
int lo 0
ip add 10.10.10.10 255.255.255.255
exit
int gig 0/0
ip add 100.1.2.1 255.255.255.0
no sh
exit
ip route 0.0.0.0 0.0.0.0 100.1.2.2
int tunnel 1
ip add 10.1.1.1 255.255.255.0
tunnel source gig 0/0
tunnel mode gre multipoint
ip nhrp network-id 1
ip nhrp map 10.1.1.2 101.0.0.2
exit
router eigrp 100
network 10.0.0.0
-----------------------------------------------------------------------
R2
int lo 0
ip add 100.0.0.3 255.255.255.255
ip ospf 1 area 0
exit
int gig 0/0
ip add 100.1.2.2 255.255.255.0
no sh
exit
int gig 0/1
ip add 100.0.3.1 255.255.255.0
no sh
ip ospf 1 area 0
exit
router ospf 1
router-id 100.0.0.3
exit
router bgp 1
no bgp default ipv4-unicast
neighbor 100.0.0.4 remote-as 1
neighbor 100.0.0.4 update-source Loopback0
address-family ipv4
network 100.0.3.0 mask 255.255.255.0
network 100.1.2.0 mask 255.255.255.0
neighbor 100.0.0.4 activate
exit
exit
ip route 0.0.0.0 0.0.0.0 100.1.2.1
---------------------------------------------------------------
R4
conf ter
int lo 0
ip add 100.0.0.4 255.255.255.255
ip ospf 1 area 0
exit
int gig 0/0
ip add 100.0.3.2 255.255.255.0
no sh
ip ospf 1 area 0
exit
int gig 0/1
ip add 101.0.0.1 255.255.255.0
no sh
exit
router ospf 1
router-id 100.0.0.4
exit
router bgp 1
no bgp default ipv4-unicast
neighbor 100.0.0.3 remote-as 1
neighbor 100.0.0.3 update-source Loopback0
address-family ipv4
network 100.0.3.0 mask 255.255.255.0
network 101.0.0.0 mask 255.255.255.0
neighbor 100.0.0.3 activate
exit
exit
ip route 101.0.0.0 255.255.255.0 101.0.0.2
-------------------------------------------------------------------------
Spoke1
conf ter
hostname spoke1
int lo0
ip add 25.25.25.25 255.255.255.255
exit
int gig 0/0
ip add 101.0.0.2 255.255.255.0
no sh
exit
ip route 0.0.0.0 0.0.0.0 101.0.0.1
int tunnel 1
ip add 10.1.1.2 255.255.255.0
tunnel source gig 0/0
tunnel destination 100.1.2.1
ip nhrp network-id 1
ip nhrp map 10.1.1.1 100.1.2.1
exit
router eigrp 100
network 10.0.0.0
---------------------------------------------------------------------------------
Solved! Go to Solution.
03-17-2023 08:05 PM
@burhaans28 , looks like you are missing multicast capability config.
Pls configure and add the following on the Hub router and provide results:
int tunnel 1
ip nhrp map multicast 101.0.0.2
03-17-2023 08:49 PM
Hello
Providing your underlay is all working correctly you need to allow nhrp multicast on the nbma address and disable split horizon
hub
int tunnel 1
ip add 10.1.1.1 255.255.255.0
tunnel source gig 0/0
tunnel mode gre multipoint
ip nhrp network-id 1
ip nhrp map 10.1.1.2 101.0.0.2
ip nhrp map multicast 101.0.0.2
no ip split-horizon
03-17-2023 08:57 PM
@paul driver - in his topology, disabling split horizon is optional. But yes, if you have other spokes you want to connect to the DMVPN, you would need to disable split horizon.
03-18-2023 04:50 PM
Yeah Dmvpn is working now Thanks a lot
03-18-2023 04:51 PM
Yeah its working Thanks a lot
03-17-2023 08:05 PM
@burhaans28 , looks like you are missing multicast capability config.
Pls configure and add the following on the Hub router and provide results:
int tunnel 1
ip nhrp map multicast 101.0.0.2
03-17-2023 08:49 PM
Hello
Providing your underlay is all working correctly you need to allow nhrp multicast on the nbma address and disable split horizon
hub
int tunnel 1
ip add 10.1.1.1 255.255.255.0
tunnel source gig 0/0
tunnel mode gre multipoint
ip nhrp network-id 1
ip nhrp map 10.1.1.2 101.0.0.2
ip nhrp map multicast 101.0.0.2
no ip split-horizon
03-18-2023 04:50 PM
Yeah Dmvpn is working now Thanks a lot
03-18-2023 05:15 PM
Hi,
Here DMVPN is working fine i can ping from hub to spoke
But from Hub to Vios I am working ospf 1
this is the config
Vios
int gig 0/0
ip add 10.11.3.1
no sh
ip ospf 1 area 0
On hub router
int gig 0/1
ip add 10.11.3.1
no sh
ip ospf 1 area 0
So i can't ping 10.11.3.1 and lo0 1.1.1.1 from spoke
but i can ping 10.11.3.2 which is on Hub router
03-17-2023 08:57 PM
@paul driver - in his topology, disabling split horizon is optional. But yes, if you have other spokes you want to connect to the DMVPN, you would need to disable split horizon.
03-18-2023 04:51 PM
Yeah its working Thanks a lot
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide