Hi there! I'm currently trying to setup Dynamic DNS for a home server I'm running so I can update multiple subdomains on it. Unfortunatly after trying multiple way of configuring it I get a Bad parameters error when Debugging is enabled. I have a Cisco 3825 connected to a switch I got to help me learn IOS as I'm working to get a CCNA (I found one for a smoking deal!). However for the life of me I just cannot figure this out. When trying to figure it out I've changed the host= to mc, mcadmin, resrise, and <h> without it working thus far.
Debug shows the following:
*Feb 7 07:23:51.231: DYNDNSUPD: Adding DNS mapping for resrise.manate.ch <=> [External IP] server 199.188.202.39
*Feb 7 07:23:51.231: HTTPDNS: Update add called for resrise.manate.ch <=> [External IP]
*Feb 7 07:23:51.231: HTTPDNSUPD: Session ID = 0x2E
*Feb 7 07:23:51.231: HTTPDNSUPD: URL = 'dynamicdns.park-your-domain/update?host=resrise&domain=manate.ch&password=[Password]'
*Feb 7 07:23:51.231: HTTPDNSUPD: Sending request... status='Bad parameters', tid=0
Show Run below:
Rooter3825-HAWSE#sh run
Building configuration...
Current configuration : 2304 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Rooter3825-HAWSE
!
boot-start-marker
boot-end-marker
!
enable secret 5 [Secrets]
enable password [Password]
no aaa new-model
dot11 syslog
no ip dhcp use vrf connected
ip dhcp excluded-address 10.137.0.1
!
ip dhcp pool INTRA
network 10.137.0.0 255.255.0.0
default-router 10.137.0.1
dns-server 8.8.8.8 8.8.4.4
lease 7
!
!
ip cef
!
!
ip domain name manate.ch
ip host-list SERVARS
host 10.137.0.12 mc.manate.ch mcadmin.manate.ch resrise.manate.ch
ip name-server 8.8.8.8
ip name-server 8.8.4.4
ip ddns update method namecheap
HTTP
add dynamicdns.park-your-domain.com/update?host=mc&domain=manate.ch&password=[Password]&ip=<a>
remove dynamicdns.park-your-domain.com/update?host=mc&domain=manate.ch&password=[Password]&ip=<a>
interval maximum 0 0 1 0
interval minimum 0 0 1 0
!
!
multilink bundle-name authenticated
!
!
!
!
!
username [user] password 0 [password]
archive
log config
hidekeys
!
!
!
!
!
!
!
interface GigabitEthernet0/0
description TOISP
ip ddns update hostname resrise.manate.ch
ip ddns update namecheap host dynamicdns.park-your-domain.com
ip address dhcp
ip nat outside
ip nat enable
ip virtual-reassembly
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/1
ip address 10.137.0.1 255.255.0.0
ip nat inside
ip nat enable
ip virtual-reassembly
duplex auto
speed auto
media-type rj45
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0
!
!
no ip http server
no ip http secure-server
ip dns server
ip nat inside source static tcp 10.137.0.12 81 interface GigabitEthernet0/0 81
ip nat inside source static tcp 10.137.0.12 8080 interface GigabitEthernet0/0 8080
ip nat inside source static tcp 10.137.0.12 25566 interface GigabitEthernet0/0 25566
ip nat inside source list INTERNALTOEXTERNAL interface GigabitEthernet0/0 overload
!
ip access-list extended INTERNALTOEXTERNAL
permit ip any any
!
!
!
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
password [Password]
login
transport input ssh
line vty 5 924
password [Password]
login
transport input ssh
!
scheduler allocate 20000 1000
!
end