cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
756
Views
0
Helpful
4
Replies
Highlighted
Beginner

dyndns et NAT

Bonjour

Etant nouveau dans le domaine Cisco , notement dans le CLI, j'ai deux petit problème qui sont peut être lié.

La misea jour de mon DDNS ne se fait pas et la NAT ne fonctionne pas, quelqu'un pourrait peut être m'aider

Voici la config du CISCO881-K9


!
!
!
!
ip dhcp update dns both
no ip bootp server
no ip domain lookup
ip domain name dyndns.org
ip name-server 8.8.8.8
ip ddns update method dyndns
DDNS
!
ip ddns update method wellmess6780_dyndns
HTTP
  add http://MyLogin:MyPassword@members.dyndns.org/nic/updatesystem=dyndns&hostnam              e=<h>&myip=<a>
  remove http://MyLogin:MyPassword@members.dyndns.org/nic/updatesystem=dyndns&host              name=<h>&myip=<a>
interval maximum 0 0 30 0
interval minimum 0 0 30 0
!
ip dhcp-client update dns server both
ip cef
no ipv6 cef
!
!
license udi pid CISCO881-K9 sn FCZ164091N8
!
!
username thierry privilege 15 secret 4 hxs3I1G5/VfWpIztplmqsbnfWy7MCP3fSM9VloHus              9Q
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0
description LAN
no ip address
!
interface FastEthernet1
description LAN
no ip address
!
interface FastEthernet2
description LAN
no ip address
!
interface FastEthernet3
description LAN
no ip address
!
interface FastEthernet4
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface Vlan1
description $FW_INSIDE$
ip address 192.168.16.254 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat inside
ip virtual-reassembly in
ip tcp adjust-mss 1452
!
interface Dialer1
ip ddns update hostname wellmess6780.dyndns.org
ip ddns update wellmess6780_dyndns
ip address negotiated
no ip redirects
no ip unreachables
no ip proxy-arp
ip mtu 1492
ip nat outside
ip virtual-reassembly in
encapsulation ppp
dialer pool 1
dialer idle-timeout 0
dialer persistent
ppp authentication chap pap callin
ppp chap hostname MyLogin@SKYNET
ppp chap password 7 01125F575611505C38
ppp ipcp dns request
no cdp enable
!
ip default-gateway 192.168.16.254
ip forward-protocol nd
no ip http server
ip http port 8088
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip nat inside source static tcp 192.168.16.99 80 interface Dialer1 80
ip nat inside source static tcp 192.168.16.99 21 interface Dialer1 21
ip nat inside source static tcp 192.168.16.99 1433 interface Dialer1 1433
ip nat inside source static tcp 192.168.16.99 3389 interface Dialer1 3389
ip nat inside source static tcp 192.168.16.99 3160 interface Dialer1 3160
ip nat inside source list 100 interface Dialer1 overload
ip route 0.0.0.0 0.0.0.0 FastEthernet4
ip route 0.0.0.0 0.0.0.0 Dialer1
!
access-list 100 permit ip 192.168.16.0 0.0.0.255 any
access-list 100 permit ip any any
no cdp run
!
!
!
line con 0
login local
line aux 0
line vty 0 4
access-class 23 in
privilege level 15
login local
transport input telnet ssh
!
!
end

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Advisor

Hi,

no ip route 0.0.0.0 0.0.0.0 FastEthernet4

no access-list 100 permit ip any any

Regards.

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.

View solution in original post

4 REPLIES 4
Highlighted
Advisor

Hi,

no ip route 0.0.0.0 0.0.0.0 FastEthernet4

no access-list 100 permit ip any any

Regards.

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.

View solution in original post

Highlighted

many thank for you help

And for Dyndns your have on suggestion, or it's godd configuration, because I dont have update of my dyndns

Regard

Thierry

Highlighted

Hi,

look here:https://supportforums.cisco.com/thread/2104560

Regards.

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
Highlighted

Hi

This configuration is in place , may dont work correctly with the NAT

I test with "telnet wellmess6780.dyndns.org 1433"

no response

anywhere see why?

ip default-gateway 192.168.16.254

ip forward-protocol nd

no ip http server

ip http port 8088

ip http access-class 23

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

ip nat inside source static tcp 192.168.16.99 80 interface Dialer1 80

ip nat inside source static tcp 192.168.16.99 21 interface Dialer1 21

ip nat inside source static tcp 192.168.16.99 1433 interface Dialer1 1433

ip nat inside source static tcp 192.168.16.99 3389 interface Dialer1 3389

ip nat inside source static tcp 192.168.16.99 3160 interface Dialer1 3160

ip nat inside source list 1 interface Dialer1 overload

ip route 0.0.0.0 0.0.0.0 Dialer1

!

access-list 1 permit 192.168.16.0 0.0.0.255

no cdp run

!

!

!

line con 0

login local

line aux 0

line vty 0 4

access-class 23 in

privilege level 15

login local

transport input telnet ssh