01-20-2023 08:06 PM - edited 01-20-2023 08:26 PM
Hi there are three routers linked together like this: R1---R2---R3. R1 and R3 can ping each other through R2. There is basic ebgp config on R1 and R3 for ebgp connection between R1 and R3. No bgp config is allowed on R2. Now we want to setup ebgp neighbor connection between R1 and 3. What else config is needed for this purpose? Thank you
Solved! Go to Solution.
01-20-2023 08:53 PM
This is homework, isn't it?
If you have a basic BGP config on R1 and R3 (whatever this is), start bei debugging the BGP communication and see if there is any hint in the debug.
01-20-2023
11:09 PM
- last edited on
01-22-2023
09:34 PM
by
Translator
Hello
Best practice would be to peer to a lookback interface of both rtrs.
So if you have
static/ igp
connection ( between rtr 1/3 for their respective loopbacks then the following example should work for you,
Note: Do not use default routes on each rtr for reachability otherwise the bgp peers will not come up.
.example
R1
ip route 2.2.2.2 255.255.255.255 x.x.x.x
router bgp 1
neighbor 2.2.2.2 remote-as 2
neighbor 2.2.2.2 ebgp-multihop 3
neighbor 2.2.2.2 update-source loopback 0
R2
ip route 1.1.1.1 255.255.255.255 x.x.x.x
router bgp 2
neighbor 1.1.1.1 remote-as 1
neighbor 1.1.1.1 ebgp-multihop 3
neighbor 1.1.1.1 update-source loopback 0
01-21-2023
12:36 AM
- last edited on
01-22-2023
09:32 PM
by
Translator
Hello,
if this is just for practicing, you can also configure a tunnel between R1 and R3. The configs would look like below:
R1
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Tunnel0
ip address 172.16.1.1 255.255.255.0
mtu 1476
tunnel source GigabitEthernet0/0/0
tunnel destination 192.168.23.3
!
interface GigabitEthernet0/0/0
ip address 192.168.12.1 255.255.255.0
duplex auto
speed auto
!
router eigrp 1
network 0.0.0.0
!
router bgp 1
bgp log-neighbor-changes
no synchronization
neighbor 172.16.1.2 remote-as 2
network 1.1.1.1 mask 255.255.255.255
R2
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface GigabitEthernet0/0/0
ip address 192.168.12.2 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/0/1
ip address 192.168.23.2 255.255.255.0
duplex auto
speed auto
!
router eigrp 1
network 0.0.0.0
R3
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface Tunnel0
ip address 172.16.1.2 255.255.255.0
mtu 1476
tunnel source GigabitEthernet0/0/0
tunnel destination 192.168.12.1
!
interface GigabitEthernet0/0/0
ip address 192.168.23.3 255.255.255.0
duplex auto
speed auto
!
router eigrp 1
network 0.0.0.0
!
router bgp 2
bgp log-neighbor-changes
no synchronization
neighbor 172.16.1.1 remote-as 1
network 3.3.3.3 mask 255.255.255.255
01-20-2023 08:53 PM
This is homework, isn't it?
If you have a basic BGP config on R1 and R3 (whatever this is), start bei debugging the BGP communication and see if there is any hint in the debug.
01-20-2023
11:09 PM
- last edited on
01-22-2023
09:34 PM
by
Translator
Hello
Best practice would be to peer to a lookback interface of both rtrs.
So if you have
static/ igp
connection ( between rtr 1/3 for their respective loopbacks then the following example should work for you,
Note: Do not use default routes on each rtr for reachability otherwise the bgp peers will not come up.
.example
R1
ip route 2.2.2.2 255.255.255.255 x.x.x.x
router bgp 1
neighbor 2.2.2.2 remote-as 2
neighbor 2.2.2.2 ebgp-multihop 3
neighbor 2.2.2.2 update-source loopback 0
R2
ip route 1.1.1.1 255.255.255.255 x.x.x.x
router bgp 2
neighbor 1.1.1.1 remote-as 1
neighbor 1.1.1.1 ebgp-multihop 3
neighbor 1.1.1.1 update-source loopback 0
01-21-2023
12:36 AM
- last edited on
01-22-2023
09:32 PM
by
Translator
Hello,
if this is just for practicing, you can also configure a tunnel between R1 and R3. The configs would look like below:
R1
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Tunnel0
ip address 172.16.1.1 255.255.255.0
mtu 1476
tunnel source GigabitEthernet0/0/0
tunnel destination 192.168.23.3
!
interface GigabitEthernet0/0/0
ip address 192.168.12.1 255.255.255.0
duplex auto
speed auto
!
router eigrp 1
network 0.0.0.0
!
router bgp 1
bgp log-neighbor-changes
no synchronization
neighbor 172.16.1.2 remote-as 2
network 1.1.1.1 mask 255.255.255.255
R2
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface GigabitEthernet0/0/0
ip address 192.168.12.2 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/0/1
ip address 192.168.23.2 255.255.255.0
duplex auto
speed auto
!
router eigrp 1
network 0.0.0.0
R3
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface Tunnel0
ip address 172.16.1.2 255.255.255.0
mtu 1476
tunnel source GigabitEthernet0/0/0
tunnel destination 192.168.12.1
!
interface GigabitEthernet0/0/0
ip address 192.168.23.3 255.255.255.0
duplex auto
speed auto
!
router eigrp 1
network 0.0.0.0
!
router bgp 2
bgp log-neighbor-changes
no synchronization
neighbor 172.16.1.1 remote-as 1
network 3.3.3.3 mask 255.255.255.255
01-21-2023 08:08 AM
Thank you all for your reply!
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide