03-28-2008 07:55 AM - edited 03-03-2019 09:19 PM
Hi everyone how are things? I have a quick quesiton here. I'm trying to create a ebgp-multihop connection but the problem is it never establishes. I don't have any access-list on the interface so it is wide open, I've been looking at this for a while now so everything looks ok to me. I know I'm missing something but anyways here is my config:
router bgp 60301
neighbor 192.168.50.50 remote-as 64637
neighbor 192.168.50.50 ebgp-multihop 5
neighbor 192.168.50.50 update-source FastEthernet1/15
neighbor 192.168.50.50 version 4
neighbor 192.168.50.50 soft-reconfiguration inbound
neighbor 192.168.50.50 prefix-list from-interim in
neighbor 192.168.50.50 prefix-list to-interm out
when I do a sh ip bgp neigh 192.168.50.50 I see the bgp state as active but not established. I've done a soft clear and clear but nothing as of yet. Thank you in advance!!
Solved! Go to Solution.
03-28-2008 08:52 AM
Warren,
You can use the loopback interface as the update-source for the eBGP and iBGP session.
Regards,
03-28-2008 08:01 AM
Who is providing the number of hops?
Do you know what it is suppose to be?
Is this peering with a vendor or yourself?
If your peer is directly connected to you then you will not have multiple hops, if you are peering with a router on the other side of a router then your hop count will be 2 and so on.
03-28-2008 08:03 AM
Hi
Do you have a route to 192.168.50.50 in your routing table? as you are configuring this as multihop I am assuming that you are not directly connected to the 192.168.50.50 interface.
03-28-2008 08:12 AM
Thank you for the quick response I will try to answer your questions at once. I'm peering with another router that isn't mine inorder for me to get to the 192.168.50.50 peer I have to go through my eth 1/15 which is connected to his 10.16.4.176/30(I'm 177 and he is 178) Yes I have a static route that points to 10.16.4.178:
ip route 192.168.50.50 255.255.255.255 10.16.4.178
03-28-2008 08:05 AM
Warren,
A couple of things you might want to check.
1. Is there a route to 192.168.50.50?
2. Try an extended ping to 192.168.50.50 with the address of fa1/5 as the source.
3. Make sure that the neighbor address on the side matches the address of fa1/5 and that 192.168.50.50 matches the source addresses used on the BGP peer.
Regards,
03-28-2008 08:15 AM
Yes there is a route:
sfschirt4#sh ip route 192.168.50.50
Routing entry for 192.168.50.50/32
Known via "static", distance 1, metric 0
Redistributing via ospf 1
Routing Descriptor Blocks:
* 10.16.4.178
Route metric is 0, traffic share count is 1
Also I can ping:
sfschirt4#ping 10.128.184.105 source 172.19.80.9
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.50.50, timeout is 2 seconds:
Packet sent with a source address of 10.16.4.177
!!!!!
Success rate is 100 percent (5/5), round-trip
min/avg/max = 1/1/4 ms
03-28-2008 08:18 AM
Are you able to see the configuration of there end to check what they have configured for your peering?
03-28-2008 08:27 AM
Yes he has emailed me his config:
router bgp 64637
no synchronization
neighbor 172.19.103.45 remote-as 64821
neighbor 172.19.103.45 ebgp-multihop 5
neighbor 172.19.103.45 update-source Loopback1
neighbor 172.19.103.45 soft-reconfiguration inbound
neighbor 172.19.103.45 prefix-list Routes-from-Futures in
neighbor 172.19.103.45 prefix-list Routes-to-Futures out
no auto-summary
172.19.103.45 is my loopback address I don't have the routing though. He is also away from the office so it will be hard to get a hold of him today. Didn't want to wait till monday just trying to make sure I'm good on my end.
03-28-2008 08:30 AM
this remote as is wrong.
it has 64821
and you have configured on your end
router bgp 60301
03-28-2008 08:30 AM
Warren
Your bgp AS number
router bgp 60301
So why does his config say
neighbor 172.19.103.45 remote-as 64821 ie.
AS = 64821
Jon
03-28-2008 08:36 AM
Warren,
As other mentionned, the remote-as is wrong and should be 60301.
Also, 172.19.103.45 is your loopback address, so you should configure your loopback address as the update-source rather than fa1/5.
One more thing, make sure loopback1 address on the remote side is 192.168.50.50, as this is the address used as the update-source.
Regards,
03-28-2008 08:38 AM
Hi
The configs dont seem to match at all.
The AS number is not correct.
You are trying to peer with a source address of your fastethernet interface, and they are trying to peer with your loopback interface.
03-28-2008 08:47 AM
I was looking over the config and noticed that I have an internal peering as well that is also using the loopback as well if I source from teh new connection as suggested will that affect what is already there?
router bgp 64821
no synchronization
bgp router-id 172.19.103.45
bgp log-neighbor-changes
redistribute ospf 1 match internal external 1 external 2 route-map to-VNET
neighbor VNET peer-group
neighbor VNET remote-as 64820
neighbor VNET update-source FastEthernet1/0
neighbor VNET version 4
neighbor VNET soft-reconfiguration inbound
neighbor VNET prefix-list from-VNET in
neighbor VNET prefix-list to-VNET out
neighbor VNET route-map from-VNET-LOCALPREF in
neighbor VNET route-map to-VNET-PREPEND out
neighbor VNET filter-list 17 out
neighbor SFS-INTERNAL peer-group
neighbor SFS-INTERNAL remote-as 64821
neighbor SFS-INTERNAL update-source Loopback0
neighbor 10.128.184.105 remote-as 64637
neighbor 10.128.184.105 ebgp-multihop 5
neighbor 10.128.184.105 update-source FastEthernet1/15
neighbor 10.128.184.105 version 4
neighbor 10.128.184.105 soft-reconfiguration inbound
neighbor 10.128.184.105 prefix-list from-interim in
neighbor 10.128.184.105 prefix-list to-interm out
neighbor 172.19.98.50 peer-group VNET
neighbor 172.19.103.30 peer-group SFS-INTERNAL
no auto-summary
03-28-2008 08:25 AM
Warren,
"debug ip bgp" should give you a lot more information on why the session is not coming up.
Regards,
03-28-2008 08:29 AM
Warren,
The extended ping should be to 192.168.50.50 rather than 10.128.184.105 and should also use the address of fa1/5 as the source.
Regards,
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide