05-30-2007 09:52 AM - last edited on 01-12-2024 03:07 AM by Translator
Imagine I want to let my 3750 do
ip routing:
RouterB[g0/0:192.168.10.1]----[fa0/10:no switchport CAT3750 fa0/11:no switchport]----[fa0/0:192.168.20.1 RouterC]
Then on my CAT3750, I configure:
(...)
int vlan1
ip add 192.168.10.2 255.255.255.0
int vlan 2
ip add 192.168.20.2 255.255.255.0
(...)
My observation is, if I did "no switchport" on the port fa0/12 and fa/011 in the switch how should I approach the respective fa0/12 and fa0/12 in order to specify to which vlan the respective ports are associated with?
I am sorry for this question, but I came across this concept which I forgot and I don't have a switch handy to test it out right now.
Solved! Go to Solution.
05-30-2007 10:07 AM
Hi,
When using "no switchport" the port is converted into a layer 3 interface, which needs an IP address, and can't be assigned to a certain VLAN, as its now a routed port not a switched port, further more it can communicate with VLAN1 and VLAN2 through the SVI interfaces of the VLANs (int vlan1 and int vlan2).
HTH, please do rate all helpful relies,
Mohammed Mahmoud.
05-30-2007 10:07 AM
Hi,
When using "no switchport" the port is converted into a layer 3 interface, which needs an IP address, and can't be assigned to a certain VLAN, as its now a routed port not a switched port, further more it can communicate with VLAN1 and VLAN2 through the SVI interfaces of the VLANs (int vlan1 and int vlan2).
HTH, please do rate all helpful relies,
Mohammed Mahmoud.
05-30-2007 10:09 AM
Thanks!!
05-30-2007 10:18 AM
Hi,
You are very welcomed :)
Please do come back if you have further questions.
BR,
Mohammed Mahmoud.
01-09-2024 01:06 PM
Does it mean any number of ports can be added to "no switchport" port channel and they create LAG by default ? Or how is load balanced? Curious. Tx
01-09-2024 01:42 PM
No and no and LB depends on selected LB algorithm.
01-10-2024 08:12 AM - last edited on 01-12-2024 03:09 AM by Translator
Got two 3750x stacks linked up. with L3 port channel containing two ports. I guess that creates a LAG by default. Since it's L3 no tagging at all. But since there are two ports there has to be LB of some sort (??). I know, I should know this, but I only do enough to get by. Just fairly basic internal network and connect to corporate firewalls. Did pair of 9300 Nexus from scratch for VMWare, ouch, that was a pain. Tx for response, below config I talked about.
interface Port-channel1
description UPLINK to Main
no switchport
ip address 1.4.4.2 255.255.255.248
!
interface GigabitEthernet1/1/1
no switchport
no ip address
channel-group 1 mode active
interface GigabitEthernet2/1/1
no switchport
no ip address
channel-group 1 mode active
the other end ************
interface Port-channel4
description Uplink the other way
no switchport
ip address 1.4.4.1 255.255.255.248
!
interface GigabitEthernet1/1/4
no switchport
no ip address
channel-group 4 mode active
!
interface GigabitEthernet2/1/4
no switchport
no ip address
channel-group 4 mode active
!
01-09-2024 03:24 PM
@janit wrote:
Does it mean any number of ports can be added to "no switchport" port channel and they create LAG by default
Depends on the platform.
Generally, no. Layer 3 ports will not "auto-magically" form a LAG.
01-10-2024 05:17 AM
"Depends on the platform."
Max does depend on platform but I believe none allow an unlimited number.
01-10-2024 08:12 AM
Replied above.
Tx for responding
05-30-2007 10:11 AM - last edited on 01-12-2024 03:09 AM by Translator
Either you configure it as you have done and on the fa0/12 and 11 you just say sw acc vla 1 sw mode access,
or
give no switchport on your interface and then assign ip address inside the interface.. When you give the command
no switchport
the port becomes a layer 3 port.
HTH
Hoogen
Do rate if this post helps
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide