07-22-2024 04:33 PM - last edited on 07-22-2024 04:53 PM by shule
I'm using CML, and I have 2 routers and a switch. I am trying set up EIGRP. on my router I have my two interfaces in my EIGRP instance and when I try to add 3 VLANS (192.168.10.0, 192.168.20.0, 192.168.30.0) the wildcard masks won't show up. when I do a show IP EIGRP neighbors my interfaces with the wildcard masks are there but not my VLANS. Anyone know why the masks for the VLANS aren't showing up
router EIGRP 10
network 10.10.10.0 0.0.0.255
network 172.10.10.0 0.0.0.255
network 192.168.10.0
network 192.168.20.0
network 192.168.30.0
passive-interface default
no passive-interface GigabitEthernet0/0
no passive-interface GigabitEthernet0/1
Router-2#sh IP EIGRP neighbors
EIGRP-IPv4 Neighbors for AS (10)H Address Interface Hold Uptime SRTT RTO Q Seq (sec) (MS) CNT Num
1 172.10.10.2 Gi0/1 14 00:01:15 407 2442 0 3
0 10.10.10.1 Gi0/0 13 00:01:30 167 1002 0 3
07-22-2024 04:44 PM
Can I see topology and where is vlan config
MHM
07-22-2024 04:54 PM
interface GigabitEthernet2/3
negotiation auto
!
interface Vlan10
description MGMT
IP address 192.168.10.10 255.255.255.0
!
interface Vlan20
description Voice
IP address 192.168.20.10 255.255.255.0
!
interface Vlan30
description Voice
IP address 192.168.30.10 255.255.255.0
07-22-2024 04:55 PM
the VLANS are on switch 1
07-22-2024 05:10 PM
if it in SW only and not appear in show ip route in router then router not advertise it
the prefix need direct connect OR summary of direct connect
router with eigrp or ospf or any other IGP not advertise prefix not connect to it
MHM
07-22-2024 05:49 PM - edited 07-22-2024 05:51 PM
Becasue that is the classful boundary, and depends what your configuration is.
Your 192.168.X.X networks are a /16 by default so no need to show the wildcard representation if you put the following:
network 192.168.30.0 0.0.255.255
Your other 10 and 172 networks are not a /24 so when you use a wildcard mask of 0.0.0.255 then it shows up.
Also, the mask that's advertised into EIGRP is whats configured on the interface, not what wildcard you use. A wildcard is only configured to include or exclude interfaces withing the range.
-David
07-22-2024 06:55 PM
I added the network 192.168.10.0 0.0.255.255, 192.168.20.0 0.0.255.255 and 192.168.30.0 0.0.255.255. it now shows up in my Router EIGRP10 as 192.168.0.0 0.0.255.255 however when i do a show run IP EIGRP neighbor I'm still not seeing that IP address as a neighbor
07-22-2024 07:00 PM
IP address 192.168.10.10 255.255.255.0 <- this it wildcard is 0.0.0.255
If you want to see prefix do
Show ip eigrp interface
Not show ip eigrp neighbor
Last show only prefix use to connect to neighbor.
And again are you sure these prefix connect to router?
MHM
07-22-2024 07:14 PM
Show running | in eigrp
Some prefix show wildcard other not?
This depends
1- if prefix is class A or B or C and you config correct mask for it the eigrp dont show wildcard
2- if the prefix is class A or B or C and yoh use different mask for it then eigrp show wildcard (correct)
Here you have 192.168.20/30/40.0 and it class C and you use wildcard 0.0.0.255 so it by defualt not appear.
Above only how eigrp show wildcard
MHM
07-23-2024 04:10 AM
07-22-2024 07:38 PM
They need something to be a neighbor to. As in you need an IP address on the router (probably a subinterface) with the same subnets as your VLANs. Enable EIGRP on that and the router and SW should for 3 neighborships. In order to form an EIGRP neighborship you need to have 2 IPs in the same subnet to be compatible.
On R2s G/1 interface configure 3 subinterfaces (one for each VLAN) with a different IP than the VLAN on the switch. ENable EIGRP for those networks on bot the router and switch, make the switch link a trunk and it should form 3 neighborships.
-David
07-23-2024 08:08 AM
Other posters' replies well describe the "why", but in simple summary, some routing protocols were also designed to be used when classful addressing was in use and still have "artifacts" due to that. (Similar issue on some need to use a "no auto-summary" statement in the router protocol config section.)
07-23-2024 11:57 AM
Hello
You do not need to add the vlan subnet, be as specific as possible and just add the interface ip of the vlan, also depending on what rtr software you are using , if its old you may need to disable auto-summarization under the eigrp process.
example:
int vlan x
ip address 10.10.10.1 255.255.255.0
int vlan y
ip address 10.10.20.1 255.255.255.0
router eigrp xxx
no auto-summary
network 10.10.10.1 0.0.0.0
network 10.10.20.1 0.0.0.0
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide