cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1690
Views
0
Helpful
19
Replies

EIGRP not populating routes on core from branch

cloksin
Level 1
Level 1

I have a strange issue here.  I have a branch router that I just deployed, connected via DMVPN.  The DMVPN tunnel builds just fine.  Once the tunnel is up, the branch router gets all the routes via EIGRP from the core.  However, the core routing table is not getting any of the routes from the branch.  

 

Branch config:

version 15.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname router
!
boot-start-marker
boot system flash c880data-universalk9-mz.153-2.T.bin
boot system flash c880data-universalk9-mz.153-3.M4.bin
boot system flash:c880data-universalk9-mz.154-3.M7.bin
boot-end-marker
!
!
enable secret 5 xxxx
!
aaa new-model
!
!
!
!
!
!
!
aaa session-id common
memory-size iomem 10
clock timezone CST -6 0
clock summer-time CDT recurring
service-module wlan-ap 0 bootimage autonomous
!
!
!
!
!
!


!
ip dhcp excluded-address 10.40.62.1 10.40.62.99
!
ip dhcp pool 40
network 10.40.62.0 255.255.255.0
default-router 10.40.62.1
dns-server 10.1.1.69 10.1.1.95
!
ip dhcp pool 36
network 10.36.62.0 255.255.255.0
option 43 hex xxxx.xxxx.xxxx
default-router 10.36.62.1
!
ip dhcp pool 38
network 10.38.62.0 255.255.255.0
default-router 10.38.62.1
option 150 ip 10.1.1.20 10.1.65.240
domain-name domain.generic
!
!
!
ip flow-cache timeout active 1
no ip domain lookup
ip domain name domain.generic
ip cef
no ipv6 cef
ipv6 multicast rpf use-bgp
!
!
multilink bundle-name authenticated
!
flow record NTARecord
match ipv4 tos
match ipv4 protocol
match ipv4 source address
match ipv4 destination address
match transport source-port
match transport destination-port
match interface input
collect counter bytes
collect counter packets
!
!
flow exporter NTAExporter
destination 10.110.110.46
transport udp 2055
!
!
flow monitor NTAMonitor
exporter NTAExporter
cache timeout active 60
record NTARecord
!
license udi pid CISCO881W-GN-A-K9 sn xxxx
license accept end user agreement
license boot module c880-data level advipservices
!
!
archive
log config
hidekeys
username user1 privilege 15 secret 5 xxxx
!
!
!
!
!
ip ssh time-out 60
ip ssh authentication-retries 5
ip ssh version 2
!
!
!
!
!
!
!
!
!
interface Tunnel0
ip address 10.254.240.62 255.255.255.0
no ip redirects
ip mtu 1440
ip nhrp authentication cisco123
ip nhrp map multicast 71.xxx.xxx.xxx
ip nhrp map 10.254.240.1 71.xxx.xxx.xxx
ip nhrp network-id 1
ip nhrp nhs 10.254.240.1
delay 120
tunnel source FastEthernet4
tunnel mode gre multipoint
tunnel key 0
!
interface FastEthernet0
switchport access vlan 921
no ip address
no cdp enable
!
interface FastEthernet1
switchport access vlan 40
no ip address
!
interface FastEthernet2
switchport trunk native vlan 40
switchport mode trunk
no ip address
!
interface FastEthernet3
switchport trunk native vlan 40
switchport mode trunk
no ip address
!
interface FastEthernet4
ip address dhcp
duplex full
speed 100
!
interface wlan-ap0
description Service module interface to manage the embedded AP
no ip address
arp timeout 0
!
interface Wlan-GigabitEthernet0
description Internal switch interface connecting to the embedded AP
no ip address
!
interface Vlan1
no ip address
shutdown
!
interface Vlan36
ip address 10.36.62.1 255.255.255.0
!
interface Vlan38
ip address 10.38.62.1 255.255.255.0
!
interface Vlan40
ip address 10.40.62.1 255.255.255.0
!
interface Vlan54
ip address 10.54.62.1 255.255.255.0
!
interface Vlan57
ip address 10.57.62.1 255.255.255.0
!
interface Vlan60
ip address 10.60.62.1 255.255.255.0
!
interface Vlan921
ip address 10.254.230.62 255.255.255.0
ip flow monitor NTAMonitor input
ip flow monitor NTAMonitor output
!
!
router eigrp 101
network 10.36.62.0 0.0.0.255
network 10.38.62.0 0.0.0.255
network 10.40.62.0 0.0.0.255
network 10.54.62.0 0.0.0.255
network 10.57.62.0 0.0.0.255
network 10.60.62.0 0.0.0.255
network 10.254.230.0 0.0.0.255
network 10.254.240.0 0.0.0.255
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
ip flow-export version 5
ip flow-export destination 10.1.1.15 2055
!
ip route 71.xxx.xxx.xxx 255.255.255.255 dhcp
!
!
!
!
!
control-plane
!
!
!
line con 0
logging synchronous
no modem enable
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input ssh
line vty 0 4
logging synchronous
transport input ssh
line vty 5 15
logging synchronous
transport input ssh
!
scheduler max-task-time 5000
ntp update-calendar
ntp server 192.5.41.209
ntp server 198.30.92.2
!
end

19 Replies 19

all your physical interfaces are down, you need to make sure you need to bring atleast one of the fa0-fa3 up and configure that interface as trunk and allow all vlans on trunk to bring the SVIs up.

The physical interfaces are down because there are currently no other devices connected to this L3 switch.  I am waiting on another device to arrive.  One of the SVIs is my management VLAN though.  Is there no way to get this to come up without having one of the L2 ports connected?

Hello,

 

there used to be the command 'state active' in Vlan configuration mode, that would bring up the SVI even when there is no port assigned to that Vlan, not sure if that command is still around:

 

router#conf t

router(config)#vlan 40

router(config-vlan)#state active

 

 

They're all active already, they're just down and down.  I did run that command on the management vlan, but it didn't change anything.

 

I'm guessing I'll just have to connect something to it in order to bring the SVIs up.  I'll let you know when my device arrives and I can get to the remote location to install it.

It's been a little while since this thread stalled.  I've just been too busy to get around to replying what happened.  Turns out I was just being a dope.  I've been so used to connecting everything together (router, switches, endpoints) during my deployments, I just assumed that everything would come up as planned.  In this particular case, the deployment was in stages, and nothing was connected to the router for a couple of weeks.  Once I connected a switch and some endpoints, everything came up as expected.

 

Thanks everyone for your help and input, I learned something from this experience, and I hope someone else can learn something from this too.

Review Cisco Networking products for a $25 gift card