11-18-2022 02:34 PM
Hi all,
A lab has been created on my Eve-NG with 4 router rings topology, done routing and basic ip configuration. But when I check, there is no connectivity between the two PCs. This must be done only using EIGRP. No access lists configured and automatic summarization disabled.
It is not possible to ping 192.168.1.x and 192.168.2.x from the router except for those attached routers.
Using cisco IOL L3 router! - Network diagram attached!
ROUTER1:
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Ethernet0/0
ip address 10.0.10.1 255.255.255.252
!
interface Ethernet0/1
ip address 10.0.13.1 255.255.255.252
!
interface Ethernet0/2
ip address 192.168.1.1 255.255.255.0
!
interface Ethernet0/3
no ip address
shutdown
!
!
router eigrp 10
network 0.0.0.0
network 1.1.1.1 0.0.0.0
network 10.0.10.0 0.0.0.3
network 10.0.13.0 0.0.0.3
network 192.168.1.0
passive-interface Ethernet0/2
passive-interface Loopback0
============================
ROUTER2:
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface Ethernet0/0
ip address 10.0.10.2 255.255.255.252
!
interface Ethernet0/1
ip address 10.0.11.1 255.255.255.252
!
interface Ethernet0/2
no ip address
shutdown
!
interface Ethernet0/3
no ip address
shutdown
!
!
router eigrp 10
network 2.2.2.2 0.0.0.0
network 10.0.10.0 0.0.0.3
network 10.0.11.0 0.0.0.3
passive-interface Loopback0
!
============================
ROUTER3:
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface Ethernet0/0
ip address 10.0.11.2 255.255.255.252
!
interface Ethernet0/1
ip address 10.0.12.2 255.255.255.252
!
interface Ethernet0/2
ip address 192.168.2.1 255.255.255.0
!
interface Ethernet0/3
no ip address
shutdown
!
!
router eigrp 10
network 3.3.3.3 0.0.0.0
network 10.0.11.0 0.0.0.3
network 10.0.12.0 0.0.0.3
network 192.168.2.0
passive-interface Ethernet0/2
passive-interface Loopback0
!
============================
ROUTER4:
interface Loopback0
ip address 4.4.4.4 255.255.255.255
!
interface Ethernet0/0
ip address 10.0.12.1 255.255.255.252
!
interface Ethernet0/1
ip address 10.0.13.2 255.255.255.252
!
interface Ethernet0/2
no ip address
shutdown
!
interface Ethernet0/3
no ip address
shutdown
!
!
router eigrp 10
network 4.4.4.4 0.0.0.0
network 10.0.12.0 0.0.0.3
network 10.0.13.0 0.0.0.3
passive-interface Loopback0
!
Any suggestion will be highly appreciable!!!
Thanks!
Solved! Go to Solution.
11-18-2022 05:54 PM - last edited on 11-21-2022 01:11 AM by Translator
Hi @san ju. ,
Thanks for providing more information. I now see what the problem is. Both R1 and R3 have the same router-id (192.168.1.1 according to the
show ip eigrp
topology you provided), which causes R1 to reject the information received from R3 and vice versa.
The solution is to explicitly configure the router-id, let's say on R3 as follow:
router eigrp 10
eigrp router-id 3.3.3.3
You should be able to ping 192.168.2.1 from 192.168.1.1 and vice versa or from PC to PC after making that change.
You could do the same on all routers, using the loopback 0 ip address as the router-id on each router.
Regards,
11-18-2022 03:29 PM
Hello,
The config looks pretty well laid out and correct. 2 questions.
1. Are all 4 Routers form an EIGRP neighborship with their directly connected neighbors?
2. Can you provide the Route/topology table of R1 and R3 please
I'm leaning towards some weird configuration with the PCs at initial glance.
-David
11-18-2022 05:03 PM
Hi David,
Yes, all the routers adjacency is fine, Routers communicating with each other - Also the PC side is fine verified - Am thinking if my eve winVM has some problem or something!
R1 can't ping 192.168.2.x & R3 can't ping 192.168.1.x
ROUTER1#sho ip route eigrp
Gateway of last resort is not set
2.0.0.0/32 is subnetted, 1 subnets
D 2.2.2.2 [90/409600] via 10.0.10.2, 03:27:03, Ethernet0/0
4.0.0.0/32 is subnetted, 1 subnets
D 4.4.4.4 [90/409600] via 10.0.13.2, 03:27:07, Ethernet0/1
10.0.0.0/8 is variably subnetted, 6 subnets, 2 masks
D 10.0.11.0/30 [90/307200] via 10.0.10.2, 03:27:03, Ethernet0/0
D 10.0.12.0/30 [90/307200] via 10.0.13.2, 03:27:07, Ethernet0/1
ROUTER1#sho ip eigrp topology
EIGRP-IPv4 Topology Table for AS(10)/ID(192.168.1.1)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status
P 4.4.4.4/32, 1 successors, FD is 409600
via 10.0.13.2 (409600/128256), Ethernet0/1
P 10.0.10.0/30, 1 successors, FD is 281600
via Connected, Ethernet0/0
P 192.168.1.0/24, 1 successors, FD is 281600
via Connected, Ethernet0/2
P 10.0.13.0/30, 1 successors, FD is 281600
via Connected, Ethernet0/1
P 2.2.2.2/32, 1 successors, FD is 409600
via 10.0.10.2 (409600/128256), Ethernet0/0
P 10.0.11.0/30, 1 successors, FD is 307200
via 10.0.10.2 (307200/281600), Ethernet0/0
P 1.1.1.1/32, 1 successors, FD is 128256
via Connected, Loopback0
P 10.0.12.0/30, 1 successors, FD is 307200
via 10.0.13.2 (307200/281600), Ethernet0/1
===========
ROUTER3#sho ip route eigrp
Gateway of last resort is not set
2.0.0.0/32 is subnetted, 1 subnets
D 2.2.2.2 [90/409600] via 10.0.11.1, 03:45:39, Ethernet0/0
4.0.0.0/32 is subnetted, 1 subnets
D 4.4.4.4 [90/409600] via 10.0.12.1, 03:41:53, Ethernet0/1
10.0.0.0/8 is variably subnetted, 6 subnets, 2 masks
D 10.0.10.0/30 [90/307200] via 10.0.11.1, 04:23:32, Ethernet0/0
D 10.0.13.0/30 [90/307200] via 10.0.12.1, 04:23:32, Ethernet0/1
ROUTER3#sho ip eigrp topology
EIGRP-IPv4 Topology Table for AS(10)/ID(192.168.1.1)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status
P 192.168.2.0/24, 1 successors, FD is 281600
via Connected, Ethernet0/2
P 4.4.4.4/32, 1 successors, FD is 409600
via 10.0.12.1 (409600/128256), Ethernet0/1
P 10.0.10.0/30, 1 successors, FD is 307200
via 10.0.11.1 (307200/281600), Ethernet0/0
P 10.0.13.0/30, 1 successors, FD is 307200
via 10.0.12.1 (307200/281600), Ethernet0/1
P 2.2.2.2/32, 1 successors, FD is 409600
via 10.0.11.1 (409600/128256), Ethernet0/0
P 10.0.11.0/30, 1 successors, FD is 281600
via Connected, Ethernet0/0
P 3.3.3.3/32, 1 successors, FD is 128256
via Connected, Loopback0
P 10.0.12.0/30, 1 successors, FD is 281600
via Connected, Ethernet0/1
Thanks
11-18-2022 05:54 PM - last edited on 11-21-2022 01:11 AM by Translator
Hi @san ju. ,
Thanks for providing more information. I now see what the problem is. Both R1 and R3 have the same router-id (192.168.1.1 according to the
show ip eigrp
topology you provided), which causes R1 to reject the information received from R3 and vice versa.
The solution is to explicitly configure the router-id, let's say on R3 as follow:
router eigrp 10
eigrp router-id 3.3.3.3
You should be able to ping 192.168.2.1 from 192.168.1.1 and vice versa or from PC to PC after making that change.
You could do the same on all routers, using the loopback 0 ip address as the router-id on each router.
Regards,
11-18-2022 06:45 PM - edited 11-18-2022 06:47 PM
Good catch! I guess it was the right output to ask for because everything else provided does not indicate the same RID. The router interfaces clearly have separate 192 addresses so it should not have been the same if auto-assigned. Maybe a bug.
11-19-2022 12:38 AM
Thanks David for your suggestion!
11-18-2022 03:56 PM
Hi @san ju. ,
If you can ping from 192.168.1.1 to 192.168.2.1 and vice versa, It looks like you might be missing the default gateway configuration on the PCs, which prevents the PC from pinging one another.
Regards,
11-18-2022 05:05 PM
Checked PC side - GWs and IPs are fine!
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide