cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
123903
Views
25
Helpful
15
Replies
Beginner

Etherchannel Interfaces in suspend mode

Hello!!

I configured an Etherchannel two interfaces (Gi0/37 and Gi0/39) in a CiscoWS-C2960G-48TC-L, which is connected to an HP Blade, where they spend 2vlan (16 and 17).

The point is that they got these interfaces on a trial and upload these were in sleep mode produces the following log.

Sep 1 16:04:38.649:% EC-5-CANNOT_BUNDLE2: Gi0/37 is not Compatible with Po1 and Will be suspended (trunk mode of Gi0/37 is dynamic, is Po1 trunk)

Sep 1 16:04:38.733:% EC-5-CANNOT_BUNDLE2: Gi0/39 is not Compatible with Po1

and Will be suspended (trunk mode of Gi0/39 is dynamic, is Po1 trunk

Applied to equipment configuration is as follows:

interface Port-channel1
switchport trunk allowed vlan 16,17
switchport  mode trunk
switchport nonegotiate
speed 1000
duplex  full
spanning-tree portfast trunk
!
interface  GigabitEthernet0/37
description c7000te2-vc1
switchport trunk allowed  vlan 16,17
switchport mode trunk
switchport nonegotiate
speed  1000
duplex full
channel-group 1 mode active
!
interface  GigabitEthernet0/39
description c7000te2-vc1
switchport trunk allowed  vlan 16,17
switchport mode trunk
switchport nonegotiate
speed  1000
duplex full

Any idea why interfaces are in "suspend"

regards

Atte.

César Pérez

Everyone's tags (2)
1 ACCEPTED SOLUTION

Accepted Solutions
Beginner

Do you have work around or

Do you have work around or solution ?

15 REPLIES 15
Advisor

Etherchannel Interfaces in suspend mode

Hi,

Can you do sh int trunk and post output because apparently there is a trunking mode mismatch and I don't see that g0/39 is part of the PortChannel also.

Regards.

Alain.

Don't forget to rate helpful posts.
Beginner

Etherchannel Interfaces in suspend mode

Hello,

Herewith the "show interface trunk"

switch # show interfaces trunk

Port Mode Encapsulation Status Native vlan

802.1q trunking 1 Gi0/47 on

802.1q trunking 1 Gi0/48 on

802.1q trunking 1 Po1 on

Port VLANs allowed on trunk

1-5,11-19 Gi0/47

1-5,11-19 Gi0/48

16-17 Po1

Port VLANs allowed and active in management domain

1,5,11-14,16-17 Gi0/47

1,5,11-14,16-17 Gi0/48

16-17 Po1

Port VLANs in spanning tree forwarding state and not pruned

Gi0/47 none

1,5,11-14,16-17 Gi0/48

Port VLANs in spanning tree forwarding state and not pruned

16-17 Po1

switch #

The interface belongs to Po1 Gi0/39 if I pasted the wrong configuration, my apologies. Again attached configuration Gi0/39.

!

interface GigabitEthernet0/39

description c7000te2-vc1

switchport trunk allowed vlan 16,17

switchport mode trunk

switchport nonegotiate

speed 1000

duplex full

channel-group 1 mode active

!

Regards!

César Pérez

Beginner

Etherchannel Interfaces in suspend mode

Hi Cesar:

Tear down the existing configuration and start fresh. Also, remove the Port Channel that's already defined.

interface range gig0/37 , gig0/39

shutdown

switch trunk encap dot1q

switch mode trunk

switchport nonegotiate         

channel-group 1 mode active

no shutdown

PS: If configuring Active on the interfaces does not work, change it to passive. Before you do it, shut both interfaces prior to making the changes. Also ensure both devices have the same Native VLAN defined. If the port-channel comes up, then add the command "switch trunk allowed vlan add 16,17" under the port-channel 1. I hope this fixes your problem.

Engager

Etherchannel Interfaces in suspend mode

This is probably an LACP negotiation problem.

"LACP is supported on cross-stack EtherChannels from Cisco IOS Software Release 12.2(25)SEC and later. Switch interfaces exchange LACP packets only with partner interfaces with the active or passive mode configuration."

This is the HP switch. When the other side is in sleep-mode, a channel cannot be negotiated or maintained.

Link:

http://www.cisco.com/en/US/products/hw/switches/ps5023/products_configuration_example09186a00806cb982.shtml#lacp

regards,

Leo

Beginner

Etherchannel Interfaces in suspend mode

Thank you.

It would be nice this configuration?

interface  Port-channel1
switchport trunk allowed vlan 16,17
switchport mode  trunk
switchport nonegotiate
spanning-tree portfast  trunk

interface range  gig0/37 , gig0/39

   shutdown

   switch trunk allowed vlan 16,17

   switch mode trunk

   switchport nonegotiate

   speed auto

  duplex  auto        

   spanning-tree portfast trunk

   channel-group 1 mode active

   channel-protocol lacp

  no  shutdown

Thank you all for the answers.

César Pérez

Hall of Fame Community Legend

Etherchannel Interfaces in suspend mode

Hi Cesar,

Avoid configuring the PortChannel first.

Try this ...

no int po 1

default int r g0/37 , g0/39

int r g0/37 , g0/39

switchport mode trunk

switchport trunk allow vlan 16,17

switchport non

channel-group 1 mode act

[optional]

channel-prot lacp

Highlighted
Beginner

Etherchannel Interfaces in suspend mode

I would also make sure what the HP blade protocol is for NIC teaming or else the config wont work..protocol mismatch

Cisco Employee

The datasheet for the 2960X

The datasheet for the 2960X mention that if any inconsistency is found in the interfaces participating in the etherchannel it will change the status of the interfaces of the 2960x to suspended.

I found in my case that the SFP´s and the "native" speed of the interfaces didn't match, meaning:

1.-some of the sfp´s status in the show inventory looked like: unspecified or no status at all

2.- the "native" speed of the interfaces were in the 3750x (1000BaseSX SFP) while in the 2960x (10/100/1000BaseTX).

I Hope this helps.

Taoki

Beginner

Have you found out the issue

Have you found out the issue ?

Cisco Employee

Assuming that you are using

Assuming that you are using SFP´s and it goes in suspended mode. I found out that the 2960x switch needs to have connected the SFP´s on interfaces g1/0/25 and g1/0/27 instead of g1/0/25 and g1/0/26. As silly as it sound it prevents the etherchannel to form if not connected as described.

Cisco Employee

Yes, from the 4 SFP ports

Yes, from the 4 SFP ports that I have on my 2960x Only the connectivity with the ports 25-27 and 26-28 worked

Beginner

Do you have work around or

Do you have work around or solution ?

Beginner

Re: Etherchannel Interfaces in suspend mode

Hi Dear,

I've exactly the same problem with my VSL port-channel

Let me know how did you get it resolved

BR,

Beginner

Re: Etherchannel Interfaces in suspend mode

I have the same problem on my 2960x but not with SFP mines with copper
CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards