cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
401
Views
0
Helpful
2
Replies
aanurast15
Beginner

External IP to Internal IP NAT Issue

I have a 2600 I am trying to setup for educational use. 

My Cable ISP has issued me 5 routable IP's through their SMC modem 86.28.12.226-229.  The SMC modem is .225.  Currently the internal network can get out through .229 as expected but nothing outside (tcp 80 to web server) can get through.  When I assigned the ip's to e0/1 as secondarr I could get it to route from the inside network (so hitting .226 80 went to the correct place) but it still didn't work from the outside - plus I read that wasn't a great way to do it anyway.

After two days of reading through posts and discussion I am pretty sure this is going to be an easy answer and probably make me feel silly for asking.

!

interface FastEthernet0/0

description LAN Interface

ip address 192.168.0.2 255.255.255.0

ip nat inside

duplex auto

speed auto

!

interface Serial0/0

no ip address

shutdown

!

interface FastEthernet0/1

description WAN Interface

ip address 86.28.12.229 255.255.255.248

ip nat outside

speed 100

full-duplex

!

interface Serial0/1

no ip address

shutdown

!

ip nat inside source list 100 interface FastEthernet0/1 overload

ip nat inside source static tcp 192.168.0.150 80 86.28.12.228 80 extendable

ip classless

ip route 0.0.0.0 0.0.0.0 86.28.12.225

no ip http server

no ip pim bidir-enable

!

access-list 100 permit ip 192.168.0.0 0.0.0.255 any

!

Thanks in advance!

1 ACCEPTED SOLUTION

Accepted Solutions
mfurnival
Enthusiast

The config looks OK to me.

Can you try and hit the outside address on port 80 and do:

#show ip nat translations

#debug ip nat

and paste the output please?

View solution in original post

2 REPLIES 2
mfurnival
Enthusiast

The config looks OK to me.

Can you try and hit the outside address on port 80 and do:

#show ip nat translations

#debug ip nat

and paste the output please?

Hello mfurnival,

I had the gateway set to the old ip on the VM the webserver os was hosted on.  That is what causing the grief.  I am giving you the credit because your confirmation of my config drove me into looking outside the router for the real issue. 

Thank you for your help and quick response!

Cheers!