cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
476
Views
0
Helpful
4
Replies

Flapping neighbor adjacency

Randyx
Level 1
Level 1

Hi Guys,

Need your assistance. I created topology below. I created HSRP on R12 and R13 then EIGRP everywhere. After everything is configured. The adjacency between R12 and R14 keeps coming up and down. I noticed that all packets are being routed to R13. All interfaces have equal speed (10mbps / half duplex). I'm suspecting split-horizon but not 100% sure. 

Here are the configurations

R12

interface FastEthernet0/0
ip address 192.168.10.2 255.255.255.248
speed auto
duplex auto
standby 1 ip 192.168.10.1
standby 1 priority 110
standby 1 preempt
!
interface Serial0/0
no ip address
shutdown
clock rate 2000000
!
interface FastEthernet0/1
ip address 192.168.10.9 255.255.255.248
speed auto
duplex auto


!
router eigrp 1
network 192.168.10.0 0.0.0.7
network 192.168.10.8 0.0.0.3
no auto-summary
!


R13

interface FastEthernet0/0
ip address 192.168.10.3 255.255.255.248
speed auto
duplex auto
standby 1 ip 192.168.10.1
standby 1 preempt
!
interface Serial0/0
no ip address
shutdown
clock rate 2000000
!
interface FastEthernet0/1
ip address 192.168.10.22 255.255.255.252
speed auto
duplex auto
!

!
router eigrp 1
network 192.168.10.0 0.0.0.7
network 192.168.10.20 0.0.0.3
no auto-summary

R14

interface FastEthernet0/0
ip address 192.168.10.13 255.255.255.252
speed auto
duplex auto
!
interface Serial0/0
no ip address
shutdown
clock rate 2000000
!
interface FastEthernet0/1
ip address 192.168.10.10 255.255.255.252
speed auto
duplex auto

router eigrp 1
network 192.168.10.8 0.0.0.3
network 192.168.10.12 0.0.0.3
no auto-summary

R15
interface FastEthernet0/0
ip address 192.168.10.18 255.255.255.252
duplex auto
speed auto
!
interface Serial0/0
no ip address
shutdown
clock rate 2000000
!
interface FastEthernet0/1
ip address 192.168.10.21 255.255.255.252
duplex auto
speed auto

!
router eigrp 1
network 192.168.10.16 0.0.0.3
network 192.168.10.20 0.0.0.3
no auto-summary


R11
!
interface Loopback0
ip address 11.11.11.11 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.10.14 255.255.255.252
speed auto
duplex auto
!
interface Serial0/0
no ip address
shutdown
clock rate 2000000
!
interface FastEthernet0/1
ip address 192.168.10.17 255.255.255.252
speed auto
duplex auto

router eigrp 1
network 11.11.11.0 0.0.0.255
network 192.168.10.12 0.0.0.3
network 192.168.10.16 0.0.0.3
no auto-summary

1 Accepted Solution

Accepted Solutions

azibnaseem
Level 1
Level 1

spamguard006  

What I have observed from the configuration that you have miss-configured R12 Fa 0/1. Its subnet mask should be 252.

interface FastEthernet0/1
ip address 192.168.10.9 255.255.255.248.

It should be 255.255.255.252.

You have also advertised network 192.168.10.8 0.0.0.3 in Eigrp.

Make these changes if can help.

Regards'

View solution in original post

4 Replies 4

azibnaseem
Level 1
Level 1

spamguard006  

What I have observed from the configuration that you have miss-configured R12 Fa 0/1. Its subnet mask should be 252.

interface FastEthernet0/1
ip address 192.168.10.9 255.255.255.248.

It should be 255.255.255.252.

You have also advertised network 192.168.10.8 0.0.0.3 in Eigrp.

Make these changes if can help.

Regards'

Wow!! I completely missed it. I've been troubleshooting this for a day. Darn!! Thanks for everyone's help..appreciate it!

HI spamguard006  '

Very glad to hear that your problem is resolved.

Regard'

Deepak Kumar
VIP Alumni
VIP Alumni

Hi, 

Set your interface speed and duplex manually and check your Subnet configuration. Your problem will resolved. I was faced same issue.

Reards, 

Deepak Kumar 

Regards,
Deepak Kumar,
Don't forget to vote and accept the solution if this comment will help you!
Review Cisco Networking for a $25 gift card