cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

553
Views
0
Helpful
2
Replies
Highlighted
Beginner

Flapping PPPoE connection

 I was hoping someone could help me understand why my PPPoE connection keeps “flapping” in my lab I am using the dialer persistent, dialer idle-timeout 0 and, no cdp enable commands.
(idk why i would need to disable cdp but I seen it in another post, it does not seem to matter whether I have cdp enabled or not)
Everything works like normal but after some time my PPPoE link breaks and then re-establishes. I have the configuration of the clients dialer and fast ethernet interface below.
Also i am using 7200 routers in gns3 with the image: c7200-adventerprisek9-mz.152-4.S3

interface Dialer1
 mtu 1492
 ip address negotiated
 encapsulation ppp
 dialer pool 1
 dialer idle-timeout 0
 dialer persistent
 ppp chap hostname CUSTOMER
 ppp chap password 0 CISCO
 no cdp enable

interface FastEthernet0/0
 no ip address
 duplex full
 pppoe enable
 pppoe-client dial-pool-number 1

If someone could explain to me why this is happening or teach me what I can do to prevent this from happening I would greatly appreciate it. Also I can provide the Server config if you like but I dont think it is necessary (but then again what do I know i am asking for help lol)

 

2 REPLIES 2
Highlighted
Hall of Fame Cisco Employee

Re: Flapping PPPoE connection

Hello,

Your configuration appears to be completely correct. Seeing the "server" side configuration (the PPPoE access concentrator) would be useful! Can you share that configuration as well?

Either way, the reason for the PPPoE session flap is not obvious from here. I wonder if you could run the following debugs:

debug ppp negotiation

debug pppoe errors

debug pppoe events

debug pppoe packets

on both the client and the server till the flap occurs, and then share the outputs. This should allow us to tell better what had caused the PPPoE session to go down. I personally suspect some kind of LCP timeout, perhaps due to high CPU on your GNS3 machine (just a guess), but the debugs should tell us more. Obviously, we would need to have the debugs logged, so make sure to configure both the client and the server with logging buffered 10000000 debugging to make sure these logs get recorded in their entirety.

Thanks a lot!

Best regards,
Peter

Highlighted
Beginner

Re: Flapping PPPoE connection

Sorry I was not been able to respond sooner. I was at work and can't work on this problem there. 

However while turning debugs on I believe I have found the issue but not the root cause.

The first debug error I seen is below

SERVER output

*Jun 7 19:54:10.751: Vi1.1 PPP: Missed 5 keepalives, taking LCP down
*Jun 7 19:54:10.751: Vi1.1 PPP DISC: Missed too many keepalives

 

CLIENT output

*Jun 7 20:08:26.359: Vi1 LCP: I TERMREQ [Open] id 4 len 4
*Jun 7 20:08:26.363: Vi1 PPP DISC: Received LCP TERMREQ from peer

So it seems the access concentrator is not getting keepalives 

I believe this could be a GNS3 issue but I am not sure if it is CPU related as my CPU never gets taxed.

I have pasted in the concentrator and client configs like you have asked. Sorry If I didn't give you enough debug information but I seen the missed keepalives and that seemed obvious to me why the connection was flapping.

 

SERVER

bba-group pppoe global
virtual-template 1

 

interface Virtual-Template1
ip address 192.168.12.2 255.255.255.0
peer default ip address pool CLIENT
ppp authentication chap callin

 

ip local pool CLIENT 192.168.12.1

 

username CUSTOMER password 0 CISCO

 

interface FastEthernet0/0
no ip address
duplex full
pppoe enable group global

 

CLIENT

ip address negotiated
encapsulation ppp
dialer pool 1
dialer idle-timeout 0
dialer persistent
ppp chap hostname CUSTOMER
ppp chap password 0 CISCO

 

interface FastEthernet0/0
no ip address
duplex full
pppoe enable
pppoe-client dial-pool-number 1

 

Please let me know your thoughts on this. I would be more than happy to get you more debugs/logs. Thanks for any help you can provide!