cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
1623
Views
0
Helpful
4
Replies
ashrafkhanm
Beginner

Frame-relay interface not coming up!

Hello Everyone,

I 'm trying to set up a home lab with a couple of 28XX and 2651XM series routers.

I would like to simulate a frame-relay connection between HQ, Branch1 and Branch2 . All of them are conneced to a PSTN switch (2811 router) via T1 cross over cables. The connectivity is like this.

                                                                                        HQ

                                                                                          |

                                                                                          |

                                                               Branch 1 ---> PSTN-WAN <--  Branch 2

I have configured all the routers and FR switch with necessary configuration. However the link between HQ and Branch1 is not coming up. On both the routers I could see the line protocol is down.I have pasted the configuration below. Please advise if am missing anything here. (It is not a cable/port issue)

From the  PSTN-WAN router

=======================================================

controller T1 0/0/0

framing esf

clock source internal

linecode b8zs

channel-group 0 timeslots 1-24

description ** SERIAL DATA CONNECTION TO HQ-RTR **

controller T1 0/1/0

framing esf

clock source internal

linecode b8zs

channel-group 0 timeslots 1-24

description ** SERIAL DATA CONNECTION TO BR1-RTR **

!

interface Serial0/0/0:0

description ** T1 DATA CONNECTION TO HQ-RTR **

no ip address

encapsulation frame-relay IETF

frame-relay lmi-type ansi

frame-relay intf-type dce

frame-relay route 201 interface Serial0/1/0:0 101

frame-relay route 202 interface Serial0/3/0:0 102

interface Serial0/1/0:0

description ** T1 DATA CONNECTION TO BR1-RTR **

no ip address

encapsulation frame-relay IETF

frame-relay lmi-type ansi

frame-relay intf-type dce

PSTN-WAN#sh ip int bri

Interface                  IP-Address      OK? Method Status                Protocol

FastEthernet0/0            10.10.100.2     YES NVRAM  up                    up     

FastEthernet0/1            192.168.0.11    YES NVRAM  up                    up     

Serial0/0/0:0              unassigned      YES NVRAM  up                    up     

Serial0/0/1:0              unassigned      YES unset  down                  down   

Serial0/0/1:1              unassigned      YES unset  down                  down   

Serial0/0/1:2              unassigned      YES unset  down                  down   

Serial0/0/1:22             unassigned      YES unset  down                  down   

Serial0/0/1:23             unassigned      YES NVRAM  up                    up     

Serial0/1/0:0              unassigned      YES manual up                    down   

Serial0/1/1:0              unassigned      YES unset  down                  down   

Serial0/1/1:1              unassigned      YES unset  down                  down   

Serial0/1/1:2              unassigned      YES unset  down                  down   

Serial0/1/1:22             unassigned      YES unset  down                  down   

Serial0/1/1:23             unassigned      YES NVRAM  up                    up     

Serial0/3/0:0              unassigned      YES NVRAM  up                    up     

Serial0/3/1:0              unassigned      YES unset  down                  down   

Serial0/3/1:1              unassigned      YES unset  down                  down   

Serial0/3/1:2              unassigned      YES unset  down                  down   

Serial0/3/1:22             unassigned      YES unset  down                  down   

Serial0/3/1:23             unassigned      YES NVRAM  up                    up     

Loopback0                  1.1.1.1         YES NVRAM  up                    up

From the HQ router

====================================================================

controller T1 0/0/0

channel-group 0 timeslots 1-24

framing esf

clock source internal

linecode b8zs

interface Serial0/0/0:0

no ip address

encapsulation frame-relay

frame-relay lmi-type ansi

!

interface Serial0/0/0:0.1 point-to-point

ip address 10.10.111.1 255.255.255.0

ip ospf mtu-ignore

snmp trap link-status

frame-relay interface-dlci 201  

!

interface Serial0/0/0:0.2 point-to-point

ip address 10.10.112.1 255.255.255.0

ip ospf mtu-ignore

snmp trap link-status

frame-relay interface-dlci 202

From the BR1 router

========================================

controller T1 1/0

channel-group 0 timeslots 1-24

framing esf

clock source internal

linecode b8zs

!

interface Serial 1/0:0

no ip address

encapsulation frame-relay IETF

fair-queue

frame-relay lmi-type ansi

!

interface Serial 1/0:0.1 point-to-point

ip address 10.10.111.2 255.255.255.0

ip ospf mtu-ignore

snmp trap link-status

frame-relay interface-dlci 101  

!

========================================================

1 ACCEPTED SOLUTION

Accepted Solutions

Hi,

1)

interface Serial0/1/0:0

description ** T1 DATA CONNECTION TO BR1-RTR **

there is no frame route statement here but it should

2) HQ frame-relay interface has Cisco encapsulation but BR1 has got IETF so it won't work.

Regards.

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.

View solution in original post

4 REPLIES 4
Reza Sharifi
Hall of Fame Expert

Hi,

Can you clock the DCE side and test again?

clock rate xx

http://www.cisco.com/en/US/docs/ios/12_0/dial/configuration/guide/dcsyncs.html

HTH

Reza,

I tried it...But no luck..

Hi,

1)

interface Serial0/1/0:0

description ** T1 DATA CONNECTION TO BR1-RTR **

there is no frame route statement here but it should

2) HQ frame-relay interface has Cisco encapsulation but BR1 has got IETF so it won't work.

Regards.

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.

View solution in original post

Sorry for the late reply Alain...Yes it worked after I made both HQ and BR1 frame relay interfaces as IETF.

Thank you very much for your help !!!!!

Regards,

Ashraf