09-13-2021 04:50 AM
Hello, I need some serious help. I follow a video explaining how to set up frame relay but did no get the same results. I can ping the serial interface of each own's network but not other. I get Destination host unreachable. I will put the configs of each router below. Please let me know what I am doing wrong. If anything is missing please reach out. Im trying to get this done.
////////////////////////
West Router
interface GigabitEthernet0/0
ip address 10.20.1.1 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/1/0
bandwidth 64
ip address 12.22.2.2 255.255.255.252
encapsulation frame-relay
!
interface Serial0/1/1
no ip address
clock rate 2000000
shutdown
!
interface Vlan1
no ip address
shutdown
!
router rip
network 10.0.0.0
network 12.0.0.0
/////////////////////////
Small Router
interface GigabitEthernet0/0
ip address 10.45.1.1 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/1/0
bandwidth 64
ip address 24.24.1.2 255.255.255.252
encapsulation frame-relay
!
interface Serial0/1/1
no ip address
clock rate 2000000
shutdown
!
interface Vlan1
no ip address
shutdown
!
router rip
network 10.0.0.0
network 24.0.0.0
////////////////////////
East Router
interface GigabitEthernet0/0
ip address 10.10.1.1 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 10.10.2.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/1/0
bandwidth 64
ip address 12.24.1.2 255.255.255.252
encapsulation frame-relay
!
interface Serial0/1/1
no ip address
clock rate 2000000
shutdown
!
interface Vlan1
no ip address
shutdown
!
router rip
network 10.0.0.0
network 12.0.0.0
/////////////////////
Acct router
interface GigabitEthernet0/0
ip address 10.30.1.1 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 10.30.2.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/1/0
bandwidth 64
ip address 12.12.1.2 255.255.255.252
encapsulation frame-relay
!
interface Serial0/1/1
no ip address
clock rate 2000000
shutdown
!
interface Vlan1
no ip address
shutdown
!
router rip
network 10.0.0.0
network 12.0.0.0
////////////////////////////////
Solved! Go to Solution.
09-13-2021 05:52 AM - edited 09-13-2021 05:53 AM
If you are not using point to point sub-interfaces in frame relay, you have to map the DLCI to an IP address. A command something like this.
frame-relay map ip 172.16.200.101 20 broadcast
I prefer (and I believe it to be a best practice) to use point to point sub-interfaces. Something like this.
interface Serial0/0/0.1 point-to-point ip address 10.10.113.2 255.255.255.252 frame-relay interface-dlci 102
09-13-2021 09:26 AM
Sir, I just found out I can ping the other routers. I am going to set up eigrp rather than rip. I can only pin other routers using another router
09-13-2021 05:52 AM - edited 09-13-2021 05:53 AM
If you are not using point to point sub-interfaces in frame relay, you have to map the DLCI to an IP address. A command something like this.
frame-relay map ip 172.16.200.101 20 broadcast
I prefer (and I believe it to be a best practice) to use point to point sub-interfaces. Something like this.
interface Serial0/0/0.1 point-to-point ip address 10.10.113.2 255.255.255.252 frame-relay interface-dlci 102
09-13-2021 07:29 AM
I just now configured point-to-point and still receiving the same error. I can not get past the serial interface. Above is my frame relay map could you check if that is correct. I am lost
09-13-2021 07:36 AM
09-13-2021 09:26 AM
Sir, I just found out I can ping the other routers. I am going to set up eigrp rather than rip. I can only pin other routers using another router
09-13-2021 01:46 PM
I prefer EIGRP unless there is a reason to use RIP or OSPF so routes can be exchanged with non-cisco devices. You might be having problems because of auto summarization. You can turn that off in either the "router eigrp" of "router rip" section like this.
no auto-summary
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide